chiark / gitweb /
Debianization patch from upstream.
[python-cdb] / debian / rules
1 #!/usr/bin/make -f
2
3 export DH_COMPAT=3
4
5 configure: configure-stamp
6 configure-stamp:
7         dh_testdir
8         touch configure-stamp
9
10 build: configure-stamp build-stamp
11 build-stamp:
12         dh_testdir
13
14         python2.3 setup.py build
15
16         touch build-stamp
17
18 clean:
19         dh_testdir
20         dh_testroot
21         rm -f build-stamp configure-stamp
22
23         rm -rf build dist
24
25         dh_clean
26
27 install: build
28         dh_testdir
29         dh_testroot
30         dh_clean -k
31         dh_installdirs
32
33         python2.3 setup.py install --prefix=debian/python-cdb/usr
34
35 binary-indep: build install
36
37 binary-arch: build install
38         dh_testdir
39         dh_testroot
40         dh_installdocs
41         dh_installchangelogs ChangeLog
42         dh_link
43         dh_python
44         dh_strip
45         dh_compress
46         dh_fixperms
47         dh_installdeb
48         dh_shlibdeps
49         dh_gencontrol
50         dh_md5sums
51         dh_builddeb
52
53 binary: binary-indep binary-arch
54 .PHONY: build clean binary-indep binary-arch binary install configure