chiark / gitweb /
docs: Generate grammar and option summaries from manpage.
[fwd] / debian / rules
1 #! /usr/bin/make -f
2
3 export DH_COMPAT = 4
4
5 build:
6         rm -rf build deb-build
7         mkdir deb-build
8         cd deb-build; ../configure --prefix=/usr --mandir=/usr/share/man
9         make -C deb-build
10         touch build
11
12 clean:
13         dh_clean
14         rm -rf deb-build build
15
16 install: build
17         dh_clean
18         make -C deb-build install DESTDIR=`pwd`/debian/fw
19
20 binary-indep:
21
22 binary-arch: install
23         dh_testdir -a
24         dh_testroot -a
25         dh_compress -a
26         dh_installdocs -a GRAMMAR
27         dh_strip -a
28         dh_shlibdeps -a
29         dh_gencontrol -a
30         dh_fixperms -a
31         dh_installdeb -a
32         dh_md5sums -a
33         dh_builddeb -a
34
35 binary: binary-indep binary-arch
36
37 source:
38         rm -rf deb-build/*.tar.gz deb-build/=deb=
39         make -C deb-build dist
40         mkdir deb-build/=deb=
41         cd deb-build/=deb=; tar xvfz ../*.tar.gz
42         d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
43         rm -rf deb-build/=deb=
44
45 .PHONY: binary binary-arch binary-indep clean install source