chiark / gitweb /
Merge remote-tracking branch 'origin/HEAD'
[catacomb-python] / debian / changelog
1 catacomb-python (1.2.1) experimental; urgency=low
2
3   * Fix use-after-free bug in ECPt hashing causing hash instability.
4   * Fix keywrd argument mismatch in ECDSAPriv.
5   * Coerce DSA private key values to `MP'.
6
7  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 16 Jun 2017 01:01:05 +0100
8
9 catacomb-python (1.2.0) experimental; urgency=low
10
11   * Bindings for HSalsa20 and HChaCha PRFs.
12   * Bindings for Poly1305.
13   * Bindings for X25519.
14   * Bindings for X448.
15   * Bindings for Ed25519.
16   * Bindings for Ed448.
17   * Bindings for Keccak[1600, n].
18   * Bindings for cSHAKE; Python implementation of KMAC.
19   * Improved pretty-printing for IPython.
20   * Allow selection of public exponent when generating RSA keys.
21
22  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 17:29:53 +0100
23
24 catacomb-python (1.1.2) experimental; urgency=low
25
26   * Further 64-bit compatibility improvements.
27   * Fixed docstrings for a number of native methods.
28   * Fix range checking for `GRand' methods.
29   * Fix crash when deleting natively implemented object attributes.
30   * Fix bug which assigned the wrong hash to bytestrings.
31   * Fix `__int__' methods to return `long' objects when necessary.
32     Without this, there are unnecessary failures and bizarrely timed
33     exceptions.
34   * A couple of patches to provide forward compatibility with upstream
35     library changes.
36
37  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:25:35 +0100
38
39 catacomb-python (1.1.1) experimental; urgency=low
40
41   * ByteString operators: fix crashes on 64-bit platforms resulting from
42     the use of the wrong length types.
43
44  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:17:14 +0100
45
46 catacomb-python (1.1.0.1) experimental; urgency=low
47
48   * Just Debian packaging fixes.
49
50  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 19:39:28 +0000
51
52 catacomb-python (1.1.0) experimental; urgency=low
53
54   * Fix crash on trying to import RSA public and private keys with even
55     modulus.
56   * Add bindings for key-strength conversion functions.
57   * Add bindings for factorial and Fibonacci calculations.
58   * Implement exact field-of-fractions arithmetic for integers and binary
59     polynomials.
60   * Set module nameson types properly, so that IPython doesn't choke on
61     printing them.
62   * Implement hashing for comparable types.  Again, this makes IPython
63     work better.
64   * Support Daniel Bernstein's Salsa20 and ChaCha stream ciphers.
65   * Stop abusing SyntaxError.
66   * Support elliptic curve point compression formats.
67   * Major overhaul of the `pwsafe' utility: multiple storage backends, so
68     (a) we no longer require GDBM, and (b) we can use a Git-friendly
69     directory-based format.  Or SQLite.
70
71  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 16:07:51 +0100
72
73 catacomb-python (1.0.6) experimental; urgency=low
74
75   * Fix stupid bug in WriteBuffer resizing.
76
77  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 21 Jul 2013 15:57:06 +0100
78
79 catacomb-python (1.0.5) experimental; urgency=low
80
81   * Make Key constructor actually work.
82   * Include human-readable text in KeyError exceptions.
83
84  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jan 2014 01:38:26 +0000
85
86 catacomb-python (1.0.4) experimental; urgency=low
87
88   * Build against Python 2.7.
89
90  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 02:47:59 +0000
91
92 catacomb-python (1.0.3) experimental; urgency=low
93
94   * Remove catacomb-python-bin package, because it made building hard and
95     didn't provide any noticeable benefits.
96
97  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 05 Nov 2010 15:12:35 +0000
98
99 catacomb-python (1.0.2) experimental; urgency=low
100
101   * Overhaul build system with new support module.
102
103  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 04 Oct 2009 14:17:20 +0100
104
105 catacomb-python (1.0.1) experimental; urgency=low
106
107   * Make it work with Python 2.6.  Also switched over to the (increasingly
108     winning) CDBS.
109
110  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 03 Oct 2009 23:06:29 +0100
111
112 catacomb-python (1.0.0) experimental; urgency=low
113
114   * Debianization!
115
116  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 26 Sep 2005 11:27:00 +0100