chiark / gitweb /
.gdbinit: Delete this obsolete file.
[catacomb-python] / debian / changelog
1 catacomb-python (1.3.99~) experimental; urgency=medium
2
3   * (placeholder for next release)
4
5  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 01 Oct 2019 12:57:58 +0100
6
7 catacomb-python (1.3.0.1) experimental; urgency=medium
8
9   * Fix required Catacomb version in `setup.py' script.  Only affects the
10     source package.
11
12  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 22 Sep 2019 01:21:28 +0100
13
14 catacomb-python (1.3.0) experimental; urgency=medium
15
16   * catacomb: Bindings for new blockcipher-based MACs, and AEAD schemes.
17   * catacomb: Invalidate `grand' objects passed into Python through prime-
18     generation events.
19   * catacomb: Improve class docstrings.  (They're still extremely terse.)
20   * catacomb: Add missing `copy' methods on hash and Keccak objects.
21   * catacomb: Add `WriteBuffer.contents' as a more convenient way to
22     extract the contents than coercing to `str' or `ByteString'.
23   * catacomb: Set `RTLD_DEEPBIND' while loading the native module to work
24     around #868366.
25   * pock: New program for generating efficiently verifiable prime numbers,
26     and for verifying their certificates.
27
28  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 23:00:25 +0100
29
30 catacomb-python (1.2.1.1) experimental; urgency=medium
31
32   * Fixing to build against Debian `stretch'.
33
34  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 24 Dec 2018 15:21:08 +0000
35
36 catacomb-python (1.2.1) experimental; urgency=low
37
38   * Fix use-after-free bug in ECPt hashing causing hash instability.
39   * Fix keywrd argument mismatch in ECDSAPriv.
40   * Coerce DSA private key values to `MP'.
41
42  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 16 Jun 2017 01:01:05 +0100
43
44 catacomb-python (1.2.0) experimental; urgency=low
45
46   * Bindings for HSalsa20 and HChaCha PRFs.
47   * Bindings for Poly1305.
48   * Bindings for X25519.
49   * Bindings for X448.
50   * Bindings for Ed25519.
51   * Bindings for Ed448.
52   * Bindings for Keccak[1600, n].
53   * Bindings for cSHAKE; Python implementation of KMAC.
54   * Improved pretty-printing for IPython.
55   * Allow selection of public exponent when generating RSA keys.
56
57  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 17:29:53 +0100
58
59 catacomb-python (1.1.2) experimental; urgency=low
60
61   * Further 64-bit compatibility improvements.
62   * Fixed docstrings for a number of native methods.
63   * Fix range checking for `GRand' methods.
64   * Fix crash when deleting natively implemented object attributes.
65   * Fix bug which assigned the wrong hash to bytestrings.
66   * Fix `__int__' methods to return `long' objects when necessary.
67     Without this, there are unnecessary failures and bizarrely timed
68     exceptions.
69   * A couple of patches to provide forward compatibility with upstream
70     library changes.
71
72  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:25:35 +0100
73
74 catacomb-python (1.1.1) experimental; urgency=low
75
76   * ByteString operators: fix crashes on 64-bit platforms resulting from
77     the use of the wrong length types.
78
79  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:17:14 +0100
80
81 catacomb-python (1.1.0.1) experimental; urgency=low
82
83   * Just Debian packaging fixes.
84
85  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 19:39:28 +0000
86
87 catacomb-python (1.1.0) experimental; urgency=low
88
89   * Fix crash on trying to import RSA public and private keys with even
90     modulus.
91   * Add bindings for key-strength conversion functions.
92   * Add bindings for factorial and Fibonacci calculations.
93   * Implement exact field-of-fractions arithmetic for integers and binary
94     polynomials.
95   * Set module nameson types properly, so that IPython doesn't choke on
96     printing them.
97   * Implement hashing for comparable types.  Again, this makes IPython
98     work better.
99   * Support Daniel Bernstein's Salsa20 and ChaCha stream ciphers.
100   * Stop abusing SyntaxError.
101   * Support elliptic curve point compression formats.
102   * Major overhaul of the `pwsafe' utility: multiple storage backends, so
103     (a) we no longer require GDBM, and (b) we can use a Git-friendly
104     directory-based format.  Or SQLite.
105
106  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 16:07:51 +0100
107
108 catacomb-python (1.0.6) experimental; urgency=low
109
110   * Fix stupid bug in WriteBuffer resizing.
111
112  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 21 Jul 2013 15:57:06 +0100
113
114 catacomb-python (1.0.5) experimental; urgency=low
115
116   * Make Key constructor actually work.
117   * Include human-readable text in KeyError exceptions.
118
119  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jan 2014 01:38:26 +0000
120
121 catacomb-python (1.0.4) experimental; urgency=low
122
123   * Build against Python 2.7.
124
125  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 02:47:59 +0000
126
127 catacomb-python (1.0.3) experimental; urgency=low
128
129   * Remove catacomb-python-bin package, because it made building hard and
130     didn't provide any noticeable benefits.
131
132  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 05 Nov 2010 15:12:35 +0000
133
134 catacomb-python (1.0.2) experimental; urgency=low
135
136   * Overhaul build system with new support module.
137
138  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 04 Oct 2009 14:17:20 +0100
139
140 catacomb-python (1.0.1) experimental; urgency=low
141
142   * Make it work with Python 2.6.  Also switched over to the (increasingly
143     winning) CDBS.
144
145  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 03 Oct 2009 23:06:29 +0100
146
147 catacomb-python (1.0.0) experimental; urgency=low
148
149   * Debianization!
150
151  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 26 Sep 2005 11:27:00 +0100