chiark / gitweb /
Build-Depends: move tcl-dev to the end, so that we prefer tcl8.4-dev. This is necessa...
[chiark-tcl.git] / debian / rules
index 9a62e2b8809713e1f28fda735c8a5bf6c51e607b..faa763a91b3e1456da41e07357b9a82e80f2e757 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 # chiark-tcl - various Tcl bindings and extensions
-# Copyright 2006 Ian Jackson
+# Copyright 2006-2012 Ian Jackson
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License as
@@ -14,9 +14,7 @@
 # General Public License for more details.
 #
 # You should have received a copy of the GNU General Public License
-# along with this library; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-# 02110-1301, USA.
+# along with this library; if not, see <http://www.gnu.org/licenses/>.
 
 
 majversion=1
@@ -32,10 +30,13 @@ define checkdir
        test -f hbytes/hbytes.tct
 endef
 
-build:
+build: build-arch build-indep
+build-arch:
        $(checkdir)
        $(MAKE) prefix=/usr VERSION=$(majversion) TCL_VERSION=$(tclversion)
 
+build-indep:
+
 clean:
        $(checkdir)
        $(MAKE) clean