chiark / gitweb /
Build-Depends: move tcl-dev to the end, so that we prefer tcl8.4-dev. This is necessa...
authorIan Jackson <ijackson@chiark.greenend.org.uk>
Sun, 9 Nov 2014 12:44:17 +0000 (12:44 +0000)
committerIan Jackson <ijackson@chiark.greenend.org.uk>
Sun, 9 Nov 2014 12:44:17 +0000 (12:44 +0000)
debian/changelog
debian/control

index b0b4e5e..b2142f3 100644 (file)
@@ -1,6 +1,9 @@
 chiark-tcl (1.1.2~) unstable; urgency=low
 
   * tuntap: Use <net/if.h> not <linux/if.h>.  Closes:#768766.  (FTBFS)
+  * Build-Depends: move tcl-dev to the end, so that we prefer tcl8.4-dev.
+    This is necessary because we want to build against tcl8.4 in jessie
+    to avoid requiring a newer Tcl ABI.
   * Reintroduce .gitignore which a build tool brokenly deleted.
   * Remove .cvsignore files from git repo.
 
index 7aa0918..5572639 100644 (file)
@@ -3,7 +3,7 @@ Maintainer: Ian Jackson <ijackson@chiark.greenend.org.uk>
 Priority: optional
 Section: interpreters
 Standards-Version: 3.9.1
-Build-Depends: libadns1-dev (>= 1.2), nettle-dev, libcdb-dev | tinycdb (<= 0.75), tcl-dev | tcl8.4-dev | tcl8.3-dev | tcl8.2-dev, debhelper (>= 5)
+Build-Depends: libadns1-dev (>= 1.2), nettle-dev, libcdb-dev | tinycdb (<= 0.75), tcl8.4-dev | tcl8.3-dev | tcl8.2-dev | tcl-dev, debhelper (>= 5)
 
 Package: libtcl-chiark-1
 Architecture: any