chiark / gitweb /
tcmdifgen: Replace deprecated `use IO;' with `use IO::File'.
[chiark-tcl.git] / debian / control
index 8e4dcc7015826532fa5f6ffb3062bb7782286d6a..9465cb17eab325e0bf15d18ac5d365b16e6b94a0 100644 (file)
@@ -2,26 +2,30 @@ Source: chiark-tcl
 Maintainer: Ian Jackson <ijackson@chiark.greenend.org.uk>
 Priority: optional
 Section: interpreters
-Standards-Version: 3.6.2
-Build-Depends: libadns1-dev (>= 1.2), nettle-dev, libcdb-dev | tinycdb (<= 0.75), tcl8.4-dev | tcl8.3-dev | tcl8.2-dev, debhelper (>= 3)
+Standards-Version: 3.9.1
+Build-Depends: libadns1-dev (>= 1.2), nettle-dev, libcdb-dev | tinycdb (<= 0.75), tcl8.6-dev | tcl8.5-dev | tcl8.4-dev | tcl8.3-dev | tcl8.2-dev | tcl-dev, debhelper (>= 5)
 
 Package: libtcl-chiark-1
 Architecture: any
 Description: Tcl interfaces for adns, cdb, crypto, etc.
  Tcl bindings for:
   * adns (resolver library)
-  * cdb (constant database) plus journalling writeable database
+  * cdb (constant database) plus journalling writable database
   * crypto: the nettle cryptographic library
   * hbytes: bytestrings with hex as string representation but efficient
+  * dgram: datagram sockets
+  * tuntap: tun/tap interfaces
+  * maskmap: address masks and maps
  To make sensible use of these you will need a version of Tcl installed
  (this package is compatible with at least Tcl 8.0 to 8.4 inclusive).
  To use the adns and nettle bindings you need to have the
  appropriate libraries installed too.
 Depends: ${shlibs:Depends}, ${misc:Depends}
+Multi-arch: same
 
 
 # chiark-tcl - various Tcl bindings and extensions
-# Copyright 2006 Ian Jackson
+# Copyright 2006-2012 Ian Jackson
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License as
@@ -34,6 +38,4 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
 # General Public License for more details.
 #
 # You should have received a copy of the GNU General Public License
-# along with this library; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-# 02110-1301, USA.
+# along with this library; if not, see <http://www.gnu.org/licenses/>.