PuTTY artifact sshcrcda-assertion-failed

Home | FAQ | Feedback | Licence | Updates | Mirrors | Keys | Links | Team
Download: Stable · Pre-release · Snapshot | Docs | Changes | Wishlist

summary: Failed assertion in sshcrcda.c
present-in: 0.52 0.53 0.53b

From comp.security.ssh:

I was running putty.exe version 52 and then I tried version 53 using a
local L119 to news.host.com:119 tunnel to pull news across with Forte
Agent.  I ended up getting this assert from putty.exe (this is version
53):

Microsoft Visual C++ Runtime Library
========================================
Assertion failed!

Program: ...Users\Documents\Downloads\SSH\Putty\putty.exe
File: sshcrcda.c
Line: 98

Expression: !(len > (SSH_MAXBLOCKS * SSH_BLOCKSIZE) || len % SSH_BLOCKSIZE != 0)

Just thought I'd let you know.


If you want to comment on this web site, see the Feedback page.
Audit trail for this artifact.
(last revision of this bug record was at 2003-01-06 22:24:05 +0000)