chiark / gitweb /
Debianization\!
[xtoys] / debian / rules
1 #! /usr/bin/make -f
2
3 build:
4         rm -rf deb-build build; mkdir deb-build
5         cd deb-build; ../configure --prefix=/usr --mandir=/usr/share/man
6         make -C deb-build
7         touch build
8
9 clean:
10         dh_clean
11         rm -rf deb-build build
12
13 install: build
14         dh_clean
15         for i in xscsize xwait xtell; do \
16                 dh_install -p xtoys deb-build/$$i usr/bin; \
17                 dh_installman -p xtoys $$i.1; \
18         done
19         for i in xcatch xgetline xmsg xshutdown; do \
20                 dh_install -p xtoys-gtk deb-build/$$i usr/bin; \
21                 dh_installman -p xtoys-gtk $$i.1; \
22         done
23         dh_strip -a
24
25 binary-indep:
26
27 binary-arch: install
28         dh_testdir -a
29         dh_testroot -a
30         dh_compress -a
31         dh_installdocs -a
32         dh_shlibdeps -a
33         dh_gencontrol -a
34         dh_fixperms -a
35         dh_installdeb -a
36         dh_md5sums -a
37         dh_builddeb -a
38
39 binary: binary-indep binary-arch
40
41 source:
42         rm -rf deb-build/*.tar.gz deb-build/=deb=
43         make -C deb-build dist
44         mkdir deb-build/=deb=
45         cd deb-build/=deb=; tar xvfz ../*.tar.gz
46         d=`pwd`; cd ..; dpkg-source -i -b $$d/deb-build/=deb=/*
47         rm -rf deb-build/=deb=
48
49 .PHONY: binary binary-arch binary-indep clean install source