chiark / gitweb /
Documentation restructuring: provide a useful overview.
[tripe] / debian / rules
1 #! /usr/bin/make -f
2
3 CDBS = /usr/share/cdbs/1
4
5 include $(CDBS)/rules/debhelper.mk
6 include $(CDBS)/class/autotools.mk
7
8 ###--------------------------------------------------------------------------
9 ### General settings.
10
11 DEB_BUILDDIR = $(CURDIR)/build
12 DEB_MAKE_BUILD_TARGET = all html pdf
13 DEB_MAKE_INSTALL_TARGET = \
14         install install-html install-pdf \
15         DESTDIR=$(CURDIR)/debian/tmp/
16 DEB_MAKE_CHECK_TARGET = check
17
18 ###--------------------------------------------------------------------------
19 ### Correct configuration.
20
21 ## This will need changing on other kernels.
22 default_tunnel = linux
23
24 ## Configuration arguments.
25 DEB_CONFIGURE_EXTRA_FLAGS = \
26         --with-tunnel="$(default_tunnel) slip" \
27         --with-configdir="/etc/tripe" \
28         --with-socketdir="/var/run" \
29         --with-logfile="/var/log/tripe/tripe.log" \
30         --with-pidfile="/var/run/tripectl.pid" \
31         --with-initconfig="/etc/default/tripe" \
32         --with-wireshark="/usr/lib/wireshark/libwireshark0/plugins"
33
34 ###--------------------------------------------------------------------------
35 ### Python.
36
37 binary-install/python-tripe::
38         dh_pycentral -ppython-tripe
39
40 ###--------------------------------------------------------------------------
41 ### Install the startup scripts.
42
43 install/tripe::
44         cp $(DEB_BUILDDIR)/init/tripe-init debian/tripe.init
45         sed 's/^#\(user\|group\)/\1/' \
46                 $(DEB_SRCDIR)/init/tripe.conf >debian/tripe.default
47
48 cleanbuilddir::
49         rm -f debian/tripe.init debian/tripe.default
50
51 ###--------------------------------------------------------------------------
52 ### Install configuration files.
53
54 install/tripe-peer-services::
55         install -m644 $(DEB_SRCDIR)/peerdb/peers.in \
56                 debian/tripe-peer-services/etc/tripe/peers.d/10base
57
58 ###--------------------------------------------------------------------------
59 ### Wireshark plugin.
60
61 ## Grab the version we built against, so we can put it in the dependencies.
62 install/tripe-wireshark::
63         dpkg --status wireshark | \
64                 sed -n 's/^Version: */tripe:Wireshark-Version=/p' \
65                 >> debian/tripe-wireshark.substvars
66
67 ## Don't track dependencies for the plugin.  We have it covered already.
68 DEB_DH_SHLIBDEPS_ARGS_tripe-wireshark += -Xwireshark/plugins
69
70 ###----- That's all, folks --------------------------------------------------