chiark / gitweb /
Debianize new mup version
[mup] / mup / debian / rules
1 #! /usr/bin/make -f
2
3 export DH_COMPAT = 4
4
5 clean:
6         dh_testdir
7         dh_clean
8         make clobber
9         rm -f build
10
11 build:
12         make
13         touch build
14
15 install: build
16         dh_clean
17         make install PREFIX=`pwd`/debian/tmp/usr
18         dh_install --sourcedir=debian/tmp
19
20 binary-indep: install
21         dh_testdir -i
22         dh_testroot -i
23         dh_installdocs -i
24         dh_compress -i
25         dh_fixperms -i
26         dh_installdeb -i
27         dh_gencontrol -i
28         dh_md5sums -i
29         dh_builddeb -i
30
31 binary-arch: install
32         dh_testdir -a
33         dh_testroot -a
34         dh_installdocs -a
35         dh_compress -a
36         dh_fixperms -a
37         dh_installdeb -a
38         dh_shlibdeps -a
39         dh_gencontrol -a
40         dh_md5sums -a
41         dh_builddeb -a
42
43 binary: binary-indep binary-arch
44
45 .PHONY: clean install binary-indep binary-arch binary