chiark / gitweb /
Release 2.6.0.
[catacomb] / debian / changelog
1 catacomb (2.6.0) experimental; urgency=medium
2
3   * catacomb: Introduce Mike Hamburg's `STROBE' syymetric encryption
4     framework, based on Keccak.
5   * catacomb: Fix KCDSA prime generation so that it makes primes of
6     exactly the right length.  I think this is the last of the prime-
7     generation algorthms that needs fixing.
8   * catacomb: Inttroduce low-level key-file functions to accommodate
9     Python 3 bindings.
10   * catacomb: Support `tag:', `id:' and `type:' prefixes in `bytag' key
11     queries.
12   * catacomb-bin: Be consistent about metasyntax used to denote hash
13     function names.
14   * catacomb: Introduce fast SIMD multiplication for ARM32 and ARM64
15     platforms.  I think this finally means that X86 and ARM have similar
16     levels of optimization.
17   * catacomb: Check SIMD feature bit on ARM64 before using the optimized
18     code.  I don't know of any ARM64 implementations which lack SIMD
19     instructions, but the bit must be there for a reason, so I might as
20     well use it.
21   * catacomb-dev: Allow reading the current number of passes from a
22     `dsarand' object.
23   * catacomb: Prefer X84 `rdseed' instruction for quick entropy over
24     `rdrand' if it's available.
25
26  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 17:38:45 +0100
27
28 catacomb (2.5.2) experimental; urgency=medium
29
30   * Merge changes from 2.4.5.
31   * catacomb-dev: Fix ARM32 FP/SIMD register dumping.
32
33  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 20:50:57 +0100
34
35 catacomb (2.5.1) experimental; urgency=medium
36
37   * Merge changes from 2.4.4.
38
39  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 17:50:59 +0100
40
41 catacomb (2.5.0) experimental; urgency=medium
42
43   * catacomb: MACs based on blockciphers: PMAC1 and CMAC (also known as
44     OMAC).
45   * catacomb: Authenticated Encryption with Additional Data (AEAD)
46     schemes.  Some based on blockciphers: CCM, EAX, GCM (with CPU-specific
47     acceleration), OCB1 and OCB3 (OCB2 is broken).  Also Salsa20 and
48     ChaCha20 with Poly1305: the RFC7539 scheme, and the NaCl `secret_box'
49     transform.
50   * catacomb: Implement Grantham's Frobenius test.  Combine it with
51     Rabin--Miller, as Baillie--PSW, for testing given primes.
52   * catacomb-bin (catcrypt): Support AEAD schemes for bulk crypto.
53   * catacomb-bin (perftest): Options for batching; report cycle counts
54     where available.
55   * Many internal improvements: better documentation, debugging, testing,
56     etc.
57
58  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 21:26:44 +0100
59
60 catacomb (2.4.5) experimental; urgency=medium
61
62   * catacomb: Fix memory leak in key-file error handling.
63   * catacomb: Don't leak internal `exptime' symbol into the global
64     namespace.
65   * catacomb: Check that the X86 `rdrand' instruction actually works
66     before leaning on it.  This is in response to the well-publicized AMD
67     bug which always returns all-bits-set with the carry /set/ (indicating
68     success).
69   * catacomb: Mix in the random pool key during `rand_gate' and
70     `rand_stretch' operations.
71   * catacomb: Fix by-tag key lookups: if the query string looks like a hex
72     number, it's treated as a search by id; but if no such id is found,
73     the search wouldn't continue to look for a key by type or tag.
74   * catacomb: Fix reference leak in `key_split'.
75   * catacomb: Fix bug which completely broke `key_copydata'.
76   * catacomb: Fix segfault from `pgen', if it fails before setting up the
77     prime tester.
78   * catacomb: Propagate failure from `pgen' during Lim--Lee prime
79     generation, rather than immediately retrying.
80   * catacomb: Fix memory leak of factor vector from failed Lim--Lee prime
81     generation.
82   * catacomb: Fix segfault when multiplying the identity elliptic-curve
83     point.
84   * catacomb: Fix the `lcrand' descriptor, so that it's not advertised as
85     being cryptographically strong, and to fix a bias in its output.
86   * catacomb: Fix a memory leak in the error case of KCDSA prime
87     generation.
88   * catacomb-bin: Fix segfault from `pixie', if given an empty passphrase
89     to remember.
90   * catacomb: Check SIMD feature bit on ARM64 before using the optimized
91     code.  I don't know of any ARM64 implementations which lack SIMD
92     instructions, but the bit must be there for a reason, so I might as
93     well use it.
94   * catacomb: Support parsing binary-group descriptions.  This is a long-
95     standing lacuna that I've only recently noticed.
96
97  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 17:46:24 +0100
98
99 catacomb (2.4.4) experimental; urgency=medium
100
101   * debian: Bump to Debhelper 10.
102   * debian: Ship a shared-library `symbols' file for more precise
103     dependencies.
104
105  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 15:58:26 +0100
106
107 catacomb (2.4.3) experimental; urgency=medium
108
109   * catacomb (idea): Fix key-length descriptor.
110   * catacomb (xchachaNN): Fix nonce-size descriptor.
111   * catacomb (key-management): Fix incorrect handling of keyring
112     modifiability.
113   * catacomb-dev: Configure `pkg-config' correctly for static linking.
114   * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
115     padding on very long messages, and handling of large datestamps.
116   * catacomb-bin (catsign): Don't open temporary files unnecessarily.
117   * catacomb-bin (catcrypt): Fix key-attribute parsing.
118   * catacomb-bin (perftest): Add missing help-string text for `-n' used
119     with `enc' and `hash'
120
121  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 17:43:59 +0100
122
123 catacomb (2.4.2) experimental; urgency=medium
124
125   * catacomb2: Support multi-arch at last.
126   * catacomb2: Fix mangled key-size data for HMAC.
127   * rspit: Support generating large files.
128   * pixie: Improve error-handling around dropping privilege.
129   * ed25519, ed448: Very minor performance improvement.
130   * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
131     `rspit'.
132   * salsa20, chacha: Fix declaration of cipher classes to prevent them
133     ending up as (useless) common symbols in client code.
134   * limlee: Improve the prime size heuristics.
135   * sha, sha256, sha512: Restructure compression function to improve
136     performance and use less memory.
137   * rijndael: Include enough round constants to make very tiny keys work
138     correctly.
139
140  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 01:15:59 +0100
141
142 catacomb (2.4.1) experimental; urgency=low
143
144   * catacomb2: Two's-complement fix from 2.3.x release branch.
145
146  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:37:40 +0100
147
148 catacomb (2.4.0.1) experimental; urgency=low
149
150   * Fix build failure with later ARM assemblers.
151
152  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
153
154 catacomb (2.4.0) experimental; urgency=low
155
156   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
157     code.
158   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
159     and Salsa20.
160   * catacomb2: Implement Bernstein's X25519.
161   * catacomb2: Implement Hamburg's X448 (RFC7748).
162   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
163     as defined in RFC8032.
164   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
165     RFC8032.
166   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
167   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
168   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
169   * catacomb2: Allow RSA key generation with chosen public exponent.
170   * catacomb2: Optimize RSA public-key operations with common public
171     exponents.
172   * catacomb-bin: Support new algorithms in the provided tools.
173   * catacomb-bin: Allow parameters keys for all key types.
174
175  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
176
177 catacomb (2.3.2) experimental; urgency=low
178
179   * catacomb2: Fix bignum loading and storing in two's complement form.
180
181  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
182
183 catacomb (2.3.1) experimental; urgency=low
184
185   * catacomb2: Fix memory corruption when allocating `salsa20' and
186     `chacha'-based RNGs.
187   * catacomb2: Fix segfault when opening read-only keyring with no
188     associated file.
189   * catacomb2: Return the correct stream offset in `chacha_tell*'.
190   * catacomb2: Produce correct keyring files when they contain empty
191     keys.
192   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
193     and binary group implementations.
194   * catacomb-dev: Add missing licence notices to `salsa20.h'.
195   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
196   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
197     verifying.
198   * catacomb-bin: Compare MAC tags in constant time.
199   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
200
201  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
202
203 catacomb (2.3.0.1) experimental; urgency=low
204
205   * catacomb2: Actually make the stack non-executable rather than just
206     pretending.
207
208  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
209
210 catacomb (2.3.0) experimental; urgency=low
211
212   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
213     was a duplicate of the Oakley 1536 group.  There's a compatibility
214     break here, but it's for the best.
215   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
216     so that the process stack doesn't get marked executable.
217   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
218   * catacomb2: Lots of other improvements to the assembler code.
219
220  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
221
222 catacomb (2.2.5) experimental; urgency=low
223
224   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
225     is unaligned.
226   * build: Use less obsolete macro names in configure script.
227
228  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
229
230 catacomb (2.2.4) experimental; urgency=low
231
232   * build: Fix build failures on post-wheezy Debian versions.
233   * catacomb2: Use ARM AES instructions if available.  (But they can't be
234     assembled using wheezy's version of gas, so this doesn't work in the
235     binary package.)
236   * catacomb2: Fix poor performance (and wrong answers for very small
237     numbers) in prime generation.
238   * catacomb2: Return numbers of exactly the requested length in prime and
239     public-key generation.  The `strongprime' and `limlee' algorithms have
240     changed as a result; previously verifiable parameters generated using
241     this algorithm won't be verifiable any more.
242   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
243
244  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
245
246 catacomb (2.2.3) experimental; urgency=low
247
248   * rand: Make the main generator resiliant in the face of fork(2).
249   * rand: Introduce `rand_quick', which may also mix in CPU-level
250     randomness sources.
251   * rand: Use higher-resolution timer in the quick-win noise source.
252   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
253     which got lost down the side of the sofas.
254
255  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
256
257 catacomb (2.2.2) experimental; urgency=low
258
259   * build: Cope with newer Autotools and related equipment.
260   * Miscellaneous small fixes for Cygwin.
261   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
262     particularly, this causes a segfault reading bit zero of a zero-length
263     integer.
264
265  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
266
267 catacomb (2.2.1.1) experimental; urgency=low
268
269   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
270     really won't work well without it.
271
272  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
273
274 catacomb (2.2.1) experimental; urgency=low
275
276   * Some internal improvements.
277   * Debian packaging cleanups (fix build-depends, update mLib dependency).
278
279  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
280
281 catacomb (2.2.0) experimental; urgency=low
282
283   * catacomb2: Fix rsa_recover crash on even modulus.
284   * catacomb-bin: Report error taking factorial of negative input.
285   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
286   * catacomb-dev: Support multiple flavours of EC point compression.
287   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
288     out of prime numbers.
289   * catacomb2: Overhaul crypto primitives used in true-random generator.
290   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
291     support.
292   * catacomb-dev: New conversions between MP integers and C integer types.
293   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
294     big-endian bytes (rather than `uint32'), and the `block size' is 4.
295   * catacomb2: Mix a constant string into DSA nonce generation to improve
296     resistance to protocol interference.
297   * catacomb2: Fix the freewheel random source, which hasn't been enabled
298     for ages due to a configure-script bug.
299   * catacomb-bin: The key tool can now read and write multiple
300     presentations for key fingerprints.
301   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
302     stream ciphers.
303
304  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
305
306 catacomb (2.1.7) experimental; urgency=low
307
308   * A number of entropy-source fixes.
309   * Internal tidying.
310   * Add more elliptic curves, from Brainpool and BADA55.
311   * hashsum: Fix hash file verification.
312
313  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
314
315 catacomb (2.1.6.1) experimental; urgency=low
316
317   * Fix building from source tarball.
318   * Fix building with Python 2.5.
319
320  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
321
322 catacomb (2.1.6) experimental; urgency=low
323
324   * mpreduce: Extend domain to all positive integers.
325   * gfreduce: Fix out-of-bounds memory access.
326   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
327   * pixie: Don't replace existing pixie unless explicitly requested.
328
329  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
330
331 catacomb (2.1.5) experimental; urgency=low
332
333   * New build system.
334
335  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
336
337 catacomb (2.1.4) experimental; urgency=low
338
339   * Constant-time operations.
340   * Some minor fixes to header files.
341
342  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
343
344 catacomb (2.1.3) experimental; urgency=low
345
346   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
347     example program.
348   * Upper bounds on phrase entropy in mkphrase(1).
349   * Don't make the Pixie setuid-root by default.  Make the documentation
350     less scary.
351
352  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
353
354 catacomb (2.1.2.1) experimental; urgency=low
355
356   * hashsum: Document `--progress' option in `--help' output.
357
358  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
359
360 catacomb (2.1.2) experimental; urgency=low
361
362   * hashsum: Correct return code when running in `-c' mode.
363   * dsig: Fix core dump on large-ish outputs.
364   * dsig: Fix repeat-close bug.
365   * dsig: Accept precomputed hashes when making signatures.
366   * Utilities: New `-p' option for progress bars.
367   * dsig, hashsum: New `-j' option checks for files not covered by
368     manifest.
369   * Various library improvements.
370
371  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
372
373 catacomb (2.1.1) experimental; urgency=low
374
375   * Do configuration through pkgconfig.
376
377  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
378
379 catacomb (2.1.0) experimental; urgency=low
380
381   * Added support for elliptic curves, on both prime and binary fields
382     (polynomial basis only).  No actual crypto, but there's enough already
383     to do ECDH and stuff on well-known curves  Testing is currently a bit
384     patchy.
385
386  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
387
388 catacomb (2.0.1) experimental; urgency=low
389
390   * Debianization!
391   * (pixie): Don't report uninteresting errors when accepting connections.
392
393  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000