chiark / gitweb /
pubkey.c (dsa_setup): Make sure `u' is None or an MP object.
[catacomb-python] / debian / changelog
1 catacomb-python (1.2.0) experimental; urgency=low
2
3   * Bindings for HSalsa20 and HChaCha PRFs.
4   * Bindings for Poly1305.
5   * Bindings for X25519.
6   * Bindings for X448.
7   * Bindings for Ed25519.
8   * Bindings for Ed448.
9   * Bindings for Keccak[1600, n].
10   * Bindings for cSHAKE; Python implementation of KMAC.
11   * Improved pretty-printing for IPython.
12   * Allow selection of public exponent when generating RSA keys.
13
14  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 17:29:53 +0100
15
16 catacomb-python (1.1.2) experimental; urgency=low
17
18   * Further 64-bit compatibility improvements.
19   * Fixed docstrings for a number of native methods.
20   * Fix range checking for `GRand' methods.
21   * Fix crash when deleting natively implemented object attributes.
22   * Fix bug which assigned the wrong hash to bytestrings.
23   * Fix `__int__' methods to return `long' objects when necessary.
24     Without this, there are unnecessary failures and bizarrely timed
25     exceptions.
26   * A couple of patches to provide forward compatibility with upstream
27     library changes.
28
29  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:25:35 +0100
30
31 catacomb-python (1.1.1) experimental; urgency=low
32
33   * ByteString operators: fix crashes on 64-bit platforms resulting from
34     the use of the wrong length types.
35
36  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:17:14 +0100
37
38 catacomb-python (1.1.0.1) experimental; urgency=low
39
40   * Just Debian packaging fixes.
41
42  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 19:39:28 +0000
43
44 catacomb-python (1.1.0) experimental; urgency=low
45
46   * Fix crash on trying to import RSA public and private keys with even
47     modulus.
48   * Add bindings for key-strength conversion functions.
49   * Add bindings for factorial and Fibonacci calculations.
50   * Implement exact field-of-fractions arithmetic for integers and binary
51     polynomials.
52   * Set module nameson types properly, so that IPython doesn't choke on
53     printing them.
54   * Implement hashing for comparable types.  Again, this makes IPython
55     work better.
56   * Support Daniel Bernstein's Salsa20 and ChaCha stream ciphers.
57   * Stop abusing SyntaxError.
58   * Support elliptic curve point compression formats.
59   * Major overhaul of the `pwsafe' utility: multiple storage backends, so
60     (a) we no longer require GDBM, and (b) we can use a Git-friendly
61     directory-based format.  Or SQLite.
62
63  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 16:07:51 +0100
64
65 catacomb-python (1.0.6) experimental; urgency=low
66
67   * Fix stupid bug in WriteBuffer resizing.
68
69  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 21 Jul 2013 15:57:06 +0100
70
71 catacomb-python (1.0.5) experimental; urgency=low
72
73   * Make Key constructor actually work.
74   * Include human-readable text in KeyError exceptions.
75
76  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jan 2014 01:38:26 +0000
77
78 catacomb-python (1.0.4) experimental; urgency=low
79
80   * Build against Python 2.7.
81
82  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 02:47:59 +0000
83
84 catacomb-python (1.0.3) experimental; urgency=low
85
86   * Remove catacomb-python-bin package, because it made building hard and
87     didn't provide any noticeable benefits.
88
89  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 05 Nov 2010 15:12:35 +0000
90
91 catacomb-python (1.0.2) experimental; urgency=low
92
93   * Overhaul build system with new support module.
94
95  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 04 Oct 2009 14:17:20 +0100
96
97 catacomb-python (1.0.1) experimental; urgency=low
98
99   * Make it work with Python 2.6.  Also switched over to the (increasingly
100     winning) CDBS.
101
102  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 03 Oct 2009 23:06:29 +0100
103
104 catacomb-python (1.0.0) experimental; urgency=low
105
106   * Debianization!
107
108  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 26 Sep 2005 11:27:00 +0100