chiark / gitweb /
[PATCH] fix dbus build in the udev.spec file.
[elogind.git] / udev.spec
1 # if we want to build against the included version of klibc or not.
2 # 0 - do not use klibc
3 # 1 - use klibc
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
6 %define klibc 1
7
8 # if we want to have logging support in or not.
9 # 0 - no logging  support
10 # 1 - logging support
11 # Note, it is not recommend if you use klibc to enable logging.
12 %define log 0
13
14 # if we want to build SELinux support in or not.
15 # 0 - no SELinux support
16 # 1 - SELinux support
17 %define selinux 0
18
19 # if we want to enable debugging support in udev.  If it is enabled, lots of 
20 # stuff will get sent to the debug syslog.
21 # 0 - debugging disabled
22 # 1 - debugging enabled
23 %define debug 0
24
25 # if we want to build the DBUS "extra package or not
26 # 0 - no DBUS support
27 # 1 - DBUS support
28 %define dbus 0
29
30 # if we want to build the scsi_id "extra" package or not
31 # 0 - do not build the package
32 # 1 - build it
33 %define scsi_id 1
34
35 Summary: A userspace implementation of devfs
36 Name: udev
37 Version: 022_bk
38 Release: 1
39 License: GPL
40 Group: Utilities/System
41 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
42 ExclusiveOS: Linux
43 Vendor: Greg Kroah-Hartman <greg@kroah.com>
44 URL : kernel.org/pub/linux/utils/kernel/hotplug/
45 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
46 Prereq: /bin/sh, fileutils, hotplug
47
48 %description
49 udev is a implementation of devfs in userspace using sysfs and
50 /sbin/hotplug. It requires a 2.6 kernel to run properly.
51
52 %prep
53 %setup -q
54
55 %build
56 make CC="gcc $RPM_OPT_FLAGS"    \
57 %if %{klibc}
58         USE_KLIBC=true          \
59 %endif
60 %if %{log}
61         USE_LOG=true            \
62 %else
63         USE_LOG=false           \
64 %endif
65 %if %{selinux}
66         USE_SELINUX=true        \
67 %else
68         USE_SELINUX=false       \
69 %endif
70 %if %{debug}
71         DEBUG=true              \
72 %else
73         DEBUG=false             \
74 %endif
75         EXTRAS="        \
76 %if %{scsi_id}
77         extras/scsi_id  \
78 %endif
79 %if %{dbus}
80         extras/dbus     \
81 %endif
82 "
83
84 %install
85 make DESTDIR=$RPM_BUILD_ROOT install \
86 %if %{selinux}
87         USE_SELINUX=true        \
88 %else
89         USE_SELINUX=false       \
90 %endif
91         EXTRAS="        \
92 %if %{scsi_id}
93         extras/scsi_id  \
94 %endif
95 %if %{dbus}
96         extras/dbus     \
97 %endif
98 "
99
100 %post
101 /sbin/chkconfig --add udev
102
103 %postun
104 if [ $1 = 0 ]; then
105         /sbin/chkconfig --del udev
106 fi
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(-,root,root)
113 %doc COPYING README TODO ChangeLog HOWTO* docs/*
114 %doc etc/udev/udev.rules.{examples,gentoo,redhat}
115 %doc etc/udev/udev.permissions.{gentoo,redhat}
116 %attr(755,root,root) /sbin/udev
117 %attr(755,root,root) /usr/bin/udevinfo
118 %attr(755,root,root) /sbin/udevsend
119 %attr(755,root,root) /sbin/udevd
120 %attr(755,root,root) /sbin/udevtest
121 %attr(755,root,root) /sbin/udevstart
122 %attr(755,root,root) %dir /udev/
123 %attr(755,root,root) %dir /etc/udev/
124 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
125 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
126 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
127 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
128 %attr(755,root,root) /etc/init.d/udev
129 %attr(0644,root,root) %{_mandir}/man8/udev*.8*
130
131 %if %{dbus}
132         %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
133 %endif
134
135 %if %{scsi_id}
136         %attr(755,root,root) /sbin/scsi_id
137         %config(noreplace) %attr(0644,root,root) /etc/scsi_id.config
138         %attr(0644,root,root) %{_mandir}/man8/scsi_id*.8*
139 %endif
140
141 %changelog
142 * Wed Mar 24 2004 Greg Kroah-Hartman <greg@kroah.com>
143 - change the way dbus support is built (now an extra)
144
145 * Tue Mar 2 2004 Greg Kroah-Hartman <greg@kroah.com>
146 - added udevstart to the list of files installed
147 - udevinfo is now in /usr/bin not /sbin
148
149 * Fri Feb 27 2004 Greg Kroah-Hartman <greg@kroah.com>
150 - added ability to build with SELinux support
151
152 * Thu Feb 19 2004 Greg Kroah-Hartman <greg@kroah.com>
153 - add some more files to the documentation directory
154 - add ability to build scsi_id and make it the default
155
156 * Mon Feb 16 2004 Greg Kroah-Hartman <greg@kroah.com>
157 - fix up udevd build, as it's no longer needed to be build seperatly
158 - add udevtest to list of files
159 - more Red Hat sync ups.
160
161 * Thu Feb 12 2004 Greg Kroah-Hartman <greg@kroah.com>
162 - add some changes from the latest Fedora udev release.
163
164 * Mon Feb 2 2004 Greg Kroah-Hartman <greg@kroah.com>
165 - add udevsend, and udevd to the files
166 - add ability to build udevd with glibc after the rest is build with klibc
167
168 * Mon Jan 26 2004 Greg Kroah-Hartman <greg@kroah.com>
169 - added udevinfo to rpm
170 - added URL to spec file
171 - added udevinfo's man page
172
173 * Mon Jan 05 2004 Rolf Eike Beer <eike-hotplug@sf-tec.de>
174 - add defines to choose the init script (Redhat or LSB)
175
176 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
177 - install the initscript and run chkconfig on it
178
179 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
180 - changes due to config file name changes
181
182 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
183 - Make work without a build root
184 - Correctly install the right files
185 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
186 - Put some prereqs in
187 - Install the hotplug symlink to udev
188
189 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
190 - Initial spec file for udev-0.2.