chiark / gitweb /
svc/watch.in: Bug fix: addpeer on correct coroutine.
[tripe] / debian / rules
1 #! /usr/bin/make -f
2
3 CDBS = /usr/share/cdbs/1
4
5 include $(CDBS)/rules/debhelper.mk
6 include $(CDBS)/class/autotools.mk
7
8 ###--------------------------------------------------------------------------
9 ### General settings.
10
11 DEB_BUILDDIR = $(CURDIR)/build
12 DEB_MAKE_CHECK_TARGET = check
13
14 ###--------------------------------------------------------------------------
15 ### Correct configuration.
16
17 ## This will need changing on other kernels.
18 default_tunnel = linux
19
20 ## Configuration arguments.
21 DEB_CONFIGURE_EXTRA_FLAGS = \
22         --with-tunnel="$(default_tunnel) slip" \
23         --with-configdir="/etc/tripe" \
24         --with-socketdir="/var/run" \
25         --with-logfile="/var/log/tripe.log" \
26         --with-pidfile="/var/run/tripectl.pid" \
27         --with-initconfig="/etc/default/tripe" \
28         --with-wireshark
29
30 ###--------------------------------------------------------------------------
31 ### Python.
32
33 binary-install/python-tripe::
34         dh_pycentral -ppython-tripe
35
36 ###--------------------------------------------------------------------------
37 ### Install the startup scripts.
38
39 install/tripe::
40         cp $(DEB_BUILDDIR)/init/tripe-init debian/tripe.init
41         sed 's/^#\(user\|group\)/\1/' \
42                 $(DEB_SRCDIR)/init/tripe.conf >debian/tripe.default
43
44 cleanbuilddir::
45         rm -f debian/tripe.init debian/tripe.default
46
47 ###--------------------------------------------------------------------------
48 ### Install configuration files.
49
50 install/tripe-peer-services::
51         install -m644 $(DEB_SRCDIR)/peerdb/peers.in \
52                 debian/tripe-peer-services/etc/tripe/peers.d/10base
53
54 ###--------------------------------------------------------------------------
55 ### Wireshark plugin.
56
57 ## Grab the version we built against, so we can put it in the dependencies.
58 install/tripe-wireshark::
59         dpkg --status wireshark | \
60                 sed -n 's/^Version: */tripe:Wireshark-Version=/p' \
61                 >> debian/tripe-wireshark.substvars
62
63 ## Don't track dependencies for the plugin.  We have it covered already.
64 DEB_DH_SHLIBDEPS_ARGS_tripe-wireshark += -Xwireshark/plugins
65
66 ###----- That's all, folks --------------------------------------------------