chiark / gitweb /
server, common: Split more code into utilities.
[tripe] / debian / rules
1 #! /usr/bin/make -f
2
3 CDBS = /usr/share/cdbs/1
4
5 include $(CDBS)/rules/debhelper.mk
6 include $(CDBS)/class/autotools.mk
7
8 ###--------------------------------------------------------------------------
9 ### General settings.
10
11 DEB_BUILDDIR = $(CURDIR)/build
12
13 ###--------------------------------------------------------------------------
14 ### Correct configuration.
15
16 ## This will need changing on other kernels.
17 default_tunnel = linux
18
19 ## Configuration arguments.
20 DEB_CONFIGURE_EXTRA_FLAGS = \
21         --with-tunnel="$(default_tunnel) slip" \
22         --with-configdir="/etc/tripe" \
23         --with-socketdir="/var/run" \
24         --with-logfile="/var/log/tripe.log" \
25         --with-pidfile="/var/run/tripectl.pid" \
26         --with-initconfig="/etc/default/tripe" \
27         --with-wireshark
28
29 ###--------------------------------------------------------------------------
30 ### Install the startup scripts.
31
32 install/tripe::
33         cp $(DEB_BUILDDIR)/init/tripe-init debian/tripe.init
34         cp $(DEB_SRCDIR)/init/tripe.conf debian/tripe.default
35
36 cleanbuilddir::
37         rm -f debian/tripe.init debian/tripe.default
38
39 ###--------------------------------------------------------------------------
40 ### Wireshark plugin.
41
42 ## Grab the version we built against, so we can put it in the dependencies.
43 install/tripe-wireshark::
44         dpkg --status wireshark | \
45                 sed -n 's/^Version: */tripe:Wireshark-Version=/p' \
46                 >> debian/tripe-wireshark.substvars
47
48 ## Don't track dependencies for the plugin.  We have it covered already.
49 DEB_DH_SHLIBDEPS_ARGS_tripe-wireshark += -Xwireshark/plugins
50
51 ###----- That's all, folks --------------------------------------------------