chiark / gitweb /
maint-utils/keysubst: A monstrously unpleasant sed hack.
[tripe] / debian / rules
1 #! /usr/bin/make -f
2
3 CDBS = /usr/share/cdbs/1
4
5 include $(CDBS)/rules/debhelper.mk
6 include $(CDBS)/class/autotools.mk
7
8 ###--------------------------------------------------------------------------
9 ### General settings.
10
11 DEB_BUILDDIR = $(CURDIR)/build
12 DEB_MAKE_CHECK_TARGET = check
13
14 ###--------------------------------------------------------------------------
15 ### Correct configuration.
16
17 ## This will need changing on other kernels.
18 default_tunnel = linux
19
20 ## Configuration arguments.
21 DEB_CONFIGURE_EXTRA_FLAGS = \
22         --with-tunnel="$(default_tunnel) slip" \
23         --with-configdir="/etc/tripe" \
24         --with-socketdir="/var/run" \
25         --with-logfile="/var/log/tripe.log" \
26         --with-pidfile="/var/run/tripectl.pid" \
27         --with-initconfig="/etc/default/tripe" \
28         --with-wireshark
29
30 ###--------------------------------------------------------------------------
31 ### Install the startup scripts.
32
33 install/tripe::
34         cp $(DEB_BUILDDIR)/init/tripe-init debian/tripe.init
35         cp $(DEB_SRCDIR)/init/tripe.conf debian/tripe.default
36
37 cleanbuilddir::
38         rm -f debian/tripe.init debian/tripe.default
39
40 ###--------------------------------------------------------------------------
41 ### Wireshark plugin.
42
43 ## Grab the version we built against, so we can put it in the dependencies.
44 install/tripe-wireshark::
45         dpkg --status wireshark | \
46                 sed -n 's/^Version: */tripe:Wireshark-Version=/p' \
47                 >> debian/tripe-wireshark.substvars
48
49 ## Don't track dependencies for the plugin.  We have it covered already.
50 DEB_DH_SHLIBDEPS_ARGS_tripe-wireshark += -Xwireshark/plugins
51
52 ###----- That's all, folks --------------------------------------------------