2 # Sample debian/rules that uses debhelper.
3 # This file is public domain software, originally written by Joey Hess.
4 # Modified for secnet by Stephen Early <steve@greenend.org.uk>
6 # Uncomment this to turn on verbose mode.
9 # This is the debhelper compatibility version to use.
16 # Add here commands to compile the package.
17 ./configure --prefix=/usr --sysconfdir=/etc && $(MAKE)
26 # Add here commands to clean up after the build process.
37 # Add here commands to install the package into debian/<packagename>
38 $(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
40 # Build architecture-independent files here.
41 binary-indep: build install
42 # We have nothing to do by default.
44 # Build architecture-dependent files here.
45 binary-arch: build install
49 dh_installdocs INSTALL README NOTES TODO
50 dh_installexamples example.conf make-secnet-sites.py ipaddr.py
74 binary: binary-indep binary-arch
75 .PHONY: build clean binary-indep binary-arch binary install