chiark / gitweb /
debian: Dump CDBS in favour of plain Debhelper.
[misc] / debian / rules
1 #! /usr/bin/make -f
2
3 DH_OPTIONS = --parallel --builddir=debian/build
4 %:; dh $@ $(DH_OPTIONS)
5
6 override_dh_auto_configure:
7         dh_auto_configure -- --with-perlmoddir=/usr/share/perl5
8
9 ###--------------------------------------------------------------------------
10 ### Installation.
11 ###
12 ### Rather than have lots (and /lots/) of little *.install files, we just
13 ### have one big list of everything and split it out as we go.
14
15 override_dh_clean:
16         dh_clean
17         rm -f debian/*.install debian/*.stamp
18
19 override_dh_install: debian/install-files.stamp
20         dh_install
21
22 debian/install-files.stamp: debian/inst
23         rm -f debian/*.install debian/*.install.new
24         pkgs=" "; while read file pkg dir; do \
25           case "$$pkgs" in *" $$pkg "*) ;; *) pkgs="$$pkgs$$pkg ";; esac; \
26           echo "debian/tmp$$dir/$$file" >>debian/$$pkg.install.new; \
27         done <debian/inst; \
28         for pkg in $$pkgs; do \
29           mv debian/$$pkg.install.new debian/$$pkg.install; \
30         done
31
32 ###----- That's all, folks --------------------------------------------------