chiark / gitweb /
Build system overhaul.
[misc] / debian / rules
1 #! /usr/bin/make -f
2
3 CDBS = /usr/share/cdbs/1
4
5 include $(CDBS)/class/autotools.mk
6 include $(CDBS)/rules/debhelper.mk
7
8 ###--------------------------------------------------------------------------
9 ### General settings.
10
11 DEB_BUILDDIR = $(CURDIR)/build
12
13 ###--------------------------------------------------------------------------
14 ### Correct configuration.
15
16 DEB_CONFIGURE_EXTRA_FLAGS = \
17         --with-perlmoddir=/usr/share/perl5
18
19 ###--------------------------------------------------------------------------
20 ### Installation.
21 ###
22 ### Rather than have lots (and /lots/) of little *.install files, we just
23 ### have one big list of everything and split it out as we go.
24
25 clean::; rm -f debian/*.install
26
27 $(addprefix install/, $(DEB_ALL_PACKAGES)):: install/%: debian/%.install
28
29 debian/%.install: debian/inst
30         while read file pkg dir; do \
31           if [ "$$pkg" = "$*" ]; then \
32             echo "debian/tmp$$dir/$$file"; \
33           fi; \
34         done <debian/inst >$@.new && mv $@.new $@
35
36 ###----- That's all, folks --------------------------------------------------