chiark / gitweb /
debian/: Bump to Debhelper 10.
[mLib] / debian / rules
index f7796aa7bcec6f68d235fbce48f622a30370a1ab..4bd7c2c1d62f9bae455fa007bd18088691ac88ad 100755 (executable)
@@ -31,7 +31,7 @@ DH_BUILD_OVERRIDES = configure clean build install test
 ## How to perform build action for a particular library flavour.
 define flavour-build-action
 dh_auto_$1 -Bdebian/build-$2 \
-       $(DH_OPTIONS) $(DH_OPTIONS_$2) \
+       $(addprefix -O, $(DH_OPTIONS)) $(DH_OPTIONS_$2) \
        $(DH_$1_OPTIONS) $(DH_$1_OPTIONS_$2)
 
 endef
@@ -58,6 +58,9 @@ DH_install_OPTIONS_adns = --destdir=debian/tmp-adns
 ###--------------------------------------------------------------------------
 ### Additional tweaks.
 
+## Don't try to rebuild our configure script.
+DH_OPTIONS += --without=autoreconf
+
 ## Some of the install lists need to be generated.  This is a little
 ## annoying.
 GEN_INSTALL_PKGS = mlib2-adns
@@ -69,8 +72,8 @@ dh-install-hook:: $(GEN_INSTALL_FILES); @:
 dh-clean-hook::
        rm -f $(GEN_INSTALL_FILES)
 
-## Override the shared-library dependency information to allow any flavour.
+## Check that the shared-library symbols are plausible.
 override_dh_makeshlibs:
-       dh_makeshlibs -V"mlib2 (>= $v) | mlib2-adns (>= $v)"
+       dh_makeshlibs -- -c4
 
 ###----- That's all, folks --------------------------------------------------