chiark / gitweb /
struct/buf.c: Add functions for serializing and deserializing `kludge64'.
[mLib] / debian / changelog
1 mlib (2.5.0) experimental; urgency=medium
2
3   * Fix internal Python build scripts to work with Python 3.
4   * Introduce wrapper macros around the <ctype.h> functions (to handle
5     negative character codes correctly), and the <string.h> comparison
6     functions `strcmp', `strncmp', and `memcmp'.
7
8  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 08 May 2020 20:16:37 +0100
9
10 mlib (2.4.2) experimental; urgency=medium
11
12   * mlib (buf): Handle 64-bit length prefixes correctly on 32-bit
13     platforms.  Previously, a huge length was reduced modulo 2^32 prior to
14     checking via an implicit conversion to `size_t'.
15   * mlib (bres-adns): Use correct array bound when reassembling `hostent'
16     structures to return.  Apparently this has never been correct.
17   * mlib-dev: Some formatting fixes in manpages.
18
19  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 08 May 2020 13:43:00 +0100
20
21 mlib (2.4.1) experimental; urgency=medium
22
23   * (internals): Delete `track', which stopped being built or distributed
24     in 2.2.0 and nobody noticed.
25   * mlib-dev: Add a `STATIC_ASSERT' macro, because we've wanted one for ages.
26   * debian: Ship a shared-library `symbols' file for more precise
27     dependencies.
28
29  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 15:13:30 +0100
30
31 mlib (2.4.0) experimental; urgency=medium
32
33   * mlib (crc32): Make table be read-only.
34   * mlib-dev (macros): Decorate attribute names with `__...__'.
35   * mlib-bin (crc-mktab, unihash-mkstatic): Add option for generating
36     `const' tables.
37   * Support building with Clang.
38
39  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 21:37:47 +0100
40
41 mlib (2.3.3.1) experimental; urgency=medium
42
43   * macros: Add missing fallback definition for `NORETURN'.
44
45  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 09 Aug 2019 11:32:38 +0100
46
47 mlib (2.3.3) experimental; urgency=medium
48
49   * mlib2-adns: Make sure there's a `DT_NEEDED' entry for libadns.  I
50     don't know why this has just become important.
51   * mlib-dev: Fix the `pkg-config' snippet so that static linking works.
52   * macros: Properly parenthesize the `N' macro's argument.  (I think it
53     doesn't make any difference.)
54   * fdpass: Fix file-descriptor passing on 64-bit targets.  This was
55     broken by an embarrassing typo (and inadequate testing).
56
57  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 25 Dec 2018 15:06:00 +0000
58
59 mlib (2.3.2) experimental; urgency=medium
60
61   * url: Fix crash in `url_enc' introduced in earlier alleged fix.
62
63  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 10:53:19 +0100
64
65 mlib (2.3.1) experimental; urgency=medium
66
67   * Pick up missed fix from 2.2.5.
68
69  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 01:40:14 +0100
70
71 mlib (2.3.0) experimental; urgency=medium
72
73   * url: Always encode whitespace characters.  Particularly egregiously,
74     mLib used to leave linefeeds unescaped in `lax' mode.
75   * bits: Document the many improvements since the original version nearly
76     20 years ago.
77   * bits: Add macros for byte-swapping integers in-place.
78   * bits: Use compiler intrinsics where available.
79
80  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 00:30:47 +0100
81
82 mlib (2.2.5) experimental; urgency=medium
83
84   * ident: Only close the socket once if connection fails early.
85
86  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 Jun 2018 17:40:21 +0100
87
88 mlib (2.2.4) experimental; urgency=medium
89
90   * debian: Update for Debhelper 9.
91   * debian: Multi-arch support.
92   * mlib-dev: Compiler-hack support for Clang.
93
94  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 13 Aug 2017 20:12:19 +0100
95
96 mlib (2.2.3) experimental; urgency=low
97
98   * build: Cope with newer Autotools and related equipment.
99   * Miscellaneous small fixes for Cygwin.
100
101  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:09:53 +0100
102
103 mlib (2.2.2.2) experimental; urgency=low
104
105   * codec: Minor formatting fix to manpage.
106   * Fixed Build-Depends and missing debian/source/format file.
107
108  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 08:19:10 +0000
109
110 mlib (2.2.2.1) experimental; urgency=low
111
112   * dstr: `dstr_putf' no longer leaks memory.  Sorry.
113
114  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 18 Jan 2015 16:54:30 +0000
115
116 mlib (2.2.2) experimental; urgency=low
117
118   * bres: Fixed `bres_abort' scrambing the freelist leading to a segfault.
119   * codec: New flag `CDCF_IGNSPC' to ignore whitespace when decoding.  This
120     is the default in bincode(1).
121   * dstr: `dstr_putf' no longer crashes on `%.*s' and similar.
122   * dstr: `dstr_putf' now understands `%n$...' positional placeholders.
123
124  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 20 Jul 2014 21:35:20 +0100
125
126 mlib (2.2.1) experimental; urgency=low
127
128   * crc32: Fix on 64-bit systems.
129   * dstr: `dstr_putc' now takes an `int' argument.
130   * macros.h: Provide macros for annotating functions (e.g., as following
131     various kinds of varargs protocols) and controlling warnings.
132
133  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 28 Jun 2013 23:27:49 +0100
134
135 mlib (2.2.0.1) experimental; urgency=low
136
137   * Brown paper-bag: failed to include `codec.h' in `hex.h' and `base32.h'
138     leading to build failures of clients.
139
140  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 12 Jan 2013 18:49:36 +0000
141
142 mlib (2.2.0) experimental; urgency=low
143
144   * Major internal reorganization.
145   * Ship precomputed tables and provide partial support for
146     cross-compilation.
147   * Overhaul of binary-to-text coding: now has better error handling, and
148     a single unified engine.  Also provides a program, bincode(1), for
149     exercising the system.
150   * Replace random ad-hoc testing by a system based on GNU Autotest.
151
152  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 03 May 2009 01:44:45 +0100
153
154 mlib (2.1.1) experimental; urgency=low
155
156   * Actually declare buf_putstr* in buf.h.
157   * Skip past terminating null in buf_get*z, rather than leaving it for
158     the next get.
159
160  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 05 May 2012 13:18:40 +0100
161
162 mlib (2.1.0) experimental; urgency=low
163
164   * New function `mdup' for renumbering file descriptors.
165   * Various internal build-system changes.
166
167  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 04 Jan 2009 14:45:07 +0000
168
169 mlib (2.0.7) experimental; urgency=low
170
171   * The new build system put the headers in /usr/include/mlib, where
172     nothing could find them.  Put them back in /usr/include/mLib where
173     they belong.
174   * Actually include config.h in the correct places, so that, for example,
175     dstr_putf doesn't explode.
176
177  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 28 Dec 2008 21:23:59 +0000
178
179 mlib (2.0.6) experimental; urgency=low
180
181   * Build system overhaul.
182
183  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 27 Dec 2008 13:42:39 +0000
184
185 mlib (2.0.5) experimental; urgency=low
186
187   * Fix versioncmp to deal with `~' characters properly, in line with
188     Debian policy.
189
190  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 14 May 2008 15:10:32 +0100
191
192 mlib (2.0.4) experimental; urgency=low
193
194   * Switch over to pkgconfig.  This is largely a stopgap release, to stop
195     stuff breaking hopelessly while mLib 3 is worked on.
196
197  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 17:51:45 +0000
198
199 mlib (2.0.3) experimental; urgency=low
200
201   * Document hex encoding/decoding.
202   * Add file descriptor passing.
203   * Add ADNS-based background resolver.
204   * Split binaries off into their own package.
205   * Document, fix and test universal hashing; use it in symbol tables.
206
207  -- Mark Wooding <mdw@nsict.org>  Mon, 15 Dec 2003 20:54:16 +0000
208
209 mlib (2.0.2) experimental; urgency=low
210
211   * Debianization!
212
213  -- Mark Wooding <mdw@nsict.org>  Sat,  8 Nov 2003 22:43:10 +0000