chiark / gitweb /
Bring CGI docs pretty much up to date
[disorder] / debian / rules
1 #! /usr/bin/make -f
2 #
3 # Copyright (C) 2004-2008 Richard Kettlewell
4 #
5 # This program is free software; you can redistribute it and/or modify
6 # it under the terms of the GNU General Public License as published by
7 # the Free Software Foundation; either version 2 of the License, or
8 # (at your option) any later version.
9 #
10 # This program is distributed in the hope that it will be useful, but
11 # WITHOUT ANY WARRANTY; without even the implied warranty of
12 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
13 # General Public License for more details.
14 #
15 # You should have received a copy of the GNU General Public License
16 # along with this program; if not, write to the Free Software
17 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
18 # USA
19 #
20
21 # Options to configure.  This can be overridden by the caller if necessary.
22 CONFIGURE=--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib --mandir=/usr/share/man --with-browser=x-www-browser
23
24 # Set DEB_BUILD_OPTIONS=noopt to produce a non-optimized build.
25 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26 CFLAGS=-O0 -g
27 else
28 CFLAGS=-O2 -g
29 endif
30 export CFLAGS
31
32 # Install commands.  You wouldn't normally override these.
33 INSTALL=install
34 INSTALL_DATA=$(INSTALL) -p -o root -g root -m 644
35 INSTALL_PROGRAM=$(INSTALL) -p -o root -g root -m 755
36 INSTALL_SCRIPT=$(INSTALL) -p -o root -g root -m 755
37 MKDIR=mkdir -p -m 755
38
39 # Set DEB_BUILD_OPTIONS=nostrip to install debuggable executables.
40 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
41 INSTALL_PROGRAM += -s
42 endif
43
44 export INSTALL_DATA
45 export INSTALL_SCRIPT
46 export INSTALL_PROGRAM
47
48 LIBTOOL=./libtool
49 FAKEROOT=fakeroot
50
51 # ./prepare is the script that generates configure etc.  It only needs to be
52 # run if building from a checkout rather than a tarball.
53 build:
54         @set -e;if test ! -f configure; then \
55           echo ./prepare;\
56           ./prepare;\
57         fi
58         @set -e;if test ! -f config.status; then \
59           echo ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
60           ./configure ${CONFIGURE} ${CONFIGURE_EXTRA};\
61         else\
62           echo ./config.status;\
63           ./config.status;\
64         fi
65         $(MAKE)
66
67 pkg-disorder: build
68         rm -rf debian/disorder
69         $(MKDIR) debian/disorder
70         $(MKDIR) debian/disorder/DEBIAN
71         $(MKDIR) debian/disorder/usr/share/doc/disorder
72         $(MKDIR) debian/disorder/etc/bash_completion.d
73         $(INSTALL_DATA) debian/copyright \
74                 debian/disorder/usr/share/doc/disorder/copyright
75         $(INSTALL_DATA) debian/changelog \
76                 debian/disorder/usr/share/doc/disorder/changelog.Debian
77         gzip -9 debian/disorder/usr/share/doc/disorder/changelog.Debian
78         @for f in preinst postinst prerm postrm conffiles templates config; do\
79           if test -e debian/$$f.disorder; then\
80             echo $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
81             $(INSTALL_SCRIPT) debian/$$f.disorder debian/disorder/DEBIAN/$$f; \
82           fi;\
83         done
84         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C doc
85         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C clients
86         $(MAKE) DESTDIR=`pwd`/debian/disorder installdirs install -C lib
87         $(INSTALL_DATA) scripts/completion.bash \
88                 debian/disorder/etc/bash_completion.d/disorder
89         rm -rf debian/disorder/usr/share/man/man8
90         rm -rf debian/disorder/usr/share/disorder/*.html
91         rmdir debian/disorder/usr/share/disorder
92         rm -f debian/disorder/usr/bin/disorder-playrtp
93         rm -f debian/disorder/usr/bin/disobedience
94         rm -f debian/disorder/usr/share/man/man1/disorder-playrtp.1
95         rm -f debian/disorder/usr/share/man/man1/disobedience.1
96         $(MKDIR) debian/disorder/etc/disorder
97         dpkg-shlibdeps -Tdebian/substvars.disorder \
98                 debian/disorder/usr/bin/*
99         $(INSTALL_DATA) CHANGES README debian/README.Debian \
100                 BUGS README.* \
101                 debian/disorder/usr/share/doc/disorder/.
102         gzip -9f debian/disorder/usr/share/doc/disorder/CHANGES \
103                  debian/disorder/usr/share/doc/disorder/README \
104                  debian/disorder/usr/share/doc/disorder/README.* \
105                  debian/disorder/usr/share/doc/disorder/BUGS \
106                  debian/disorder/usr/share/man/man*/*
107         dpkg-gencontrol -isp -pdisorder -Pdebian/disorder -Tdebian/substvars.disorder
108         chown -R root:root debian/disorder
109         chmod -R g-ws debian/disorder
110         dpkg --build debian/disorder ..
111
112 pkg-disorder-server: build
113         rm -rf debian/disorder-server
114         $(MKDIR) debian/disorder-server
115         $(MKDIR) debian/disorder-server/DEBIAN
116         $(MKDIR) debian/disorder-server/usr/share/doc/disorder-server
117         $(INSTALL_DATA) debian/copyright \
118                 debian/disorder-server/usr/share/doc/disorder-server/copyright
119         $(INSTALL_DATA) debian/changelog \
120                 debian/disorder-server/usr/share/doc/disorder-server/changelog.Debian
121         gzip -9 debian/disorder-server/usr/share/doc/disorder-server/changelog.Debian
122         @for f in preinst postinst prerm postrm conffiles templates config; do\
123           if test -e debian/$$f.disorder-server; then\
124             echo $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
125             $(INSTALL_SCRIPT) debian/$$f.disorder-server debian/disorder-server/DEBIAN/$$f; \
126           fi;\
127         done
128         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C images
129         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C server
130         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C templates
131         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C driver
132         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C plugins
133         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C sounds
134         $(MAKE) DESTDIR=`pwd`/debian/disorder-server staticdir=/var/www/disorder installdirs install -C doc
135         rm -rf debian/disorder-server/usr/share/man/man1
136         rm -rf debian/disorder-server/usr/share/man/man3
137         rm -rf debian/disorder-server/usr/share/man/man5
138         $(MKDIR) debian/disorder-server/etc/disorder
139         $(MKDIR) debian/disorder-server/etc/init.d
140         $(MKDIR) debian/disorder-server/usr/lib/cgi-bin
141         $(MKDIR) debian/disorder-server/var/lib/disorder
142         $(INSTALL_SCRIPT) examples/disorder.init \
143                 debian/disorder-server/etc/init.d/disorder
144         $(INSTALL_DATA) debian/etc.disorder.config \
145                 debian/disorder-server/etc/disorder/config
146         $(INSTALL_DATA) templates/options \
147                 debian/disorder-server/etc/disorder/options
148         $(INSTALL_DATA) debian/etc.disorder.options.user \
149                 debian/disorder-server/etc/disorder/options.user
150         $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) server/disorder.cgi \
151                 $(shell pwd)/debian/disorder-server/usr/lib/cgi-bin/disorder
152         dpkg-shlibdeps -Tdebian/substvars.disorder-server \
153                 debian/disorder-server/usr/lib/cgi-bin/disorder \
154                 debian/disorder-server/usr/sbin/* \
155                 debian/disorder-server/usr/lib/disorder/*.so*
156         rm -rf debian/disorder-server/usr/share/doc/disorder-server
157         ln -s disorder debian/disorder-server/usr/share/doc/disorder-server
158         dpkg-gencontrol -isp -pdisorder-server -Pdebian/disorder-server -Tdebian/substvars.disorder-server
159         chown -R root:root debian/disorder-server
160         chmod -R g-ws debian/disorder-server
161         dpkg --build debian/disorder-server ..
162
163 pkg-disorder-playrtp: build
164         rm -rf debian/disorder-playrtp
165         $(MKDIR) debian/disorder-playrtp
166         $(MKDIR) debian/disorder-playrtp/DEBIAN
167         $(MKDIR) debian/disorder-playrtp/usr/share/doc/disorder-playrtp
168         $(INSTALL_DATA) debian/copyright \
169                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/copyright
170         $(INSTALL_DATA) debian/changelog \
171                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog.Debian
172         gzip -9 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/changelog.Debian
173         @for f in preinst postinst prerm postrm conffiles templates config; do\
174           if test -e debian/$$f.disorder-playrtp; then\
175             echo $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
176             $(INSTALL_SCRIPT) debian/$$f.disorder-playrtp debian/disorder-playrtp/DEBIAN/$$f; \
177           fi;\
178         done
179         $(MKDIR) debian/disorder-playrtp/usr/bin
180         $(MKDIR) debian/disorder-playrtp/usr/share/man/man1
181         $(INSTALL_PROGRAM) clients/disorder-playrtp \
182                 debian/disorder-playrtp/usr/bin/disorder-playrtp
183         $(INSTALL_DATA) doc/disorder-playrtp.1 \
184                 debian/disorder-playrtp/usr/share/man/man1/disorder-playrtp.1
185         dpkg-shlibdeps -Tdebian/substvars.disorder-playrtp \
186                 debian/disorder-playrtp/usr/bin/*
187         $(INSTALL_DATA) debian/README.RTP \
188                 debian/disorder-playrtp/usr/share/doc/disorder-playrtp/README
189         $(INSTALL_DATA) CHANGES debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES
190         gzip -9f debian/disorder-playrtp/usr/share/doc/disorder-playrtp/CHANGES \
191                  debian/disorder-playrtp/usr/share/man/man*/*
192         dpkg-gencontrol -isp -pdisorder-playrtp -Pdebian/disorder-playrtp -Tdebian/substvars.disorder-playrtp
193         chown -R root:root debian/disorder-playrtp
194         chmod -R g-ws debian/disorder-playrtp
195         dpkg --build debian/disorder-playrtp ..
196
197 pkg-disobedience: build
198         rm -rf debian/disobedience
199         $(MKDIR) debian/disobedience
200         $(MKDIR) debian/disobedience/DEBIAN
201         $(MKDIR) debian/disobedience/usr/share/doc/disobedience
202         $(INSTALL_DATA) debian/copyright \
203                 debian/disobedience/usr/share/doc/disobedience/copyright
204         $(INSTALL_DATA) debian/changelog \
205                 debian/disobedience/usr/share/doc/disobedience/changelog.Debian
206         gzip -9 debian/disobedience/usr/share/doc/disobedience/changelog.Debian
207         @for f in preinst postinst prerm postrm conffiles templates config; do\
208           if test -e debian/$$f.disobedience; then\
209             echo $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
210             $(INSTALL_SCRIPT) debian/$$f.disobedience debian/disobedience/DEBIAN/$$f; \
211           fi;\
212         done
213         $(MKDIR) debian/disobedience/usr/bin
214         $(MKDIR) debian/disobedience/usr/share/man/man1
215         $(MKDIR) debian/disobedience/usr/share/pixmaps
216         $(MKDIR) debian/disobedience/usr/share/menu
217         $(MAKE) -C disobedience install DESTDIR=`pwd`/debian/disobedience
218         $(INSTALL_DATA) doc/disobedience.1 \
219                 debian/disobedience/usr/share/man/man1/disobedience.1
220         $(INSTALL_DATA) images/disobedience16x16.xpm \
221                         images/disobedience32x32.xpm \
222                         debian/disobedience/usr/share/pixmaps
223         $(INSTALL_DATA) debian/usr.share.menu.disobedience \
224                 debian/disobedience/usr/share/menu/disobedience
225         dpkg-shlibdeps -Tdebian/substvars.disobedience \
226                 debian/disobedience/usr/bin/*
227         rm -rf debian/disobedience/usr/share/doc/disobedience
228         ln -s disorder debian/disobedience/usr/share/doc/disobedience
229         dpkg-gencontrol -isp -pdisobedience -Pdebian/disobedience -Tdebian/substvars.disobedience
230         chown -R root:root debian/disobedience
231         chmod -R g-ws debian/disobedience
232         dpkg --build debian/disobedience ..
233
234 DEBVERSION:=$(shell dpkg-parsechangelog|awk '/Version:/ {print $$2}')
235 DSC=disorder_$(DEBVERSION).dsc
236 DEBSRC=disorder_$(DEBVERSION).tar.gz
237 VERSION=$(shell $(MAKE) echo-version)
238
239 source:
240         $(MAKE) dist
241         rm -rf disorder-$(VERSION)
242         tar xfz disorder-$(VERSION).tar.gz
243         dpkg-source -b disorder-$(VERSION)
244         rm -rf disorder-$(VERSION) disorder-$(VERSION).tar.gz
245
246 source-check: source
247         rm -rf disorder-$(DEBVERSION)
248         dpkg-source -x $(DSC)
249         cd disorder-$(DEBVERSION) && dpkg-buildpackage -r$(FAKEROOT)
250
251 binary: binary-arch binary-indep
252 binary-arch: pkg-disorder pkg-disorder-server pkg-disorder-playrtp \
253              pkg-disobedience
254 binary-indep: 
255
256 clean:
257         -$(MAKE) distclean
258         rm -f config.cache
259         rm -f debian/files
260         rm -f debian/substvars.*
261         rm -rf debian/disorder
262         rm -rf debian/disorder-server
263         rm -rf debian/disorder-playrtp
264         rm -rf debian/disobedience
265
266 .PHONY: clean build pkg-disorder pkg-disorder-server pkg-disorder-playrtp \
267         pkg-disobedience source source-check binary binary-arch binary-indep