chiark / gitweb /
Release 2.2.3.
[catacomb] / debian / changelog
1 catacomb (2.2.3) experimental; urgency=low
2
3   * rand: Make the main generator resiliant in the face of fork(2).
4   * rand: Introduce `rand_quick', which may also mix in CPU-level
5     randomness sources.
6   * rand: Use higher-resolution timer in the quick-win noise source.
7   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
8     which got lost down the side of the sofas.
9
10  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
11
12 catacomb (2.2.2) experimental; urgency=low
13
14   * build: Cope with newer Autotools and related equipment.
15   * Miscellaneous small fixes for Cygwin.
16   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
17     particularly, this causes a segfault reading bit zero of a zero-length
18     integer.
19
20  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
21
22 catacomb (2.2.1.1) experimental; urgency=low
23
24   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
25     really won't work well without it.
26
27  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
28
29 catacomb (2.2.1) experimental; urgency=low
30
31   * Some internal improvements.
32   * Debian packaging cleanups (fix build-depends, update mLib dependency).
33
34  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
35
36 catacomb (2.2.0) experimental; urgency=low
37
38   * catacomb2: Fix rsa_recover crash on even modulus.
39   * catacomb-bin: Report error taking factorial of negative input.
40   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
41   * catacomb-dev: Support multiple flavours of EC point compression.
42   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
43     out of prime numbers.
44   * catacomb2: Overhaul crypto primitives used in true-random generator.
45   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
46     support.
47   * catacomb-dev: New conversions between MP integers and C integer types.
48   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
49     big-endian bytes (rather than `uint32'), and the `block size' is 4.
50   * catacomb2: Mix a constant string into DSA nonce generation to improve
51     resistance to protocol interference.
52   * catacomb2: Fix the freewheel random source, which hasn't been enabled
53     for ages due to a configure-script bug.
54   * catacomb-bin: The key tool can now read and write multiple
55     presentations for key fingerprints.
56   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
57     stream ciphers.
58
59  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
60
61 catacomb (2.1.7) experimental; urgency=low
62
63   * A number of entropy-source fixes.
64   * Internal tidying.
65   * Add more elliptic curves, from Brainpool and BADA55.
66   * hashsum: Fix hash file verification.
67
68  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
69
70 catacomb (2.1.6.1) experimental; urgency=low
71
72   * Fix building from source tarball.
73   * Fix building with Python 2.5.
74
75  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
76
77 catacomb (2.1.6) experimental; urgency=low
78
79   * mpreduce: Extend domain to all positive integers.
80   * gfreduce: Fix out-of-bounds memory access.
81   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
82   * pixie: Don't replace existing pixie unless explicitly requested.
83
84  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
85
86 catacomb (2.1.5) experimental; urgency=low
87
88   * New build system.
89
90  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
91
92 catacomb (2.1.4) experimental; urgency=low
93
94   * Constant-time operations.
95   * Some minor fixes to header files.
96
97  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
98
99 catacomb (2.1.3) experimental; urgency=low
100
101   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
102     example program.
103   * Upper bounds on phrase entropy in mkphrase(1).
104   * Don't make the Pixie setuid-root by default.  Make the documentation
105     less scary.
106
107  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
108
109 catacomb (2.1.2.1) experimental; urgency=low
110
111   * hashsum: Document `--progress' option in `--help' output.
112
113  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
114
115 catacomb (2.1.2) experimental; urgency=low
116
117   * hashsum: Correct return code when running in `-c' mode.
118   * dsig: Fix core dump on large-ish outputs.
119   * dsig: Fix repeat-close bug.
120   * dsig: Accept precomputed hashes when making signatures.
121   * Utilities: New `-p' option for progress bars.
122   * dsig, hashsum: New `-j' option checks for files not covered by
123     manifest.
124   * Various library improvements.
125
126  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
127
128 catacomb (2.1.1) experimental; urgency=low
129
130   * Do configuration through pkgconfig.
131
132  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
133
134 catacomb (2.1.0) experimental; urgency=low
135
136   * Added support for elliptic curves, on both prime and binary fields
137     (polynomial basis only).  No actual crypto, but there's enough already
138     to do ECDH and stuff on well-known curves  Testing is currently a bit
139     patchy.
140
141  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
142
143 catacomb (2.0.1) experimental; urgency=low
144
145   * Debianization!
146   * (pixie): Don't report uninteresting errors when accepting connections.
147
148  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000