chiark / gitweb /
base/regdump.c: Be helpful about VFP/NEON registers before `regdump_init'.
[catacomb] / debian / changelog
1 catacomb (2.5.1) experimental; urgency=medium
2
3   * Merge changes from 2.4.4.
4
5  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 17:50:59 +0100
6
7 catacomb (2.5.0) experimental; urgency=medium
8
9   * catacomb: MACs based on blockciphers: PMAC1 and CMAC (also known as
10     OMAC).
11   * catacomb: Authenticated Encryption with Additional Data (AEAD)
12     schemes.  Some based on blockciphers: CCM, EAX, GCM (with CPU-specific
13     acceleration), OCB1 and OCB3 (OCB2 is broken).  Also Salsa20 and
14     ChaCha20 with Poly1305: the RFC7539 scheme, and the NaCl `secret_box'
15     transform.
16   * catacomb: Implement Grantham's Frobenius test.  Combine it with
17     Rabin--Miller, as Baillie--PSW, for testing given primes.
18   * catacomb-bin (catcrypt): Support AEAD schemes for bulk crypto.
19   * catacomb-bin (perftest): Options for batching; report cycle counts
20     where available.
21   * Many internal improvements: better documentation, debugging, testing,
22     etc.
23
24  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 21:26:44 +0100
25
26 catacomb (2.4.5) experimental; urgency=medium
27
28   * catacomb: Fix memory leak in key-file error handling.
29   * catacomb: Don't leak internal `exptime' symbol into the global
30     namespace.
31   * catacomb: Check that the X86 `rdrand' instruction actually works
32     before leaning on it.  This is in response to the well-publicized AMD
33     bug which always returns all-bits-set with the carry /set/ (indicating
34     success).
35   * catacomb: Mix in the random pool key during `rand_gate' and
36     `rand_stretch' operations.
37   * catacomb: Fix by-tag key lookups: if the query string looks like a hex
38     number, it's treated as a search by id; but if no such id is found,
39     the search wouldn't continue to look for a key by type or tag.
40   * catacomb: Fix reference leak in `key_split'.
41   * catacomb: Fix bug which completely broke `key_copydata'.
42   * catacomb: Fix segfault from `pgen', if it fails before setting up the
43     prime tester.
44   * catacomb: Propagate failure from `pgen' during Lim--Lee prime
45     generation, rather than immediately retrying.
46   * catacomb: Fix memory leak of factor vector from failed Lim--Lee prime
47     generation.
48   * catacomb: Fix segfault when multiplying the identity elliptic-curve
49     point.
50   * catacomb: Fix the `lcrand' descriptor, so that it's not advertised as
51     being cryptographically strong, and to fix a bias in its output.
52   * catacomb: Fix a memory leak in the error case of KCDSA prime
53     generation.
54   * catacomb-bin: Fix segfault from `pixie', if given an empty passphrase
55     to remember.
56   * catacomb: Check SIMD feature bit on ARM64 before using the optimized
57     code.  I don't know of any ARM64 implementations which lack SIMD
58     instructions, but the bit must be there for a reason, so I might as
59     well use it.
60   * catacomb: Support parsing binary-group descriptions.  This is a long-
61     standing lacuna that I've only recently noticed.
62
63  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 17:46:24 +0100
64
65 catacomb (2.4.4) experimental; urgency=medium
66
67   * debian: Bump to Debhelper 10.
68   * debian: Ship a shared-library `symbols' file for more precise
69     dependencies.
70
71  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 15:58:26 +0100
72
73 catacomb (2.4.3) experimental; urgency=medium
74
75   * catacomb (idea): Fix key-length descriptor.
76   * catacomb (xchachaNN): Fix nonce-size descriptor.
77   * catacomb (key-management): Fix incorrect handling of keyring
78     modifiability.
79   * catacomb-dev: Configure `pkg-config' correctly for static linking.
80   * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
81     padding on very long messages, and handling of large datestamps.
82   * catacomb-bin (catsign): Don't open temporary files unnecessarily.
83   * catacomb-bin (catcrypt): Fix key-attribute parsing.
84   * catacomb-bin (perftest): Add missing help-string text for `-n' used
85     with `enc' and `hash'
86
87  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 17:43:59 +0100
88
89 catacomb (2.4.2) experimental; urgency=medium
90
91   * catacomb2: Support multi-arch at last.
92   * catacomb2: Fix mangled key-size data for HMAC.
93   * rspit: Support generating large files.
94   * pixie: Improve error-handling around dropping privilege.
95   * ed25519, ed448: Very minor performance improvement.
96   * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
97     `rspit'.
98   * salsa20, chacha: Fix declaration of cipher classes to prevent them
99     ending up as (useless) common symbols in client code.
100   * limlee: Improve the prime size heuristics.
101   * sha, sha256, sha512: Restructure compression function to improve
102     performance and use less memory.
103   * rijndael: Include enough round constants to make very tiny keys work
104     correctly.
105
106  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 01:15:59 +0100
107
108 catacomb (2.4.1) experimental; urgency=low
109
110   * catacomb2: Two's-complement fix from 2.3.x release branch.
111
112  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:37:40 +0100
113
114 catacomb (2.4.0.1) experimental; urgency=low
115
116   * Fix build failure with later ARM assemblers.
117
118  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
119
120 catacomb (2.4.0) experimental; urgency=low
121
122   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
123     code.
124   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
125     and Salsa20.
126   * catacomb2: Implement Bernstein's X25519.
127   * catacomb2: Implement Hamburg's X448 (RFC7748).
128   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
129     as defined in RFC8032.
130   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
131     RFC8032.
132   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
133   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
134   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
135   * catacomb2: Allow RSA key generation with chosen public exponent.
136   * catacomb2: Optimize RSA public-key operations with common public
137     exponents.
138   * catacomb-bin: Support new algorithms in the provided tools.
139   * catacomb-bin: Allow parameters keys for all key types.
140
141  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
142
143 catacomb (2.3.2) experimental; urgency=low
144
145   * catacomb2: Fix bignum loading and storing in two's complement form.
146
147  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
148
149 catacomb (2.3.1) experimental; urgency=low
150
151   * catacomb2: Fix memory corruption when allocating `salsa20' and
152     `chacha'-based RNGs.
153   * catacomb2: Fix segfault when opening read-only keyring with no
154     associated file.
155   * catacomb2: Return the correct stream offset in `chacha_tell*'.
156   * catacomb2: Produce correct keyring files when they contain empty
157     keys.
158   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
159     and binary group implementations.
160   * catacomb-dev: Add missing licence notices to `salsa20.h'.
161   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
162   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
163     verifying.
164   * catacomb-bin: Compare MAC tags in constant time.
165   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
166
167  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
168
169 catacomb (2.3.0.1) experimental; urgency=low
170
171   * catacomb2: Actually make the stack non-executable rather than just
172     pretending.
173
174  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
175
176 catacomb (2.3.0) experimental; urgency=low
177
178   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
179     was a duplicate of the Oakley 1536 group.  There's a compatibility
180     break here, but it's for the best.
181   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
182     so that the process stack doesn't get marked executable.
183   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
184   * catacomb2: Lots of other improvements to the assembler code.
185
186  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
187
188 catacomb (2.2.5) experimental; urgency=low
189
190   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
191     is unaligned.
192   * build: Use less obsolete macro names in configure script.
193
194  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
195
196 catacomb (2.2.4) experimental; urgency=low
197
198   * build: Fix build failures on post-wheezy Debian versions.
199   * catacomb2: Use ARM AES instructions if available.  (But they can't be
200     assembled using wheezy's version of gas, so this doesn't work in the
201     binary package.)
202   * catacomb2: Fix poor performance (and wrong answers for very small
203     numbers) in prime generation.
204   * catacomb2: Return numbers of exactly the requested length in prime and
205     public-key generation.  The `strongprime' and `limlee' algorithms have
206     changed as a result; previously verifiable parameters generated using
207     this algorithm won't be verifiable any more.
208   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
209
210  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
211
212 catacomb (2.2.3) experimental; urgency=low
213
214   * rand: Make the main generator resiliant in the face of fork(2).
215   * rand: Introduce `rand_quick', which may also mix in CPU-level
216     randomness sources.
217   * rand: Use higher-resolution timer in the quick-win noise source.
218   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
219     which got lost down the side of the sofas.
220
221  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
222
223 catacomb (2.2.2) experimental; urgency=low
224
225   * build: Cope with newer Autotools and related equipment.
226   * Miscellaneous small fixes for Cygwin.
227   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
228     particularly, this causes a segfault reading bit zero of a zero-length
229     integer.
230
231  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
232
233 catacomb (2.2.1.1) experimental; urgency=low
234
235   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
236     really won't work well without it.
237
238  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
239
240 catacomb (2.2.1) experimental; urgency=low
241
242   * Some internal improvements.
243   * Debian packaging cleanups (fix build-depends, update mLib dependency).
244
245  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
246
247 catacomb (2.2.0) experimental; urgency=low
248
249   * catacomb2: Fix rsa_recover crash on even modulus.
250   * catacomb-bin: Report error taking factorial of negative input.
251   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
252   * catacomb-dev: Support multiple flavours of EC point compression.
253   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
254     out of prime numbers.
255   * catacomb2: Overhaul crypto primitives used in true-random generator.
256   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
257     support.
258   * catacomb-dev: New conversions between MP integers and C integer types.
259   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
260     big-endian bytes (rather than `uint32'), and the `block size' is 4.
261   * catacomb2: Mix a constant string into DSA nonce generation to improve
262     resistance to protocol interference.
263   * catacomb2: Fix the freewheel random source, which hasn't been enabled
264     for ages due to a configure-script bug.
265   * catacomb-bin: The key tool can now read and write multiple
266     presentations for key fingerprints.
267   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
268     stream ciphers.
269
270  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
271
272 catacomb (2.1.7) experimental; urgency=low
273
274   * A number of entropy-source fixes.
275   * Internal tidying.
276   * Add more elliptic curves, from Brainpool and BADA55.
277   * hashsum: Fix hash file verification.
278
279  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
280
281 catacomb (2.1.6.1) experimental; urgency=low
282
283   * Fix building from source tarball.
284   * Fix building with Python 2.5.
285
286  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
287
288 catacomb (2.1.6) experimental; urgency=low
289
290   * mpreduce: Extend domain to all positive integers.
291   * gfreduce: Fix out-of-bounds memory access.
292   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
293   * pixie: Don't replace existing pixie unless explicitly requested.
294
295  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
296
297 catacomb (2.1.5) experimental; urgency=low
298
299   * New build system.
300
301  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
302
303 catacomb (2.1.4) experimental; urgency=low
304
305   * Constant-time operations.
306   * Some minor fixes to header files.
307
308  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
309
310 catacomb (2.1.3) experimental; urgency=low
311
312   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
313     example program.
314   * Upper bounds on phrase entropy in mkphrase(1).
315   * Don't make the Pixie setuid-root by default.  Make the documentation
316     less scary.
317
318  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
319
320 catacomb (2.1.2.1) experimental; urgency=low
321
322   * hashsum: Document `--progress' option in `--help' output.
323
324  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
325
326 catacomb (2.1.2) experimental; urgency=low
327
328   * hashsum: Correct return code when running in `-c' mode.
329   * dsig: Fix core dump on large-ish outputs.
330   * dsig: Fix repeat-close bug.
331   * dsig: Accept precomputed hashes when making signatures.
332   * Utilities: New `-p' option for progress bars.
333   * dsig, hashsum: New `-j' option checks for files not covered by
334     manifest.
335   * Various library improvements.
336
337  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
338
339 catacomb (2.1.1) experimental; urgency=low
340
341   * Do configuration through pkgconfig.
342
343  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
344
345 catacomb (2.1.0) experimental; urgency=low
346
347   * Added support for elliptic curves, on both prime and binary fields
348     (polynomial basis only).  No actual crypto, but there's enough already
349     to do ECDH and stuff on well-known curves  Testing is currently a bit
350     patchy.
351
352  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
353
354 catacomb (2.0.1) experimental; urgency=low
355
356   * Debianization!
357   * (pixie): Don't report uninteresting errors when accepting connections.
358
359  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000