chiark / gitweb /
Release 2.4.1.
[catacomb] / debian / changelog
1 catacomb (2.4.1) experimental; urgency=low
2
3   * catacomb2: Two's-complement fix from 2.3.x release branch.
4
5  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:37:40 +0100
6
7 catacomb (2.4.0.1) experimental; urgency=low
8
9   * Fix build failure with later ARM assemblers.
10
11  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
12
13 catacomb (2.4.0) experimental; urgency=low
14
15   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
16     code.
17   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
18     and Salsa20.
19   * catacomb2: Implement Bernstein's X25519.
20   * catacomb2: Implement Hamburg's X448 (RFC7748).
21   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
22     as defined in RFC8032.
23   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
24     RFC8032.
25   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
26   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
27   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
28   * catacomb2: Allow RSA key generation with chosen public exponent.
29   * catacomb2: Optimize RSA public-key operations with common public
30     exponents.
31   * catacomb-bin: Support new algorithms in the provided tools.
32   * catacomb-bin: Allow parameters keys for all key types.
33
34  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
35
36 catacomb (2.3.2) experimental; urgency=low
37
38   * catacomb2: Fix bignum loading and storing in two's complement form.
39
40  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
41
42 catacomb (2.3.1) experimental; urgency=low
43
44   * catacomb2: Fix memory corruption when allocating `salsa20' and
45     `chacha'-based RNGs.
46   * catacomb2: Fix segfault when opening read-only keyring with no
47     associated file.
48   * catacomb2: Return the correct stream offset in `chacha_tell*'.
49   * catacomb2: Produce correct keyring files when they contain empty
50     keys.
51   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
52     and binary group implementations.
53   * catacomb-dev: Add missing licence notices to `salsa20.h'.
54   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
55   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
56     verifying.
57   * catacomb-bin: Compare MAC tags in constant time.
58   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
59
60  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
61
62 catacomb (2.3.0.1) experimental; urgency=low
63
64   * catacomb2: Actually make the stack non-executable rather than just
65     pretending.
66
67  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
68
69 catacomb (2.3.0) experimental; urgency=low
70
71   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
72     was a duplicate of the Oakley 1536 group.  There's a compatibility
73     break here, but it's for the best.
74   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
75     so that the process stack doesn't get marked executable.
76   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
77   * catacomb2: Lots of other improvements to the assembler code.
78
79  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
80
81 catacomb (2.2.5) experimental; urgency=low
82
83   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
84     is unaligned.
85   * build: Use less obsolete macro names in configure script.
86
87  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
88
89 catacomb (2.2.4) experimental; urgency=low
90
91   * build: Fix build failures on post-wheezy Debian versions.
92   * catacomb2: Use ARM AES instructions if available.  (But they can't be
93     assembled using wheezy's version of gas, so this doesn't work in the
94     binary package.)
95   * catacomb2: Fix poor performance (and wrong answers for very small
96     numbers) in prime generation.
97   * catacomb2: Return numbers of exactly the requested length in prime and
98     public-key generation.  The `strongprime' and `limlee' algorithms have
99     changed as a result; previously verifiable parameters generated using
100     this algorithm won't be verifiable any more.
101   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
102
103  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
104
105 catacomb (2.2.3) experimental; urgency=low
106
107   * rand: Make the main generator resiliant in the face of fork(2).
108   * rand: Introduce `rand_quick', which may also mix in CPU-level
109     randomness sources.
110   * rand: Use higher-resolution timer in the quick-win noise source.
111   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
112     which got lost down the side of the sofas.
113
114  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
115
116 catacomb (2.2.2) experimental; urgency=low
117
118   * build: Cope with newer Autotools and related equipment.
119   * Miscellaneous small fixes for Cygwin.
120   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
121     particularly, this causes a segfault reading bit zero of a zero-length
122     integer.
123
124  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
125
126 catacomb (2.2.1.1) experimental; urgency=low
127
128   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
129     really won't work well without it.
130
131  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
132
133 catacomb (2.2.1) experimental; urgency=low
134
135   * Some internal improvements.
136   * Debian packaging cleanups (fix build-depends, update mLib dependency).
137
138  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
139
140 catacomb (2.2.0) experimental; urgency=low
141
142   * catacomb2: Fix rsa_recover crash on even modulus.
143   * catacomb-bin: Report error taking factorial of negative input.
144   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
145   * catacomb-dev: Support multiple flavours of EC point compression.
146   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
147     out of prime numbers.
148   * catacomb2: Overhaul crypto primitives used in true-random generator.
149   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
150     support.
151   * catacomb-dev: New conversions between MP integers and C integer types.
152   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
153     big-endian bytes (rather than `uint32'), and the `block size' is 4.
154   * catacomb2: Mix a constant string into DSA nonce generation to improve
155     resistance to protocol interference.
156   * catacomb2: Fix the freewheel random source, which hasn't been enabled
157     for ages due to a configure-script bug.
158   * catacomb-bin: The key tool can now read and write multiple
159     presentations for key fingerprints.
160   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
161     stream ciphers.
162
163  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
164
165 catacomb (2.1.7) experimental; urgency=low
166
167   * A number of entropy-source fixes.
168   * Internal tidying.
169   * Add more elliptic curves, from Brainpool and BADA55.
170   * hashsum: Fix hash file verification.
171
172  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
173
174 catacomb (2.1.6.1) experimental; urgency=low
175
176   * Fix building from source tarball.
177   * Fix building with Python 2.5.
178
179  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
180
181 catacomb (2.1.6) experimental; urgency=low
182
183   * mpreduce: Extend domain to all positive integers.
184   * gfreduce: Fix out-of-bounds memory access.
185   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
186   * pixie: Don't replace existing pixie unless explicitly requested.
187
188  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
189
190 catacomb (2.1.5) experimental; urgency=low
191
192   * New build system.
193
194  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
195
196 catacomb (2.1.4) experimental; urgency=low
197
198   * Constant-time operations.
199   * Some minor fixes to header files.
200
201  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
202
203 catacomb (2.1.3) experimental; urgency=low
204
205   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
206     example program.
207   * Upper bounds on phrase entropy in mkphrase(1).
208   * Don't make the Pixie setuid-root by default.  Make the documentation
209     less scary.
210
211  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
212
213 catacomb (2.1.2.1) experimental; urgency=low
214
215   * hashsum: Document `--progress' option in `--help' output.
216
217  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
218
219 catacomb (2.1.2) experimental; urgency=low
220
221   * hashsum: Correct return code when running in `-c' mode.
222   * dsig: Fix core dump on large-ish outputs.
223   * dsig: Fix repeat-close bug.
224   * dsig: Accept precomputed hashes when making signatures.
225   * Utilities: New `-p' option for progress bars.
226   * dsig, hashsum: New `-j' option checks for files not covered by
227     manifest.
228   * Various library improvements.
229
230  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
231
232 catacomb (2.1.1) experimental; urgency=low
233
234   * Do configuration through pkgconfig.
235
236  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
237
238 catacomb (2.1.0) experimental; urgency=low
239
240   * Added support for elliptic curves, on both prime and binary fields
241     (polynomial basis only).  No actual crypto, but there's enough already
242     to do ECDH and stuff on well-known curves  Testing is currently a bit
243     patchy.
244
245  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
246
247 catacomb (2.0.1) experimental; urgency=low
248
249   * Debianization!
250   * (pixie): Don't report uninteresting errors when accepting connections.
251
252  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000