chiark / gitweb /
Release 2.4.0.
[catacomb] / debian / changelog
1 catacomb (2.4.0) experimental; urgency=low
2
3   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
4     code.
5   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
6     and Salsa20.
7   * catacomb2: Implement Bernstein's X25519.
8   * catacomb2: Implement Hamburg's X448 (RFC7748).
9   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
10     as defined in RFC8032.
11   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
12     RFC8032.
13   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
14   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
15   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
16   * catacomb2: Allow RSA key generation with chosen public exponent.
17   * catacomb2: Optimize RSA public-key operations with common public
18     exponents.
19   * catacomb-bin: Support new algorithms in the provided tools.
20   * catacomb-bin: Allow parameters keys for all key types.
21
22  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
23
24 catacomb (2.3.1) experimental; urgency=low
25
26   * catacomb2: Fix memory corruption when allocating `salsa20' and
27     `chacha'-based RNGs.
28   * catacomb2: Fix segfault when opening read-only keyring with no
29     associated file.
30   * catacomb2: Return the correct stream offset in `chacha_tell*'.
31   * catacomb2: Produce correct keyring files when they contain empty
32     keys.
33   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
34     and binary group implementations.
35   * catacomb-dev: Add missing licence notices to `salsa20.h'.
36   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
37   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
38     verifying.
39   * catacomb-bin: Compare MAC tags in constant time.
40   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
41
42  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
43
44 catacomb (2.3.0.1) experimental; urgency=low
45
46   * catacomb2: Actually make the stack non-executable rather than just
47     pretending.
48
49  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
50
51 catacomb (2.3.0) experimental; urgency=low
52
53   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
54     was a duplicate of the Oakley 1536 group.  There's a compatibility
55     break here, but it's for the best.
56   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
57     so that the process stack doesn't get marked executable.
58   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
59   * catacomb2: Lots of other improvements to the assembler code.
60
61  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
62
63 catacomb (2.2.5) experimental; urgency=low
64
65   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
66     is unaligned.
67   * build: Use less obsolete macro names in configure script.
68
69  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
70
71 catacomb (2.2.4) experimental; urgency=low
72
73   * build: Fix build failures on post-wheezy Debian versions.
74   * catacomb2: Use ARM AES instructions if available.  (But they can't be
75     assembled using wheezy's version of gas, so this doesn't work in the
76     binary package.)
77   * catacomb2: Fix poor performance (and wrong answers for very small
78     numbers) in prime generation.
79   * catacomb2: Return numbers of exactly the requested length in prime and
80     public-key generation.  The `strongprime' and `limlee' algorithms have
81     changed as a result; previously verifiable parameters generated using
82     this algorithm won't be verifiable any more.
83   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
84
85  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
86
87 catacomb (2.2.3) experimental; urgency=low
88
89   * rand: Make the main generator resiliant in the face of fork(2).
90   * rand: Introduce `rand_quick', which may also mix in CPU-level
91     randomness sources.
92   * rand: Use higher-resolution timer in the quick-win noise source.
93   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
94     which got lost down the side of the sofas.
95
96  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
97
98 catacomb (2.2.2) experimental; urgency=low
99
100   * build: Cope with newer Autotools and related equipment.
101   * Miscellaneous small fixes for Cygwin.
102   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
103     particularly, this causes a segfault reading bit zero of a zero-length
104     integer.
105
106  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
107
108 catacomb (2.2.1.1) experimental; urgency=low
109
110   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
111     really won't work well without it.
112
113  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
114
115 catacomb (2.2.1) experimental; urgency=low
116
117   * Some internal improvements.
118   * Debian packaging cleanups (fix build-depends, update mLib dependency).
119
120  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
121
122 catacomb (2.2.0) experimental; urgency=low
123
124   * catacomb2: Fix rsa_recover crash on even modulus.
125   * catacomb-bin: Report error taking factorial of negative input.
126   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
127   * catacomb-dev: Support multiple flavours of EC point compression.
128   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
129     out of prime numbers.
130   * catacomb2: Overhaul crypto primitives used in true-random generator.
131   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
132     support.
133   * catacomb-dev: New conversions between MP integers and C integer types.
134   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
135     big-endian bytes (rather than `uint32'), and the `block size' is 4.
136   * catacomb2: Mix a constant string into DSA nonce generation to improve
137     resistance to protocol interference.
138   * catacomb2: Fix the freewheel random source, which hasn't been enabled
139     for ages due to a configure-script bug.
140   * catacomb-bin: The key tool can now read and write multiple
141     presentations for key fingerprints.
142   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
143     stream ciphers.
144
145  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
146
147 catacomb (2.1.7) experimental; urgency=low
148
149   * A number of entropy-source fixes.
150   * Internal tidying.
151   * Add more elliptic curves, from Brainpool and BADA55.
152   * hashsum: Fix hash file verification.
153
154  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
155
156 catacomb (2.1.6.1) experimental; urgency=low
157
158   * Fix building from source tarball.
159   * Fix building with Python 2.5.
160
161  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
162
163 catacomb (2.1.6) experimental; urgency=low
164
165   * mpreduce: Extend domain to all positive integers.
166   * gfreduce: Fix out-of-bounds memory access.
167   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
168   * pixie: Don't replace existing pixie unless explicitly requested.
169
170  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
171
172 catacomb (2.1.5) experimental; urgency=low
173
174   * New build system.
175
176  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
177
178 catacomb (2.1.4) experimental; urgency=low
179
180   * Constant-time operations.
181   * Some minor fixes to header files.
182
183  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
184
185 catacomb (2.1.3) experimental; urgency=low
186
187   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
188     example program.
189   * Upper bounds on phrase entropy in mkphrase(1).
190   * Don't make the Pixie setuid-root by default.  Make the documentation
191     less scary.
192
193  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
194
195 catacomb (2.1.2.1) experimental; urgency=low
196
197   * hashsum: Document `--progress' option in `--help' output.
198
199  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
200
201 catacomb (2.1.2) experimental; urgency=low
202
203   * hashsum: Correct return code when running in `-c' mode.
204   * dsig: Fix core dump on large-ish outputs.
205   * dsig: Fix repeat-close bug.
206   * dsig: Accept precomputed hashes when making signatures.
207   * Utilities: New `-p' option for progress bars.
208   * dsig, hashsum: New `-j' option checks for files not covered by
209     manifest.
210   * Various library improvements.
211
212  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
213
214 catacomb (2.1.1) experimental; urgency=low
215
216   * Do configuration through pkgconfig.
217
218  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
219
220 catacomb (2.1.0) experimental; urgency=low
221
222   * Added support for elliptic curves, on both prime and binary fields
223     (polynomial basis only).  No actual crypto, but there's enough already
224     to do ECDH and stuff on well-known curves  Testing is currently a bit
225     patchy.
226
227  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
228
229 catacomb (2.0.1) experimental; urgency=low
230
231   * Debianization!
232   * (pixie): Don't report uninteresting errors when accepting connections.
233
234  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000