chiark / gitweb /
Merge branch '2.3.x'
[catacomb] / debian / changelog
1 catacomb (2.4.0.1) experimental; urgency=low
2
3   * Fix build failure with later ARM assemblers.
4
5  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
6
7 catacomb (2.4.0) experimental; urgency=low
8
9   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
10     code.
11   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
12     and Salsa20.
13   * catacomb2: Implement Bernstein's X25519.
14   * catacomb2: Implement Hamburg's X448 (RFC7748).
15   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
16     as defined in RFC8032.
17   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
18     RFC8032.
19   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
20   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
21   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
22   * catacomb2: Allow RSA key generation with chosen public exponent.
23   * catacomb2: Optimize RSA public-key operations with common public
24     exponents.
25   * catacomb-bin: Support new algorithms in the provided tools.
26   * catacomb-bin: Allow parameters keys for all key types.
27
28  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
29
30 catacomb (2.3.2) experimental; urgency=low
31
32   * catacomb2: Fix bignum loading and storing in two's complement form.
33
34  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
35
36 catacomb (2.3.1) experimental; urgency=low
37
38   * catacomb2: Fix memory corruption when allocating `salsa20' and
39     `chacha'-based RNGs.
40   * catacomb2: Fix segfault when opening read-only keyring with no
41     associated file.
42   * catacomb2: Return the correct stream offset in `chacha_tell*'.
43   * catacomb2: Produce correct keyring files when they contain empty
44     keys.
45   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
46     and binary group implementations.
47   * catacomb-dev: Add missing licence notices to `salsa20.h'.
48   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
49   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
50     verifying.
51   * catacomb-bin: Compare MAC tags in constant time.
52   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
53
54  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
55
56 catacomb (2.3.0.1) experimental; urgency=low
57
58   * catacomb2: Actually make the stack non-executable rather than just
59     pretending.
60
61  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
62
63 catacomb (2.3.0) experimental; urgency=low
64
65   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
66     was a duplicate of the Oakley 1536 group.  There's a compatibility
67     break here, but it's for the best.
68   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
69     so that the process stack doesn't get marked executable.
70   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
71   * catacomb2: Lots of other improvements to the assembler code.
72
73  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
74
75 catacomb (2.2.5) experimental; urgency=low
76
77   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
78     is unaligned.
79   * build: Use less obsolete macro names in configure script.
80
81  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
82
83 catacomb (2.2.4) experimental; urgency=low
84
85   * build: Fix build failures on post-wheezy Debian versions.
86   * catacomb2: Use ARM AES instructions if available.  (But they can't be
87     assembled using wheezy's version of gas, so this doesn't work in the
88     binary package.)
89   * catacomb2: Fix poor performance (and wrong answers for very small
90     numbers) in prime generation.
91   * catacomb2: Return numbers of exactly the requested length in prime and
92     public-key generation.  The `strongprime' and `limlee' algorithms have
93     changed as a result; previously verifiable parameters generated using
94     this algorithm won't be verifiable any more.
95   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
96
97  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
98
99 catacomb (2.2.3) experimental; urgency=low
100
101   * rand: Make the main generator resiliant in the face of fork(2).
102   * rand: Introduce `rand_quick', which may also mix in CPU-level
103     randomness sources.
104   * rand: Use higher-resolution timer in the quick-win noise source.
105   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
106     which got lost down the side of the sofas.
107
108  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
109
110 catacomb (2.2.2) experimental; urgency=low
111
112   * build: Cope with newer Autotools and related equipment.
113   * Miscellaneous small fixes for Cygwin.
114   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
115     particularly, this causes a segfault reading bit zero of a zero-length
116     integer.
117
118  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
119
120 catacomb (2.2.1.1) experimental; urgency=low
121
122   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
123     really won't work well without it.
124
125  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
126
127 catacomb (2.2.1) experimental; urgency=low
128
129   * Some internal improvements.
130   * Debian packaging cleanups (fix build-depends, update mLib dependency).
131
132  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
133
134 catacomb (2.2.0) experimental; urgency=low
135
136   * catacomb2: Fix rsa_recover crash on even modulus.
137   * catacomb-bin: Report error taking factorial of negative input.
138   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
139   * catacomb-dev: Support multiple flavours of EC point compression.
140   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
141     out of prime numbers.
142   * catacomb2: Overhaul crypto primitives used in true-random generator.
143   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
144     support.
145   * catacomb-dev: New conversions between MP integers and C integer types.
146   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
147     big-endian bytes (rather than `uint32'), and the `block size' is 4.
148   * catacomb2: Mix a constant string into DSA nonce generation to improve
149     resistance to protocol interference.
150   * catacomb2: Fix the freewheel random source, which hasn't been enabled
151     for ages due to a configure-script bug.
152   * catacomb-bin: The key tool can now read and write multiple
153     presentations for key fingerprints.
154   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
155     stream ciphers.
156
157  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
158
159 catacomb (2.1.7) experimental; urgency=low
160
161   * A number of entropy-source fixes.
162   * Internal tidying.
163   * Add more elliptic curves, from Brainpool and BADA55.
164   * hashsum: Fix hash file verification.
165
166  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
167
168 catacomb (2.1.6.1) experimental; urgency=low
169
170   * Fix building from source tarball.
171   * Fix building with Python 2.5.
172
173  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
174
175 catacomb (2.1.6) experimental; urgency=low
176
177   * mpreduce: Extend domain to all positive integers.
178   * gfreduce: Fix out-of-bounds memory access.
179   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
180   * pixie: Don't replace existing pixie unless explicitly requested.
181
182  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
183
184 catacomb (2.1.5) experimental; urgency=low
185
186   * New build system.
187
188  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
189
190 catacomb (2.1.4) experimental; urgency=low
191
192   * Constant-time operations.
193   * Some minor fixes to header files.
194
195  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
196
197 catacomb (2.1.3) experimental; urgency=low
198
199   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
200     example program.
201   * Upper bounds on phrase entropy in mkphrase(1).
202   * Don't make the Pixie setuid-root by default.  Make the documentation
203     less scary.
204
205  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
206
207 catacomb (2.1.2.1) experimental; urgency=low
208
209   * hashsum: Document `--progress' option in `--help' output.
210
211  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
212
213 catacomb (2.1.2) experimental; urgency=low
214
215   * hashsum: Correct return code when running in `-c' mode.
216   * dsig: Fix core dump on large-ish outputs.
217   * dsig: Fix repeat-close bug.
218   * dsig: Accept precomputed hashes when making signatures.
219   * Utilities: New `-p' option for progress bars.
220   * dsig, hashsum: New `-j' option checks for files not covered by
221     manifest.
222   * Various library improvements.
223
224  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
225
226 catacomb (2.1.1) experimental; urgency=low
227
228   * Do configuration through pkgconfig.
229
230  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
231
232 catacomb (2.1.0) experimental; urgency=low
233
234   * Added support for elliptic curves, on both prime and binary fields
235     (polynomial basis only).  No actual crypto, but there's enough already
236     to do ECDH and stuff on well-known curves  Testing is currently a bit
237     patchy.
238
239  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
240
241 catacomb (2.0.1) experimental; urgency=low
242
243   * Debianization!
244   * (pixie): Don't report uninteresting errors when accepting connections.
245
246  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000