chiark / gitweb /
Release 2.5.2.
[catacomb] / debian / changelog
1 catacomb (2.5.2) experimental; urgency=medium
2
3   * Merge changes from 2.4.5.
4   * catacomb-dev: Fix ARM32 FP/SIMD register dumping.
5
6  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 20:50:57 +0100
7
8 catacomb (2.5.1) experimental; urgency=medium
9
10   * Merge changes from 2.4.4.
11
12  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 17:50:59 +0100
13
14 catacomb (2.5.0) experimental; urgency=medium
15
16   * catacomb: MACs based on blockciphers: PMAC1 and CMAC (also known as
17     OMAC).
18   * catacomb: Authenticated Encryption with Additional Data (AEAD)
19     schemes.  Some based on blockciphers: CCM, EAX, GCM (with CPU-specific
20     acceleration), OCB1 and OCB3 (OCB2 is broken).  Also Salsa20 and
21     ChaCha20 with Poly1305: the RFC7539 scheme, and the NaCl `secret_box'
22     transform.
23   * catacomb: Implement Grantham's Frobenius test.  Combine it with
24     Rabin--Miller, as Baillie--PSW, for testing given primes.
25   * catacomb-bin (catcrypt): Support AEAD schemes for bulk crypto.
26   * catacomb-bin (perftest): Options for batching; report cycle counts
27     where available.
28   * Many internal improvements: better documentation, debugging, testing,
29     etc.
30
31  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 21:26:44 +0100
32
33 catacomb (2.4.5) experimental; urgency=medium
34
35   * catacomb: Fix memory leak in key-file error handling.
36   * catacomb: Don't leak internal `exptime' symbol into the global
37     namespace.
38   * catacomb: Check that the X86 `rdrand' instruction actually works
39     before leaning on it.  This is in response to the well-publicized AMD
40     bug which always returns all-bits-set with the carry /set/ (indicating
41     success).
42   * catacomb: Mix in the random pool key during `rand_gate' and
43     `rand_stretch' operations.
44   * catacomb: Fix by-tag key lookups: if the query string looks like a hex
45     number, it's treated as a search by id; but if no such id is found,
46     the search wouldn't continue to look for a key by type or tag.
47   * catacomb: Fix reference leak in `key_split'.
48   * catacomb: Fix bug which completely broke `key_copydata'.
49   * catacomb: Fix segfault from `pgen', if it fails before setting up the
50     prime tester.
51   * catacomb: Propagate failure from `pgen' during Lim--Lee prime
52     generation, rather than immediately retrying.
53   * catacomb: Fix memory leak of factor vector from failed Lim--Lee prime
54     generation.
55   * catacomb: Fix segfault when multiplying the identity elliptic-curve
56     point.
57   * catacomb: Fix the `lcrand' descriptor, so that it's not advertised as
58     being cryptographically strong, and to fix a bias in its output.
59   * catacomb: Fix a memory leak in the error case of KCDSA prime
60     generation.
61   * catacomb-bin: Fix segfault from `pixie', if given an empty passphrase
62     to remember.
63   * catacomb: Check SIMD feature bit on ARM64 before using the optimized
64     code.  I don't know of any ARM64 implementations which lack SIMD
65     instructions, but the bit must be there for a reason, so I might as
66     well use it.
67   * catacomb: Support parsing binary-group descriptions.  This is a long-
68     standing lacuna that I've only recently noticed.
69
70  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 17:46:24 +0100
71
72 catacomb (2.4.4) experimental; urgency=medium
73
74   * debian: Bump to Debhelper 10.
75   * debian: Ship a shared-library `symbols' file for more precise
76     dependencies.
77
78  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 15:58:26 +0100
79
80 catacomb (2.4.3) experimental; urgency=medium
81
82   * catacomb (idea): Fix key-length descriptor.
83   * catacomb (xchachaNN): Fix nonce-size descriptor.
84   * catacomb (key-management): Fix incorrect handling of keyring
85     modifiability.
86   * catacomb-dev: Configure `pkg-config' correctly for static linking.
87   * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
88     padding on very long messages, and handling of large datestamps.
89   * catacomb-bin (catsign): Don't open temporary files unnecessarily.
90   * catacomb-bin (catcrypt): Fix key-attribute parsing.
91   * catacomb-bin (perftest): Add missing help-string text for `-n' used
92     with `enc' and `hash'
93
94  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 17:43:59 +0100
95
96 catacomb (2.4.2) experimental; urgency=medium
97
98   * catacomb2: Support multi-arch at last.
99   * catacomb2: Fix mangled key-size data for HMAC.
100   * rspit: Support generating large files.
101   * pixie: Improve error-handling around dropping privilege.
102   * ed25519, ed448: Very minor performance improvement.
103   * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
104     `rspit'.
105   * salsa20, chacha: Fix declaration of cipher classes to prevent them
106     ending up as (useless) common symbols in client code.
107   * limlee: Improve the prime size heuristics.
108   * sha, sha256, sha512: Restructure compression function to improve
109     performance and use less memory.
110   * rijndael: Include enough round constants to make very tiny keys work
111     correctly.
112
113  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 01:15:59 +0100
114
115 catacomb (2.4.1) experimental; urgency=low
116
117   * catacomb2: Two's-complement fix from 2.3.x release branch.
118
119  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:37:40 +0100
120
121 catacomb (2.4.0.1) experimental; urgency=low
122
123   * Fix build failure with later ARM assemblers.
124
125  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
126
127 catacomb (2.4.0) experimental; urgency=low
128
129   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
130     code.
131   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
132     and Salsa20.
133   * catacomb2: Implement Bernstein's X25519.
134   * catacomb2: Implement Hamburg's X448 (RFC7748).
135   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
136     as defined in RFC8032.
137   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
138     RFC8032.
139   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
140   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
141   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
142   * catacomb2: Allow RSA key generation with chosen public exponent.
143   * catacomb2: Optimize RSA public-key operations with common public
144     exponents.
145   * catacomb-bin: Support new algorithms in the provided tools.
146   * catacomb-bin: Allow parameters keys for all key types.
147
148  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
149
150 catacomb (2.3.2) experimental; urgency=low
151
152   * catacomb2: Fix bignum loading and storing in two's complement form.
153
154  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
155
156 catacomb (2.3.1) experimental; urgency=low
157
158   * catacomb2: Fix memory corruption when allocating `salsa20' and
159     `chacha'-based RNGs.
160   * catacomb2: Fix segfault when opening read-only keyring with no
161     associated file.
162   * catacomb2: Return the correct stream offset in `chacha_tell*'.
163   * catacomb2: Produce correct keyring files when they contain empty
164     keys.
165   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
166     and binary group implementations.
167   * catacomb-dev: Add missing licence notices to `salsa20.h'.
168   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
169   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
170     verifying.
171   * catacomb-bin: Compare MAC tags in constant time.
172   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
173
174  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
175
176 catacomb (2.3.0.1) experimental; urgency=low
177
178   * catacomb2: Actually make the stack non-executable rather than just
179     pretending.
180
181  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
182
183 catacomb (2.3.0) experimental; urgency=low
184
185   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
186     was a duplicate of the Oakley 1536 group.  There's a compatibility
187     break here, but it's for the best.
188   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
189     so that the process stack doesn't get marked executable.
190   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
191   * catacomb2: Lots of other improvements to the assembler code.
192
193  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
194
195 catacomb (2.2.5) experimental; urgency=low
196
197   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
198     is unaligned.
199   * build: Use less obsolete macro names in configure script.
200
201  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
202
203 catacomb (2.2.4) experimental; urgency=low
204
205   * build: Fix build failures on post-wheezy Debian versions.
206   * catacomb2: Use ARM AES instructions if available.  (But they can't be
207     assembled using wheezy's version of gas, so this doesn't work in the
208     binary package.)
209   * catacomb2: Fix poor performance (and wrong answers for very small
210     numbers) in prime generation.
211   * catacomb2: Return numbers of exactly the requested length in prime and
212     public-key generation.  The `strongprime' and `limlee' algorithms have
213     changed as a result; previously verifiable parameters generated using
214     this algorithm won't be verifiable any more.
215   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
216
217  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
218
219 catacomb (2.2.3) experimental; urgency=low
220
221   * rand: Make the main generator resiliant in the face of fork(2).
222   * rand: Introduce `rand_quick', which may also mix in CPU-level
223     randomness sources.
224   * rand: Use higher-resolution timer in the quick-win noise source.
225   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
226     which got lost down the side of the sofas.
227
228  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
229
230 catacomb (2.2.2) experimental; urgency=low
231
232   * build: Cope with newer Autotools and related equipment.
233   * Miscellaneous small fixes for Cygwin.
234   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
235     particularly, this causes a segfault reading bit zero of a zero-length
236     integer.
237
238  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
239
240 catacomb (2.2.1.1) experimental; urgency=low
241
242   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
243     really won't work well without it.
244
245  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
246
247 catacomb (2.2.1) experimental; urgency=low
248
249   * Some internal improvements.
250   * Debian packaging cleanups (fix build-depends, update mLib dependency).
251
252  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
253
254 catacomb (2.2.0) experimental; urgency=low
255
256   * catacomb2: Fix rsa_recover crash on even modulus.
257   * catacomb-bin: Report error taking factorial of negative input.
258   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
259   * catacomb-dev: Support multiple flavours of EC point compression.
260   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
261     out of prime numbers.
262   * catacomb2: Overhaul crypto primitives used in true-random generator.
263   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
264     support.
265   * catacomb-dev: New conversions between MP integers and C integer types.
266   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
267     big-endian bytes (rather than `uint32'), and the `block size' is 4.
268   * catacomb2: Mix a constant string into DSA nonce generation to improve
269     resistance to protocol interference.
270   * catacomb2: Fix the freewheel random source, which hasn't been enabled
271     for ages due to a configure-script bug.
272   * catacomb-bin: The key tool can now read and write multiple
273     presentations for key fingerprints.
274   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
275     stream ciphers.
276
277  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
278
279 catacomb (2.1.7) experimental; urgency=low
280
281   * A number of entropy-source fixes.
282   * Internal tidying.
283   * Add more elliptic curves, from Brainpool and BADA55.
284   * hashsum: Fix hash file verification.
285
286  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
287
288 catacomb (2.1.6.1) experimental; urgency=low
289
290   * Fix building from source tarball.
291   * Fix building with Python 2.5.
292
293  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
294
295 catacomb (2.1.6) experimental; urgency=low
296
297   * mpreduce: Extend domain to all positive integers.
298   * gfreduce: Fix out-of-bounds memory access.
299   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
300   * pixie: Don't replace existing pixie unless explicitly requested.
301
302  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
303
304 catacomb (2.1.5) experimental; urgency=low
305
306   * New build system.
307
308  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
309
310 catacomb (2.1.4) experimental; urgency=low
311
312   * Constant-time operations.
313   * Some minor fixes to header files.
314
315  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
316
317 catacomb (2.1.3) experimental; urgency=low
318
319   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
320     example program.
321   * Upper bounds on phrase entropy in mkphrase(1).
322   * Don't make the Pixie setuid-root by default.  Make the documentation
323     less scary.
324
325  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
326
327 catacomb (2.1.2.1) experimental; urgency=low
328
329   * hashsum: Document `--progress' option in `--help' output.
330
331  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
332
333 catacomb (2.1.2) experimental; urgency=low
334
335   * hashsum: Correct return code when running in `-c' mode.
336   * dsig: Fix core dump on large-ish outputs.
337   * dsig: Fix repeat-close bug.
338   * dsig: Accept precomputed hashes when making signatures.
339   * Utilities: New `-p' option for progress bars.
340   * dsig, hashsum: New `-j' option checks for files not covered by
341     manifest.
342   * Various library improvements.
343
344  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
345
346 catacomb (2.1.1) experimental; urgency=low
347
348   * Do configuration through pkgconfig.
349
350  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
351
352 catacomb (2.1.0) experimental; urgency=low
353
354   * Added support for elliptic curves, on both prime and binary fields
355     (polynomial basis only).  No actual crypto, but there's enough already
356     to do ECDH and stuff on well-known curves  Testing is currently a bit
357     patchy.
358
359  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
360
361 catacomb (2.0.1) experimental; urgency=low
362
363   * Debianization!
364   * (pixie): Don't report uninteresting errors when accepting connections.
365
366  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000