chiark / gitweb /
symm/{chacha,salsa20}-x86ish-sse2.S: Fix typo in commentary.
[catacomb] / debian / changelog
1 catacomb (2.4.0.1) experimental; urgency=low
2
3   * Fix build failure with later ARM assemblers.
4
5  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
6
7 catacomb (2.4.0) experimental; urgency=low
8
9   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
10     code.
11   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
12     and Salsa20.
13   * catacomb2: Implement Bernstein's X25519.
14   * catacomb2: Implement Hamburg's X448 (RFC7748).
15   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
16     as defined in RFC8032.
17   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
18     RFC8032.
19   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
20   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
21   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
22   * catacomb2: Allow RSA key generation with chosen public exponent.
23   * catacomb2: Optimize RSA public-key operations with common public
24     exponents.
25   * catacomb-bin: Support new algorithms in the provided tools.
26   * catacomb-bin: Allow parameters keys for all key types.
27
28  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
29
30 catacomb (2.3.1) experimental; urgency=low
31
32   * catacomb2: Fix memory corruption when allocating `salsa20' and
33     `chacha'-based RNGs.
34   * catacomb2: Fix segfault when opening read-only keyring with no
35     associated file.
36   * catacomb2: Return the correct stream offset in `chacha_tell*'.
37   * catacomb2: Produce correct keyring files when they contain empty
38     keys.
39   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
40     and binary group implementations.
41   * catacomb-dev: Add missing licence notices to `salsa20.h'.
42   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
43   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
44     verifying.
45   * catacomb-bin: Compare MAC tags in constant time.
46   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
47
48  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
49
50 catacomb (2.3.0.1) experimental; urgency=low
51
52   * catacomb2: Actually make the stack non-executable rather than just
53     pretending.
54
55  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
56
57 catacomb (2.3.0) experimental; urgency=low
58
59   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
60     was a duplicate of the Oakley 1536 group.  There's a compatibility
61     break here, but it's for the best.
62   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
63     so that the process stack doesn't get marked executable.
64   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
65   * catacomb2: Lots of other improvements to the assembler code.
66
67  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
68
69 catacomb (2.2.5) experimental; urgency=low
70
71   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
72     is unaligned.
73   * build: Use less obsolete macro names in configure script.
74
75  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
76
77 catacomb (2.2.4) experimental; urgency=low
78
79   * build: Fix build failures on post-wheezy Debian versions.
80   * catacomb2: Use ARM AES instructions if available.  (But they can't be
81     assembled using wheezy's version of gas, so this doesn't work in the
82     binary package.)
83   * catacomb2: Fix poor performance (and wrong answers for very small
84     numbers) in prime generation.
85   * catacomb2: Return numbers of exactly the requested length in prime and
86     public-key generation.  The `strongprime' and `limlee' algorithms have
87     changed as a result; previously verifiable parameters generated using
88     this algorithm won't be verifiable any more.
89   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
90
91  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
92
93 catacomb (2.2.3) experimental; urgency=low
94
95   * rand: Make the main generator resiliant in the face of fork(2).
96   * rand: Introduce `rand_quick', which may also mix in CPU-level
97     randomness sources.
98   * rand: Use higher-resolution timer in the quick-win noise source.
99   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
100     which got lost down the side of the sofas.
101
102  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
103
104 catacomb (2.2.2) experimental; urgency=low
105
106   * build: Cope with newer Autotools and related equipment.
107   * Miscellaneous small fixes for Cygwin.
108   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
109     particularly, this causes a segfault reading bit zero of a zero-length
110     integer.
111
112  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
113
114 catacomb (2.2.1.1) experimental; urgency=low
115
116   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
117     really won't work well without it.
118
119  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
120
121 catacomb (2.2.1) experimental; urgency=low
122
123   * Some internal improvements.
124   * Debian packaging cleanups (fix build-depends, update mLib dependency).
125
126  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
127
128 catacomb (2.2.0) experimental; urgency=low
129
130   * catacomb2: Fix rsa_recover crash on even modulus.
131   * catacomb-bin: Report error taking factorial of negative input.
132   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
133   * catacomb-dev: Support multiple flavours of EC point compression.
134   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
135     out of prime numbers.
136   * catacomb2: Overhaul crypto primitives used in true-random generator.
137   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
138     support.
139   * catacomb-dev: New conversions between MP integers and C integer types.
140   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
141     big-endian bytes (rather than `uint32'), and the `block size' is 4.
142   * catacomb2: Mix a constant string into DSA nonce generation to improve
143     resistance to protocol interference.
144   * catacomb2: Fix the freewheel random source, which hasn't been enabled
145     for ages due to a configure-script bug.
146   * catacomb-bin: The key tool can now read and write multiple
147     presentations for key fingerprints.
148   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
149     stream ciphers.
150
151  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
152
153 catacomb (2.1.7) experimental; urgency=low
154
155   * A number of entropy-source fixes.
156   * Internal tidying.
157   * Add more elliptic curves, from Brainpool and BADA55.
158   * hashsum: Fix hash file verification.
159
160  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
161
162 catacomb (2.1.6.1) experimental; urgency=low
163
164   * Fix building from source tarball.
165   * Fix building with Python 2.5.
166
167  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
168
169 catacomb (2.1.6) experimental; urgency=low
170
171   * mpreduce: Extend domain to all positive integers.
172   * gfreduce: Fix out-of-bounds memory access.
173   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
174   * pixie: Don't replace existing pixie unless explicitly requested.
175
176  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
177
178 catacomb (2.1.5) experimental; urgency=low
179
180   * New build system.
181
182  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
183
184 catacomb (2.1.4) experimental; urgency=low
185
186   * Constant-time operations.
187   * Some minor fixes to header files.
188
189  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
190
191 catacomb (2.1.3) experimental; urgency=low
192
193   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
194     example program.
195   * Upper bounds on phrase entropy in mkphrase(1).
196   * Don't make the Pixie setuid-root by default.  Make the documentation
197     less scary.
198
199  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
200
201 catacomb (2.1.2.1) experimental; urgency=low
202
203   * hashsum: Document `--progress' option in `--help' output.
204
205  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
206
207 catacomb (2.1.2) experimental; urgency=low
208
209   * hashsum: Correct return code when running in `-c' mode.
210   * dsig: Fix core dump on large-ish outputs.
211   * dsig: Fix repeat-close bug.
212   * dsig: Accept precomputed hashes when making signatures.
213   * Utilities: New `-p' option for progress bars.
214   * dsig, hashsum: New `-j' option checks for files not covered by
215     manifest.
216   * Various library improvements.
217
218  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
219
220 catacomb (2.1.1) experimental; urgency=low
221
222   * Do configuration through pkgconfig.
223
224  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
225
226 catacomb (2.1.0) experimental; urgency=low
227
228   * Added support for elliptic curves, on both prime and binary fields
229     (polynomial basis only).  No actual crypto, but there's enough already
230     to do ECDH and stuff on well-known curves  Testing is currently a bit
231     patchy.
232
233  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
234
235 catacomb (2.0.1) experimental; urgency=low
236
237   * Debianization!
238   * (pixie): Don't report uninteresting errors when accepting connections.
239
240  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000