chiark / gitweb /
debian/control: Don't require `valgrind' on `armel'.
[catacomb] / debian / changelog
1 catacomb (2.4.2) experimental; urgency=medium
2
3   * catacomb2: Support multi-arch at last.
4   * catacomb2: Fix mangled key-size data for HMAC.
5   * rspit: Support generating large files.
6   * pixie: Improve error-handling around dropping privilege.
7   * ed25519, ed448: Very minor performance improvement.
8   * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
9     `rspit'.
10   * salsa20, chacha: Fix declaration of cipher classes to prevent them
11     ending up as (useless) common symbols in client code.
12   * limlee: Improve the prime size heuristics.
13   * sha, sha256, sha512: Restructure compression function to improve
14     performance and use less memory.
15   * rijndael: Include enough round constants to make very tiny keys work
16     correctly.
17
18  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 01:15:59 +0100
19
20 catacomb (2.4.1) experimental; urgency=low
21
22   * catacomb2: Two's-complement fix from 2.3.x release branch.
23
24  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:37:40 +0100
25
26 catacomb (2.4.0.1) experimental; urgency=low
27
28   * Fix build failure with later ARM assemblers.
29
30  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
31
32 catacomb (2.4.0) experimental; urgency=low
33
34   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
35     code.
36   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
37     and Salsa20.
38   * catacomb2: Implement Bernstein's X25519.
39   * catacomb2: Implement Hamburg's X448 (RFC7748).
40   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
41     as defined in RFC8032.
42   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
43     RFC8032.
44   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
45   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
46   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
47   * catacomb2: Allow RSA key generation with chosen public exponent.
48   * catacomb2: Optimize RSA public-key operations with common public
49     exponents.
50   * catacomb-bin: Support new algorithms in the provided tools.
51   * catacomb-bin: Allow parameters keys for all key types.
52
53  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
54
55 catacomb (2.3.2) experimental; urgency=low
56
57   * catacomb2: Fix bignum loading and storing in two's complement form.
58
59  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
60
61 catacomb (2.3.1) experimental; urgency=low
62
63   * catacomb2: Fix memory corruption when allocating `salsa20' and
64     `chacha'-based RNGs.
65   * catacomb2: Fix segfault when opening read-only keyring with no
66     associated file.
67   * catacomb2: Return the correct stream offset in `chacha_tell*'.
68   * catacomb2: Produce correct keyring files when they contain empty
69     keys.
70   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
71     and binary group implementations.
72   * catacomb-dev: Add missing licence notices to `salsa20.h'.
73   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
74   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
75     verifying.
76   * catacomb-bin: Compare MAC tags in constant time.
77   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
78
79  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
80
81 catacomb (2.3.0.1) experimental; urgency=low
82
83   * catacomb2: Actually make the stack non-executable rather than just
84     pretending.
85
86  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
87
88 catacomb (2.3.0) experimental; urgency=low
89
90   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
91     was a duplicate of the Oakley 1536 group.  There's a compatibility
92     break here, but it's for the best.
93   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
94     so that the process stack doesn't get marked executable.
95   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
96   * catacomb2: Lots of other improvements to the assembler code.
97
98  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
99
100 catacomb (2.2.5) experimental; urgency=low
101
102   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
103     is unaligned.
104   * build: Use less obsolete macro names in configure script.
105
106  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
107
108 catacomb (2.2.4) experimental; urgency=low
109
110   * build: Fix build failures on post-wheezy Debian versions.
111   * catacomb2: Use ARM AES instructions if available.  (But they can't be
112     assembled using wheezy's version of gas, so this doesn't work in the
113     binary package.)
114   * catacomb2: Fix poor performance (and wrong answers for very small
115     numbers) in prime generation.
116   * catacomb2: Return numbers of exactly the requested length in prime and
117     public-key generation.  The `strongprime' and `limlee' algorithms have
118     changed as a result; previously verifiable parameters generated using
119     this algorithm won't be verifiable any more.
120   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
121
122  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
123
124 catacomb (2.2.3) experimental; urgency=low
125
126   * rand: Make the main generator resiliant in the face of fork(2).
127   * rand: Introduce `rand_quick', which may also mix in CPU-level
128     randomness sources.
129   * rand: Use higher-resolution timer in the quick-win noise source.
130   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
131     which got lost down the side of the sofas.
132
133  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
134
135 catacomb (2.2.2) experimental; urgency=low
136
137   * build: Cope with newer Autotools and related equipment.
138   * Miscellaneous small fixes for Cygwin.
139   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
140     particularly, this causes a segfault reading bit zero of a zero-length
141     integer.
142
143  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
144
145 catacomb (2.2.1.1) experimental; urgency=low
146
147   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
148     really won't work well without it.
149
150  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
151
152 catacomb (2.2.1) experimental; urgency=low
153
154   * Some internal improvements.
155   * Debian packaging cleanups (fix build-depends, update mLib dependency).
156
157  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
158
159 catacomb (2.2.0) experimental; urgency=low
160
161   * catacomb2: Fix rsa_recover crash on even modulus.
162   * catacomb-bin: Report error taking factorial of negative input.
163   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
164   * catacomb-dev: Support multiple flavours of EC point compression.
165   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
166     out of prime numbers.
167   * catacomb2: Overhaul crypto primitives used in true-random generator.
168   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
169     support.
170   * catacomb-dev: New conversions between MP integers and C integer types.
171   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
172     big-endian bytes (rather than `uint32'), and the `block size' is 4.
173   * catacomb2: Mix a constant string into DSA nonce generation to improve
174     resistance to protocol interference.
175   * catacomb2: Fix the freewheel random source, which hasn't been enabled
176     for ages due to a configure-script bug.
177   * catacomb-bin: The key tool can now read and write multiple
178     presentations for key fingerprints.
179   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
180     stream ciphers.
181
182  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
183
184 catacomb (2.1.7) experimental; urgency=low
185
186   * A number of entropy-source fixes.
187   * Internal tidying.
188   * Add more elliptic curves, from Brainpool and BADA55.
189   * hashsum: Fix hash file verification.
190
191  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
192
193 catacomb (2.1.6.1) experimental; urgency=low
194
195   * Fix building from source tarball.
196   * Fix building with Python 2.5.
197
198  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
199
200 catacomb (2.1.6) experimental; urgency=low
201
202   * mpreduce: Extend domain to all positive integers.
203   * gfreduce: Fix out-of-bounds memory access.
204   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
205   * pixie: Don't replace existing pixie unless explicitly requested.
206
207  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
208
209 catacomb (2.1.5) experimental; urgency=low
210
211   * New build system.
212
213  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
214
215 catacomb (2.1.4) experimental; urgency=low
216
217   * Constant-time operations.
218   * Some minor fixes to header files.
219
220  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
221
222 catacomb (2.1.3) experimental; urgency=low
223
224   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
225     example program.
226   * Upper bounds on phrase entropy in mkphrase(1).
227   * Don't make the Pixie setuid-root by default.  Make the documentation
228     less scary.
229
230  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
231
232 catacomb (2.1.2.1) experimental; urgency=low
233
234   * hashsum: Document `--progress' option in `--help' output.
235
236  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
237
238 catacomb (2.1.2) experimental; urgency=low
239
240   * hashsum: Correct return code when running in `-c' mode.
241   * dsig: Fix core dump on large-ish outputs.
242   * dsig: Fix repeat-close bug.
243   * dsig: Accept precomputed hashes when making signatures.
244   * Utilities: New `-p' option for progress bars.
245   * dsig, hashsum: New `-j' option checks for files not covered by
246     manifest.
247   * Various library improvements.
248
249  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
250
251 catacomb (2.1.1) experimental; urgency=low
252
253   * Do configuration through pkgconfig.
254
255  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
256
257 catacomb (2.1.0) experimental; urgency=low
258
259   * Added support for elliptic curves, on both prime and binary fields
260     (polynomial basis only).  No actual crypto, but there's enough already
261     to do ECDH and stuff on well-known curves  Testing is currently a bit
262     patchy.
263
264  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
265
266 catacomb (2.0.1) experimental; urgency=low
267
268   * Debianization!
269   * (pixie): Don't report uninteresting errors when accepting connections.
270
271  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000