chiark / gitweb /
pub/dh-kcdsa.c: Choose the cofactor size correctly.
[catacomb] / debian / changelog
1 catacomb (2.5.99~) experimental; urgency=medium
2
3   * (placeholder for next minor release)
4
5  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 30 Sep 2019 02:15:20 +0100
6
7 catacomb (2.5.2) experimental; urgency=medium
8
9   * Merge changes from 2.4.5.
10   * catacomb-dev: Fix ARM32 FP/SIMD register dumping.
11
12  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 20:50:57 +0100
13
14 catacomb (2.5.1) experimental; urgency=medium
15
16   * Merge changes from 2.4.4.
17
18  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 17:50:59 +0100
19
20 catacomb (2.5.0) experimental; urgency=medium
21
22   * catacomb: MACs based on blockciphers: PMAC1 and CMAC (also known as
23     OMAC).
24   * catacomb: Authenticated Encryption with Additional Data (AEAD)
25     schemes.  Some based on blockciphers: CCM, EAX, GCM (with CPU-specific
26     acceleration), OCB1 and OCB3 (OCB2 is broken).  Also Salsa20 and
27     ChaCha20 with Poly1305: the RFC7539 scheme, and the NaCl `secret_box'
28     transform.
29   * catacomb: Implement Grantham's Frobenius test.  Combine it with
30     Rabin--Miller, as Baillie--PSW, for testing given primes.
31   * catacomb-bin (catcrypt): Support AEAD schemes for bulk crypto.
32   * catacomb-bin (perftest): Options for batching; report cycle counts
33     where available.
34   * Many internal improvements: better documentation, debugging, testing,
35     etc.
36
37  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 21:26:44 +0100
38
39 catacomb (2.4.5) experimental; urgency=medium
40
41   * catacomb: Fix memory leak in key-file error handling.
42   * catacomb: Don't leak internal `exptime' symbol into the global
43     namespace.
44   * catacomb: Check that the X86 `rdrand' instruction actually works
45     before leaning on it.  This is in response to the well-publicized AMD
46     bug which always returns all-bits-set with the carry /set/ (indicating
47     success).
48   * catacomb: Mix in the random pool key during `rand_gate' and
49     `rand_stretch' operations.
50   * catacomb: Fix by-tag key lookups: if the query string looks like a hex
51     number, it's treated as a search by id; but if no such id is found,
52     the search wouldn't continue to look for a key by type or tag.
53   * catacomb: Fix reference leak in `key_split'.
54   * catacomb: Fix bug which completely broke `key_copydata'.
55   * catacomb: Fix segfault from `pgen', if it fails before setting up the
56     prime tester.
57   * catacomb: Propagate failure from `pgen' during Lim--Lee prime
58     generation, rather than immediately retrying.
59   * catacomb: Fix memory leak of factor vector from failed Lim--Lee prime
60     generation.
61   * catacomb: Fix segfault when multiplying the identity elliptic-curve
62     point.
63   * catacomb: Fix the `lcrand' descriptor, so that it's not advertised as
64     being cryptographically strong, and to fix a bias in its output.
65   * catacomb: Fix a memory leak in the error case of KCDSA prime
66     generation.
67   * catacomb-bin: Fix segfault from `pixie', if given an empty passphrase
68     to remember.
69   * catacomb: Check SIMD feature bit on ARM64 before using the optimized
70     code.  I don't know of any ARM64 implementations which lack SIMD
71     instructions, but the bit must be there for a reason, so I might as
72     well use it.
73   * catacomb: Support parsing binary-group descriptions.  This is a long-
74     standing lacuna that I've only recently noticed.
75
76  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 09 May 2020 17:46:24 +0100
77
78 catacomb (2.4.4) experimental; urgency=medium
79
80   * debian: Bump to Debhelper 10.
81   * debian: Ship a shared-library `symbols' file for more precise
82     dependencies.
83
84  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 29 Sep 2019 15:58:26 +0100
85
86 catacomb (2.4.3) experimental; urgency=medium
87
88   * catacomb (idea): Fix key-length descriptor.
89   * catacomb (xchachaNN): Fix nonce-size descriptor.
90   * catacomb (key-management): Fix incorrect handling of keyring
91     modifiability.
92   * catacomb-dev: Configure `pkg-config' correctly for static linking.
93   * catacomb, catacomb-bin (cookie, dsig): Fix hash-function length
94     padding on very long messages, and handling of large datestamps.
95   * catacomb-bin (catsign): Don't open temporary files unnecessarily.
96   * catacomb-bin (catcrypt): Fix key-attribute parsing.
97   * catacomb-bin (perftest): Add missing help-string text for `-n' used
98     with `enc' and `hash'
99
100  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 21 Sep 2019 17:43:59 +0100
101
102 catacomb (2.4.2) experimental; urgency=medium
103
104   * catacomb2: Support multi-arch at last.
105   * catacomb2: Fix mangled key-size data for HMAC.
106   * rspit: Support generating large files.
107   * pixie: Improve error-handling around dropping privilege.
108   * ed25519, ed448: Very minor performance improvement.
109   * salsa20, chacha: Fix crash if nonce is none, as it is when invoked by
110     `rspit'.
111   * salsa20, chacha: Fix declaration of cipher classes to prevent them
112     ending up as (useless) common symbols in client code.
113   * limlee: Improve the prime size heuristics.
114   * sha, sha256, sha512: Restructure compression function to improve
115     performance and use less memory.
116   * rijndael: Include enough round constants to make very tiny keys work
117     correctly.
118
119  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jun 2018 01:15:59 +0100
120
121 catacomb (2.4.1) experimental; urgency=low
122
123   * catacomb2: Two's-complement fix from 2.3.x release branch.
124
125  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:37:40 +0100
126
127 catacomb (2.4.0.1) experimental; urgency=low
128
129   * Fix build failure with later ARM assemblers.
130
131  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 21:05:35 +0100
132
133 catacomb (2.4.0) experimental; urgency=low
134
135   * catacomb2: Implemented Bernstein's Poly1305 message-authentication
136     code.
137   * catacomb2: Support RFC7539's different nonce/counter split in ChaCha
138     and Salsa20.
139   * catacomb2: Implement Bernstein's X25519.
140   * catacomb2: Implement Hamburg's X448 (RFC7748).
141   * catacomb2: Implement Bernstein, Duif, Lange, Schwabe, Yang's Ed25519,
142     as defined in RFC8032.
143   * catacomb2: Implement Ed448, based on Hamburg's curve, as defined in
144     RFC8032.
145   * catacomb2: Implement Keccak-p[1600, n] as defined in FIPS202.
146   * catacomb2: Implement SHA3, SHAKE, as defined in FIPS202.
147   * catacomb2: Implement cSHAKE, KMAC, as defined in SP800-185.
148   * catacomb2: Allow RSA key generation with chosen public exponent.
149   * catacomb2: Optimize RSA public-key operations with common public
150     exponents.
151   * catacomb-bin: Support new algorithms in the provided tools.
152   * catacomb-bin: Allow parameters keys for all key types.
153
154  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 16:07:00 +0100
155
156 catacomb (2.3.2) experimental; urgency=low
157
158   * catacomb2: Fix bignum loading and storing in two's complement form.
159
160  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 22 Jun 2017 09:34:59 +0100
161
162 catacomb (2.3.1) experimental; urgency=low
163
164   * catacomb2: Fix memory corruption when allocating `salsa20' and
165     `chacha'-based RNGs.
166   * catacomb2: Fix segfault when opening read-only keyring with no
167     associated file.
168   * catacomb2: Return the correct stream offset in `chacha_tell*'.
169   * catacomb2: Produce correct keyring files when they contain empty
170     keys.
171   * catacomb2: Fix cross-compilation-unit type incompatibility in prime
172     and binary group implementations.
173   * catacomb-dev: Add missing licence notices to `salsa20.h'.
174   * catacomb-bin: Fix assertion failure in RSA-PSS signing.
175   * catacomb-bin: Fix uninitialized structure slot in RSA-PSS signing and
176     verifying.
177   * catacomb-bin: Compare MAC tags in constant time.
178   * catacomb2: Fix a (minor) source of bias in BBS and RSA key generation.
179
180  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 14 May 2017 04:05:00 +0100
181
182 catacomb (2.3.0.1) experimental; urgency=low
183
184   * catacomb2: Actually make the stack non-executable rather than just
185     pretending.
186
187  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 05 Apr 2017 09:00:55 +0100
188
189 catacomb (2.3.0) experimental; urgency=low
190
191   * catacomb2: Use the correct Oakley 2048 group.  For a long time, this
192     was a duplicate of the Oakley 1536 group.  There's a compatibility
193     break here, but it's for the best.
194   * catacomb2: Include `.note.GNU-stack' sections in the assembler code,
195     so that the process stack doesn't get marked executable.
196   * catacomb2: New SSE2-based multipliers for i386 and AMD64.
197   * catacomb2: Lots of other improvements to the assembler code.
198
199  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 03 Apr 2017 10:24:17 +0100
200
201 catacomb (2.2.5) experimental; urgency=low
202
203   * catacomb2 (ARM AES): Fix crash from `rijndael*_init' when key material
204     is unaligned.
205   * build: Use less obsolete macro names in configure script.
206
207  -- Mark Wooding <mdw@distorted.org.uk>  Tue, 12 Jul 2016 10:27:05 +0100
208
209 catacomb (2.2.4) experimental; urgency=low
210
211   * build: Fix build failures on post-wheezy Debian versions.
212   * catacomb2: Use ARM AES instructions if available.  (But they can't be
213     assembled using wheezy's version of gas, so this doesn't work in the
214     binary package.)
215   * catacomb2: Fix poor performance (and wrong answers for very small
216     numbers) in prime generation.
217   * catacomb2: Return numbers of exactly the requested length in prime and
218     public-key generation.  The `strongprime' and `limlee' algorithms have
219     changed as a result; previously verifiable parameters generated using
220     this algorithm won't be verifiable any more.
221   * catacomb-dev: Deprecate the old `dsa' functions.  Use `gdsa' instead.
222
223  -- Mark Wooding <mdw@distorted.org.uk>  Sun, 26 Jun 2016 14:18:14 +0100
224
225 catacomb (2.2.3) experimental; urgency=low
226
227   * rand: Make the main generator resiliant in the face of fork(2).
228   * rand: Introduce `rand_quick', which may also mix in CPU-level
229     randomness sources.
230   * rand: Use higher-resolution timer in the quick-win noise source.
231   * debian: Pick up correct `catacomb-dev' Depends entry from 2.2.1.1
232     which got lost down the side of the sofas.
233
234  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 13 Jun 2016 22:22:33 +0100
235
236 catacomb (2.2.2) experimental; urgency=low
237
238   * build: Cope with newer Autotools and related equipment.
239   * Miscellaneous small fixes for Cygwin.
240   * catacomb2 (mp_testbit): Fix overread on reading one-bit-past-the-end;
241     particularly, this causes a segfault reading bit zero of a zero-length
242     integer.
243
244  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 04 Jun 2016 01:12:01 +0100
245
246 catacomb (2.2.1.1) experimental; urgency=low
247
248   * Arrange that catacomb-dev Depends on correct version of mlib-dev.  It
249     really won't work well without it.
250
251  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 19 Feb 2016 09:04:50 +0000
252
253 catacomb (2.2.1) experimental; urgency=low
254
255   * Some internal improvements.
256   * Debian packaging cleanups (fix build-depends, update mLib dependency).
257
258  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 18 Feb 2016 16:43:09 +0000
259
260 catacomb (2.2.0) experimental; urgency=low
261
262   * catacomb2: Fix rsa_recover crash on even modulus.
263   * catacomb-bin: Report error taking factorial of negative input.
264   * catacomb2: Fix EC_FIND and EC_NEG on 2-torsion points of prime curves.
265   * catacomb-dev: Support multiple flavours of EC point compression.
266   * catacomb2: Fix theoretical rsa_recover crash if factoring loop runs
267     out of prime numbers.
268   * catacomb2: Overhaul crypto primitives used in true-random generator.
269   * catacomb-bin: Improve rspit: high-resolution timing, and 64-bit size
270     support.
271   * catacomb-dev: New conversions between MP integers and C integer types.
272   * catacomb2: Change gcipher for Seal incompatibly.  The IV is now
273     big-endian bytes (rather than `uint32'), and the `block size' is 4.
274   * catacomb2: Mix a constant string into DSA nonce generation to improve
275     resistance to protocol interference.
276   * catacomb2: Fix the freewheel random source, which hasn't been enabled
277     for ages due to a configure-script bug.
278   * catacomb-bin: The key tool can now read and write multiple
279     presentations for key fingerprints.
280   * catacomb2, catacomb-dev: Support Daniel Bernstein's Salsa20 and ChaCha
281     stream ciphers.
282
283  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 20 Jul 2015 14:15:31 +0100
284
285 catacomb (2.1.7) experimental; urgency=low
286
287   * A number of entropy-source fixes.
288   * Internal tidying.
289   * Add more elliptic curves, from Brainpool and BADA55.
290   * hashsum: Fix hash file verification.
291
292  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 16 Jul 2014 10:21:23 +0100
293
294 catacomb (2.1.6.1) experimental; urgency=low
295
296   * Fix building from source tarball.
297   * Fix building with Python 2.5.
298
299  -- Mark Wooding <mdw@distorted.org.uk>  Sat, 28 Dec 2013 14:21:36 +0000
300
301 catacomb (2.1.6) experimental; urgency=low
302
303   * mpreduce: Extend domain to all positive integers.
304   * gfreduce: Fix out-of-bounds memory access.
305   * gcd: Don't clobber signs of `constants' when GCD calculation is trivial.
306   * pixie: Don't replace existing pixie unless explicitly requested.
307
308  -- Mark Wooding <mdw@distorted.org.uk>  Fri, 27 Dec 2013 14:28:57 +0000
309
310 catacomb (2.1.5) experimental; urgency=low
311
312   * New build system.
313
314  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 29 Jun 2013 00:38:58 +0100
315
316 catacomb (2.1.4) experimental; urgency=low
317
318   * Constant-time operations.
319   * Some minor fixes to header files.
320
321  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 27 May 2013 22:34:23 +0100
322
323 catacomb (2.1.3) experimental; urgency=low
324
325   * Fibonacci sequence computation: mp_fibonacci function and fibonacci(1)
326     example program.
327   * Upper bounds on phrase entropy in mkphrase(1).
328   * Don't make the Pixie setuid-root by default.  Make the documentation
329     less scary.
330
331  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 11 Apr 2013 12:06:28 +0100
332
333 catacomb (2.1.2.1) experimental; urgency=low
334
335   * hashsum: Document `--progress' option in `--help' output.
336
337  -- Mark Wooding <mdw@distorted.org.uk>  Thu, 28 Feb 2013 17:35:49 +0000
338
339 catacomb (2.1.2) experimental; urgency=low
340
341   * hashsum: Correct return code when running in `-c' mode.
342   * dsig: Fix core dump on large-ish outputs.
343   * dsig: Fix repeat-close bug.
344   * dsig: Accept precomputed hashes when making signatures.
345   * Utilities: New `-p' option for progress bars.
346   * dsig, hashsum: New `-j' option checks for files not covered by
347     manifest.
348   * Various library improvements.
349
350  -- Mark Wooding <mdw@distorted.org.uk>  Wed, 09 Jan 2013 03:26:44 +0000
351
352 catacomb (2.1.1) experimental; urgency=low
353
354   * Do configuration through pkgconfig.
355
356  -- Mark Wooding <mdw@distorted.org.uk>  Mon, 17 Mar 2008 18:36:30 +0000
357
358 catacomb (2.1.0) experimental; urgency=low
359
360   * Added support for elliptic curves, on both prime and binary fields
361     (polynomial basis only).  No actual crypto, but there's enough already
362     to do ECDH and stuff on well-known curves  Testing is currently a bit
363     patchy.
364
365  -- Mark Wooding <mdw@nsict.org>  Sun, 21 Mar 2004 22:47:56 +0000
366
367 catacomb (2.0.1) experimental; urgency=low
368
369   * Debianization!
370   * (pixie): Don't report uninteresting errors when accepting connections.
371
372  -- Mark Wooding <mdw@nsict.org>  Thu, 11 Dec 2003 10:47:59 +0000