chiark / gitweb /
debian/rules: Add -ffile-prefix-map to CC call to avoid embedding build paths.
[bible-kjv.git] / debian / rules
index 64fdebbda86332cbcc33c09da799646683e7863b..57e8174b743adabf3c6113183315dba644068520 100755 (executable)
@@ -23,7 +23,7 @@ build:
        dpkg-architecture -a$(DEB_BUILD_ARCH) -f -c dh_auto_build --no-parallel -- bible-index.c bible.data bible.data.conc 'LD=$$(CC)'
        rm -f *.o
        dh_auto_build --no-parallel -- bible 'LD=$$(CC)'
-       cd debian && $(CC) -g -O2 -o randverse randverse.c
+       cd debian && $(CC) -g -O2 -ffile-prefix-map=$(CURDIR)=. -o randverse randverse.c
        touch build
 
 build-arch: build