chiark / gitweb /
polkit: actually generate new InteractiveAuthorizationRequired error on the right...
authorLennart Poettering <lennart@poettering.net>
Tue, 28 Oct 2014 14:11:39 +0000 (15:11 +0100)
committerLennart Poettering <lennart@poettering.net>
Tue, 28 Oct 2014 14:11:39 +0000 (15:11 +0100)
src/libsystemd/sd-bus/bus-util.c

index b8559e9..43acf5b 100644 (file)
@@ -382,6 +382,9 @@ int bus_verify_polkit_async(
                 if (authorized)
                         return 1;
 
+                if (challenge)
+                        return sd_bus_error_set(error, SD_BUS_ERROR_INTERACTIVE_AUTHORIZATION_REQUIRED, "Interactive authentication required.");
+
                 return -EACCES;
         }
 #endif