chiark / gitweb /
Factor out common files to fix multi-arch installs
authorAndreas Messer <andi@bastelmap.de>
Sun, 7 Jan 2018 10:12:51 +0000 (11:12 +0100)
committerAndreas Messer <andi@bastelmap.de>
Sun, 7 Jan 2018 10:12:51 +0000 (11:12 +0100)
debian/control
debian/elogind-data.install [new file with mode: 0644]
debian/libelogind0.install

index 98229f5..ebb7ce5 100644 (file)
@@ -36,6 +36,7 @@ Multi-Arch: foreign
 Pre-Depends: debconf, ${misc:Pre-Depends}
 Depends: ${shlibs:Depends},
          ${misc:Depends},
+         elogind-data (= ${binary:Version}),
          libelogind0 (= ${binary:Version}),
          libpam-elogind (= ${binary:Version}),
          lsb-base (>= 3.1),
@@ -43,8 +44,8 @@ Depends: ${shlibs:Depends},
 Recommends: policykit-1
 Conflicts: openrc
 Description: user, seat and session management daemon
 elogind is a session management daemon extracted from systmd project's 
 "logind"
+ elogind is a session management daemon extracted from systmd project's 
+ "logind"
 
 Package: libelogind0
 Section: libs
@@ -54,8 +55,19 @@ Multi-Arch: same
 Pre-Depends: ${misc:Pre-Depends}
 Depends: ${shlibs:Depends},
          ${misc:Depends},
+         elogind-data (= ${binary:Version})
 Description: user, seat and session management library
-  This library provides access to elogind session management
+ This library provides access to elogind session management
+
+Package: elogind-data
+Section: admin
+Priority: optional
+Architecture: all
+Pre-Depends: ${misc:Pre-Depends}
+Depends: ${shlibs:Depends},
+         ${misc:Depends},
+Description: user, seat and session management - common files
+ Common files of elogind
 
 Package: libelogind-dev
 Section: libdevel
@@ -67,8 +79,8 @@ Depends: ${shlibs:Depends},
          ${misc:Depends},
          libelogind0 (= ${binary:Version})
 Description: user, seat and session management library (development files)
 This package contains the files needed for developing applications that 
 use libelogind
+ This package contains the files needed for developing applications that 
+ use libelogind
 
 Package: libpam-elogind
 Section: admin
@@ -78,8 +90,9 @@ Multi-Arch: same
 Pre-Depends:  ${misc:Pre-Depends}
 Depends: ${shlibs:Depends},
          ${misc:Depends},
-         libpam-runtime
+         libpam-runtime,
+         elogind-data (= ${binary:Version})
 Provides: libpam-systemd
 Description: elogind PAM module 
 Plugable Authentication Module to register a session with elogind
+ Plugable Authentication Module to register a session with elogind
 
diff --git a/debian/elogind-data.install b/debian/elogind-data.install
new file mode 100644 (file)
index 0000000..3635480
--- /dev/null
@@ -0,0 +1 @@
+usr/share/locale
index 1a0e7e1..01d84bd 100644 (file)
@@ -1,2 +1 @@
 usr/lib/*/libelogind.so.*
-usr/share/locale