chiark / gitweb /
build-sys: support non-git versions of libcgroup
authorMaarten Lankhorst <m.b.lankhorst@gmail.com>
Thu, 6 May 2010 19:30:01 +0000 (21:30 +0200)
committerLennart Poettering <lennart@poettering.net>
Thu, 6 May 2010 19:30:01 +0000 (21:30 +0200)
configure.ac

index 044dc6f..f4e1036 100644 (file)
@@ -65,7 +65,23 @@ PKG_CHECK_MODULES(GTK, [ gtk+-2.0 ])
 AC_SUBST(GTK_CFLAGS)
 AC_SUBST(GTK_LIBS)
 
-PKG_CHECK_MODULES(CGROUP, [ libcgroup ])
+PKG_CHECK_MODULES( CGROUP, [ libcgroup >= 0.35 ], [],
+    [AC_CHECK_HEADER( [libcgroup.h], [], [AC_MSG_ERROR([*** libcgroup.h not found])], )
+     save_CPPFLAGS="$CPPFLAGS"
+     save_LIBS="$LIBS"
+     CGROUP_LIBS=${CGROUP_LIBS:--lcgroup}
+     LIBS="$LIBS $CGROUP_LIBS"
+     CPPFLAGS="$CPPFLAGS $CGROUP_CFLAGS"
+     AC_MSG_CHECKING([for libcgroup >= 0.35])
+     AC_LINK_IFELSE(
+         [AC_LANG_PROGRAM([[#include <libcgroup.h>]], [[ CGFLAG_DELETE_RECURSIVE; cgroup_init(); ]])],
+         [AC_MSG_RESULT([yes])],
+         [AC_MSG_RESULT([no]); AC_MSG_ERROR([*** systemd needs libcgroup 0.35 or newer])],
+         [${CGROUP_LIBS}])
+     CPPFLAGS="$save_CPPFLAGS"
+     LIBS="$save_LIBS"
+    ])
+
 AC_SUBST(CGROUP_CFLAGS)
 AC_SUBST(CGROUP_LIBS)