chiark / gitweb /
README: update requirements
authorLennart Poettering <lennart@poettering.net>
Wed, 16 Feb 2011 18:09:11 +0000 (19:09 +0100)
committerLennart Poettering <lennart@poettering.net>
Wed, 16 Feb 2011 18:34:38 +0000 (19:34 +0100)
README

diff --git a/README b/README
index e38c19b..0e5532a 100644 (file)
--- a/README
+++ b/README
@@ -30,9 +30,27 @@ REQUIREMENTS:
         Linux kernel >= 2.6.30 (with autofs4, devtmpfs, cgroups)
         libudev >= 163
         dbus >= 1.4.0
         Linux kernel >= 2.6.30 (with autofs4, devtmpfs, cgroups)
         libudev >= 163
         dbus >= 1.4.0
+        libcap
+        gtk+ >= 2.20 (optional)
+        PAM >= 1.1.2 (optional)
+        libcryptsetup (optional)
+        libaudit (optional)
+        libselinux (optional)
+        tcpwrappers (optional)
+        libnotify (optional)
+
+        When you build from git you need the following additional dependencies:
+
         vala >= 0.10
         vala >= 0.10
+        docbook-xsl
+        xsltproc
+        automake
+        autoconf
+        libtool
+
+        During runtime you need the following dependencies:
+
         util-linux > v2.18 (requires fsck -l, agetty -s)
         sulogin (from sysvinit-tools)
         util-linux > v2.18 (requires fsck -l, agetty -s)
         sulogin (from sysvinit-tools)
-        gtk+ >= 2.20
-        libcap
-        PAM >= 1.1.2 (optional)
+        plymouth (optional)
+        dracut (optional)