chiark / gitweb /
[PATCH] udev spec file update
[elogind.git] / udev.spec
1 # if we want to build against the included version of klibc or not.
2 # 0 - do not use klibc
3 # 1 - use klibc
4 # Watch out for where the linux symlink is in the klibc part of the tarball,
5 # it probably is not where you want it to be.
6 %define klibc 1
7
8 # if we want to build DBUS support in or not.
9 # 0 - no DBUS support
10 # 1 - DBUS support
11 %define dbus 0
12
13 # if we want to enable debugging support in udev.  If it is enabled, lots of 
14 # stuff will get sent to the debug syslog.
15 # 0 - debugging disabled
16 # 1 - debugging enabled
17 %define debug 0
18
19 Summary: A userspace implementation of devfs
20 Name: udev
21 Version: 011_bk
22 Release: 1
23 License: GPL
24 Group: Utilities/System
25 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
26 ExclusiveOS: Linux
27 Vendor: Greg Kroah-Hartman <greg@kroah.com>
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29 Prereq: /bin/sh, fileutils, hotplug
30
31 %description
32 udev is a implementation of devfs in userspace using sysfs and
33 /sbin/hotplug. It requires a 2.6 kernel to run properly.
34
35 %prep
36 %setup -q
37
38 %build
39 make CC="gcc $RPM_OPT_FLAGS"    \
40 %if %{klibc}
41         USE_KLIBC=true          \
42 %endif
43 %if %{dbus}
44         USE_DBUS=true           \
45 %endif
46 %if %{debug}
47         DEBUG=true              \
48 %endif
49
50 %install
51 make DESTDIR=$RPM_BUILD_ROOT install \
52 %if %{dbus}
53         USE_DBUS=true
54 %endif
55
56 %post
57 /sbin/chkconfig --add udev
58
59 %postun
60 if [ $1 = 0 ]; then
61         /sbin/chkconfig --del udev
62 fi
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(-,root,root)
69 %doc COPYING README TODO ChangeLog
70 %attr(755,root,root) /sbin/udev
71 %attr(755,root,root) /udev/
72 %attr(755,root,root) /etc/udev/
73 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.conf
74 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.rules
75 %config(noreplace) %attr(0644,root,root) /etc/udev/udev.permissions
76 %if %{dbus}
77         %config(noreplace) %attr(0644,root,root) /etc/dbus-1/system.d/udev_sysbus_policy.conf
78 %endif
79 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
80 %attr(755,root,root) /etc/init.d/udev
81 %attr(0644,root,root) %{_mandir}/man8/udev.8*
82
83 %changelog
84 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
85 - install the initscript and run chkconfig on it
86
87 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
88 - changes due to config file name changes
89
90 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
91 - Make work without a build root
92 - Correctly install the right files
93 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
94 - Put some prereqs in
95 - Install the hotplug symlink to udev
96
97 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
98 - Initial spec file for udev-0.2.
99