chiark / gitweb /
[PATCH] install initscript in udev rpm
[elogind.git] / udev.spec
1 Summary: A userspace implementation of devfs
2 Name: udev
3 Version: 008_bk
4 Release: 1
5 License: GPL
6 Group: Utilities/System
7 Source: ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/%{name}-%{version}.tar.gz
8 ExclusiveOS: Linux
9 Vendor: Greg Kroah-Hartman <greg@kroah.com>
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11 Prereq: /bin/sh, fileutils, hotplug
12
13 %description
14 udev is a implementation of devfs in userspace using sysfs and
15 /sbin/hotplug. It requires a 2.6 kernel to run properly.
16
17 %prep
18 %setup -q
19
20 %build
21 make CC="gcc $RPM_OPT_FLAGS"
22
23 %install
24 make DESTDIR=$RPM_BUILD_ROOT install
25
26 %post
27 /sbin/chkconfig --add udev
28
29 %clean
30 rm -rf $RPM_BUILD_ROOT
31
32 %files
33 %defattr(0644,root,root)
34 %doc COPYING README TODO ChangeLog
35 %attr(755,root,root) /sbin/udev
36 %attr(755,root,root) /udev/
37 %attr(755,root,root) /etc/udev/
38 %attr(0644,root,root) /etc/udev/udev.conf
39 %attr(0644,root,root) /etc/udev/udev.rules
40 %attr(0644,root,root) /etc/udev/udev.permissions
41 %attr(-,root,root) /etc/hotplug.d/default/udev.hotplug
42 %attr(755,root,root) /etc/init.d/udev
43 %attr(0644,root,root) %{_mandir}/man8/udev.8*
44
45 %changelog
46 * Tue Dec 16 2003 Robert Love <rml@ximian.com>
47 - install the initscript and run chkconfig on it
48
49 * Tue Nov 2 2003 Greg Kroah-Hartman <greg@kroah.com>
50 - changes due to config file name changes
51
52 * Fri Oct 17 2003 Robert Love <rml@tech9.net>
53 - Make work without a build root
54 - Correctly install the right files
55 - Pass the RPM_OPT_FLAGS to gcc so we can build per the build policy
56 - Put some prereqs in
57 - Install the hotplug symlink to udev
58
59 * Mon Jul 28 2003 Paul Mundt <lethal@linux-sh.org>
60 - Initial spec file for udev-0.2.
61