chiark / gitweb /
Add dose-builddebcheck to buildd.debian.org.
[dsa-metapackages.git] / debian / control
index 579ab29..a7de1b4 100644 (file)
@@ -8,7 +8,7 @@ Standards-Version: 3.8.1
 
 Package: debian.org
 Architecture: all
-Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
+Depends: userdir-ldap, zsh, tcsh, pdksh, ksh, csh, ntp, locales-all, exim4-daemon-heavy | postfix, sudo, libpam-pwdfile, vim, nano, munin-node, gnupg, bzip2, cacert-spi | ca-certificates (>> 20080411), ed, cron, dialog, libterm-readline-gnu-perl, logrotate, syslog-ng (>= 3.1), nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic
 Recommends: debian.org-recommended
 Conflicts: dchroot-dsa (<= 2:1)
 Description: DSA's host metapackage
@@ -20,16 +20,22 @@ Package: debian.org-recommended-linux
 Architecture: all
 Depends: vlan, ifenslave, bridge-utils, iproute,
        strace,
-       lsscsi
+       lsscsi,
+       ethtool,
+       bwm-ng,
+       iputils-tracepath,
+       traceroute,
+       lshw,
+       lsof
 Description: metapackage to pull in recommended, but not essential tools for linux system
  This package depends on packages that are recommended to  be installed on
  every Linux debian.org host but are not essential.
 
 Package: debian.org-recommended
-Architecture: all
+Architecture: any
 Depends: debian.org,
        busybox-static,
-       debian.org-recommended-linux | not+gnu-linux,
+       debian.org-recommended-linux [linux-any],
        molly-guard
        ,
        man-db
@@ -41,11 +47,10 @@ Depends: debian.org,
                cvs
        ,
        mtr-tiny, tcpdump, tcptraceroute, ndisc6,
-       traceroute | not+gnu-linux,
-       iputils-tracepath | not+gnu-linux,
        bind9-host, dnsutils, whois, unbound-host
        ,
-       emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21
+       emacs23-nox | emacs23 | emacs22-nox | emacs22 | emacs21-nox | emacs21,
+       vim-scripts, vim-addon-manager
        ,
        at, uptimed,
        puppet,
@@ -57,18 +62,14 @@ Depends: debian.org,
        ,
        dsa-nagios-checks
        ,
-       lshw | not+gnu-linux,
-       dmidecode | not+amd64,
-       dmidecode | not+i386,
-       dmidecode | not+ia64
+       dmidecode [amd64 i386 ia64], 
+       sg3-utils
        ,
        ipython
        ,
-       mcelog | not+amd64 | not+gnu-linux,
-       mcelog | not+i386 | not+gnu-linux,
+       mcelog [amd64 i386]
        ,
        htop, psmisc,
-       lsof | not+gnu-linux,
        ,
        ncdu,
        mc,
@@ -118,6 +119,7 @@ Package: debian.org-bugs.debian.org
 Architecture: all
 Depends: graphviz,
        libcgi-simple-perl,
+       libgravatar-url-perl,
        libio-stringy-perl,
        liblist-moreutils-perl,
        libmail-rfc822-address-perl,
@@ -129,6 +131,7 @@ Depends: graphviz,
        liburi-perl,
        libhtml-tree-perl,
        libsoap-lite-perl,
+       libtext-iconv-perl,
        libdbd-pg-perl,
        python-pyinotify,
        python-yaml
@@ -136,6 +139,27 @@ Description: metapackages for bugs.debian.org dependencies
  This package depends on everything that is needed for a bugs.debian.org
  mirror or (in the future) bugs-master.
 
+Package: debian.org-bugs.debian.org-master
+Architecture: all
+Depends: debian.org-bugs.debian.org,
+       gnuplot,
+       ttf-liberation,
+       kgb-client-git,
+       lynx    
+Description: metapackages for bugs-master.debian.org dependencies
+ This package depends on everything that is needed for a
+ bugs-master.debian.org
+
+Package: debian.org-bugs.debian.org-search
+Architecture: all
+Depends: debian.org-bugs.debian.org,
+       hyperestraier,
+       libdate-manip-perl,
+       libsearch-estraier-perl
+Description: metapackages for bugs-search.debian.org dependencies
+ This package depends on everything that is needed for a
+ bugs-search.debian.org
+
 Package: debian.org-bugs.debian.org-mx
 Architecture: all
 Depends: debian.org-bugs.debian.org,
@@ -156,10 +180,24 @@ Description: metapackages for bugs.debian.org mail exchanger
  MX.
 
 
+Package: debian.org-packages-master.debian.org
+Architecture: all
+Depends: debian.org-packages.debian.org,
+       procmail,
+       gettext,
+       libhtml-template-perl,
+       libxml-rss-perl,
+       libtimedate-perl,
+       libio-stringy-perl,
+       freecdb
+Description: metapackages for packages.debian.org dependencies
+ This package depends on everything that is needed for a
+ packages-master.debian.org server.  For the mirrors all you need is the
+ debian.org-packages.debian.org package.
+
 Package: debian.org-packages.debian.org
 Architecture: all
-Depends: db4.6-util,
-       liblocale-maketext-lexicon-perl,
+Depends: liblocale-maketext-lexicon-perl,
        libi18n-acceptlanguage-perl,
        libnumber-format-perl,
        libcompress-zlib-perl,
@@ -172,11 +210,14 @@ Depends: db4.6-util,
        liblingua-stem-perl,
        libsearch-xapian-perl,
        libtimedate-perl,
-       libapache2-mod-perl2,
-       libapache2-reload-perl
+       libcgi-fast-perl,
+       libapache2-mod-fcgid,
+       dpkg-dev,
+       rsync
 Description: metapackages for packages.debian.org dependencies
  This package depends on everything that is needed for a packages.debian.org
- mirror or (in the future) packages-master.
+ mirror.  For packages-master install the debian.org-packages-master.debian.org
+ package.
 
 Package: debian.org-www-master.debian.org
 Architecture: all
@@ -188,6 +229,7 @@ Depends: debiandoc-sgml,
        docbook-dsssl,
        docbook-xsl,
        dpkg-dev,
+       gawk (>= 1:4.0.1),
        gettext,
        ghostscript,
        imagemagick,
@@ -240,7 +282,9 @@ Description: metapackages for www-master.debian.org dependencies
 
 Package: debian.org-buildd.debian.org
 Architecture: all
-Depends: edos-distcheck,
+Depends:
+       dose-builddebcheck,
+       edos-distcheck,
        ghostscript,
        libcompress-bzip2-perl,
        libcompress-zlib-perl,
@@ -262,9 +306,12 @@ Depends: edos-distcheck,
        python-sqlalchemy,
        r-base-core,
        r-cran-lattice,
-       php5,
        moreutils (>= 0.39~),
-       libdpkg-perl
+       libdpkg-perl,
+       php5,
+       php5-cgi,
+       php5-pgsql,
+       libapache2-mod-fcgid,
 Description: metapackages for buildd.debian.org dependencies
  This package depends on everything that is needed for a buildd.debian.org.
 
@@ -357,7 +404,6 @@ Depends: bicyclerepair,
        pychecker,
        pylint,
        python-mode,
-       ruby-elisp,
        gitstats,
        colordiff
 Description: metapackage for ftpmaster extras
@@ -382,12 +428,12 @@ Depends: edos-debcheck,
        dpkg-dev,
        procmail,
        rrdtool,
-       python3.1,
-       python3.1-dev,
        python3-apt,
        picosat,
        openjdk-6-jre-headless,
        git-email,
+       python-networkx,
+       python-pygraphviz,
 Description: metapackage for release
  This package depends on everything that is needed for a release.debian.org
  setup.
@@ -406,7 +452,8 @@ Depends: bittornado,
        fakeroot,
        dosfstools,
        libsoap-lite-perl,
-       devscripts
+       devscripts,
+       mtools
 Description: metapackage for cdbuilder
  This package depends on all the packages that are needed for a cdbuilder setup.
 
@@ -425,29 +472,25 @@ Description: metapackage for manpages
 
 Package: debian.org-nm.debian.org
 Architecture: all
-Depends: libapache2-mod-php5, libapache2-mod-wsgi,
-       php5-cli,
-       php5-ldap, php5-pgsql,
-       wml,
+Depends: libapache2-mod-wsgi,
        mutt, mboxgrep,
        python,
        python-mako (>= 0.2.5), python-gnupginterface, python-ldap,
        python-apt, python-beautifulsoup, python-debianbts, python-dns,
        python-dnspython, python-egenix-mxdatetime, python-egenix-mxtools,
        python-elementtree | python (>= 2.6), python-flup, python-libxml2,
-       python-lxml, python-psycopg2, python-soappy, python-virtualenv,
-       python-sqlalchemy (>= 0.6), python (>= 2.5.4-5~) | python-simplejson,
-       python-flask (>= 0.6),
+       python-lxml, python-psycopg2, python-soappy,
        python-xapian,
        python-dateutil,
-       perl,
-       libdbi-perl, libdbd-pg-perl, libdbd-sqlite3-perl,
+       python-debian,
+       python-django,
+       python-django-south,
+       python-tz,
+       python-markdown,
        procmail,
        moreutils,
-       python-flup
-# These are also needed, but they are currently not available in squeeze and
-# difficult to backport:
-# python-flaskext.wtf, python-wtforms
+       libjs-jquery,
+       postgresql-client
 Description: metapackage for nm.debian.org
  This package depends on all the packages that are needed for nm.debian.org setup.
 
@@ -478,9 +521,10 @@ Depends: db4.8-util,
        php5, php5-cgi, php5-cli,
                php5-ldap, php5-pgsql,
                libapache2-mod-fcgid,
-       python-apt, python-psycopg2,
+       python-apt, python-psycopg2, python-gpgme,
        libdbd-pg-ruby,
-       rrdtool
+       rrdtool,
+       raptor-utils | raptor2-utils
 Description: metapackage for qa.debian.org
  This package depends on all the packages that are needed for qa.debian.org setup.
 
@@ -557,32 +601,41 @@ Depends:   binutils,
        diffstat,
        dpkg-dev,
        debhelper,
+       devscripts,
        fakeroot,
        file,
        gettext,
+       gnuplot-nox | gnuplot,
+       hardening-includes (>= 2.2~),
        intltool-debian,
        libapt-pkg-perl,
+       libarchive-zip-perl,
        libclass-accessor-perl,
        libclone-perl,
        libdigest-sha-perl,
        libdpkg-perl,
        libemail-valid-perl,
+       libfile-basedir-perl,
        libhtml-parser-perl,
        libipc-run-perl,
+       liblist-moreutils-perl,
        libparse-debianchangelog-perl,
+       libperlio-gzip-perl,
        libtimedate-perl,
+       libtext-levenshtein-perl,
        libtext-template-perl,
        liburi-perl,
        locales,
        man-db,
        perl,
+       perl (>= 5.14~) | libautodie-perl (>= 2.10~),
+       t1utils,
        unzip,
        xz-utils
        ,
        docbook-utils,
        docbook-xml
        ,
-       hardening-includes (>= 2.0)
 Description: metapackages for lintian.debian.org dependencies
  This package depends on everything that is needed for lintian.debian.org.
 
@@ -676,7 +729,14 @@ Depends: libalgorithm-diff-xs-perl,
        ,
        gnuplot
        ,
-       tig
+       libapache2-mod-wsgi,
+       python-setuptools,
+       python-psycopg2,
+       python-django,
+       python-sqlalchemy
+       ,
+       tig,
+       postgresql-client-9.1
 Description: metapackages for ddtp.debian.org dependencies
  This package depends on everything that is needed for ddtp.debian.org.
 
@@ -690,7 +750,8 @@ Depends: gettext,
        libsoap-lite-perl,
        libtimedate-perl
        ,
-       tig
+       tig,
+       rrdtool
 Description: metapackages for i18n.debian.org dependencies
  This package depends on everything that is needed for i18n.debian.org.
 
@@ -704,6 +765,124 @@ Depends: gettext,
        libsoap-lite-perl,
        libtimedate-perl
        ,
-       tig
+       tig,
+       rrdtool
 Description: metapackages for l10n.debian.org dependencies
  This package depends on everything that is needed for l10n.debian.org.
+
+Package: debian.org-piuparts-master.debian.org
+Architecture: all
+Depends: debhelper,
+       asciidoc,
+       git,
+       xmlto,
+       python-debianbts,
+       apache2,
+       ghostscript,
+       python-rpy2,
+       r-base-dev,
+       r-recommended,
+       tango-icon-theme,
+       screen,
+       python-apt,
+       xz-utils,
+       python-yaml,
+       devscripts, libsoap-lite-perl
+Description: metapackage for piuparts-master.debian.org
+ This package depends on all the packages that are needed for the
+ master in the piuparts.debian.org setup.
+
+Package: debian.org-piuparts-slave.debian.org
+Architecture: all
+Depends: debhelper,
+       asciidoc,
+       git,
+       xmlto,
+       debootstrap,
+       debsums,
+       lsb-release,
+       lsof,
+       screen,
+       python-debian,
+       python-apt,
+       adequate
+Description: metapackage for piuparts-slave.debian.org
+ This package depends on all the packages that are needed for the
+ slaves in the piuparts.debian.org setup.
+
+Package: debian.org-wiki.debian.org
+Architecture: all
+Depends: libapache2-mod-wsgi,
+       libjson-perl,
+       python-moinmoin,
+       python-launchpadlib,
+       libsoap-lite-perl
+Description: metapackage for wiki.debian.org
+ This package depends on all the packages that are needed for the Debian wiki
+
+Package: debian.org-vote.debian.org
+Architecture: all
+Depends: libparse-recdescent-perl,
+       libmime-tools-perl,
+       libnet-ldap-perl,
+       libgnupg-interface-perl,
+       libmail-gnupg-perl,
+       graphviz
+Description: metapackage for vote.debian.org
+ This package depends on all the packages that are needed for DeVoteE
+
+Package: debian.org-bits.debian.org
+Architecture: all
+Depends: python-unidecode,
+       python-jinja2,
+       python-pygments,
+       python-docutils,
+       python-markdown,
+       python-tz,
+       python-typogrify,
+       python-six
+# Also needed, to add when they are available in Debian and can be backported:
+# feedgenerator (#702229), blinker (#702231), pelican (#702222)
+Description: metapackage for bits.debian.org
+ This package depends on all the packages that are needed for the Debian
+ blog bits.debian.org
+
+Package: debian.org-d-i.debian.org
+Architecture: all
+Depends: gnuplot,
+       libemail-mime-perl,
+       libemail-sender-perl,
+       liblist-moreutils-perl,
+       libsort-versions-perl,
+       devscripts,
+       liburi-perl,
+       edos-distcheck
+Description: metapackage for d-i.debian.org
+ This package depends on all the packages that are needed for the
+ d-i.debian.org setup.
+
+Package: debian.org-codesearch.debian.org
+Architecture: all
+Depends: dpkg-dev,
+       postgresql-client
+Description: metapackage for codesearch.debian.org
+ This package depends on all the packages that are needed for the codesearch
+ setup.
+
+Package: debian.org-dedup.debian.net
+Architecture: all
+Depends: curl,
+       devscripts,
+       python,
+       python-concurrent.futures,
+       python-debian,
+       python-imaging,
+       python-jinja2,
+       python-lzma,
+       python-pkg-resources,
+       python-werkzeug,
+       python-yaml,
+       sqlite3
+Description: metapackage for dedup.debian.net
+ This package depends on all packages that are required for operating the
+ Debian duplication detector. The recommended packages are useful for debuging.