chiark / gitweb /
Add dose-builddebcheck to buildd.debian.org.
[dsa-metapackages.git] / debian / control
index 39b448d..a7de1b4 100644 (file)
@@ -210,8 +210,8 @@ Depends: liblocale-maketext-lexicon-perl,
        liblingua-stem-perl,
        libsearch-xapian-perl,
        libtimedate-perl,
-       libapache2-mod-perl2,
-       libapache2-reload-perl,
+       libcgi-fast-perl,
+       libapache2-mod-fcgid,
        dpkg-dev,
        rsync
 Description: metapackages for packages.debian.org dependencies
@@ -282,7 +282,9 @@ Description: metapackages for www-master.debian.org dependencies
 
 Package: debian.org-buildd.debian.org
 Architecture: all
-Depends: edos-distcheck,
+Depends:
+       dose-builddebcheck,
+       edos-distcheck,
        ghostscript,
        libcompress-bzip2-perl,
        libcompress-zlib-perl,
@@ -304,9 +306,12 @@ Depends: edos-distcheck,
        python-sqlalchemy,
        r-base-core,
        r-cran-lattice,
-       php5,
        moreutils (>= 0.39~),
-       libdpkg-perl
+       libdpkg-perl,
+       php5,
+       php5-cgi,
+       php5-pgsql,
+       libapache2-mod-fcgid,
 Description: metapackages for buildd.debian.org dependencies
  This package depends on everything that is needed for a buildd.debian.org.
 
@@ -467,7 +472,7 @@ Description: metapackage for manpages
 
 Package: debian.org-nm.debian.org
 Architecture: all
-Depends: libapache2-mod-php5, libapache2-mod-wsgi,
+Depends: libapache2-mod-wsgi,
        mutt, mboxgrep,
        python,
        python-mako (>= 0.2.5), python-gnupginterface, python-ldap,
@@ -479,10 +484,13 @@ Depends: libapache2-mod-php5, libapache2-mod-wsgi,
        python-dateutil,
        python-debian,
        python-django,
+       python-django-south,
        python-tz,
+       python-markdown,
        procmail,
        moreutils,
-       libjs-jquery
+       libjs-jquery,
+       postgresql-client
 Description: metapackage for nm.debian.org
  This package depends on all the packages that are needed for nm.debian.org setup.
 
@@ -778,6 +786,7 @@ Depends: debhelper,
        screen,
        python-apt,
        xz-utils,
+       python-yaml,
        devscripts, libsoap-lite-perl
 Description: metapackage for piuparts-master.debian.org
  This package depends on all the packages that are needed for the
@@ -847,6 +856,33 @@ Depends: gnuplot,
        libsort-versions-perl,
        devscripts,
        liburi-perl,
+       edos-distcheck
 Description: metapackage for d-i.debian.org
  This package depends on all the packages that are needed for the
  d-i.debian.org setup.
+
+Package: debian.org-codesearch.debian.org
+Architecture: all
+Depends: dpkg-dev,
+       postgresql-client
+Description: metapackage for codesearch.debian.org
+ This package depends on all the packages that are needed for the codesearch
+ setup.
+
+Package: debian.org-dedup.debian.net
+Architecture: all
+Depends: curl,
+       devscripts,
+       python,
+       python-concurrent.futures,
+       python-debian,
+       python-imaging,
+       python-jinja2,
+       python-lzma,
+       python-pkg-resources,
+       python-werkzeug,
+       python-yaml,
+       sqlite3
+Description: metapackage for dedup.debian.net
+ This package depends on all packages that are required for operating the
+ Debian duplication detector. The recommended packages are useful for debuging.