chiark / gitweb /
Added two packages to nono
[dsa-metapackages.git] / debian / changelog
index 37107e4..809daed 100644 (file)
-debian.org (3x) xtable; urgency=low
+debian.org (52) UNRELEASED; urgency=low
+
+  [ Peter Palfrader ]
+  * bugs:
+    + add libgravatar-url-perl
+  * qa:
+    + add python-gpgme
+  * recommended:
+    + vim-addon-manager, vim-scripts
+  * vote:
+    + graphviz
+  * packages.d.o:
+    - remove db4.6 util
+    + dpkg-dev
+  * packages-master:
+    + freecdb
+  * bugs-search
+    + libdate-manip-perl
+  * release
+    - python3.1*
+  * ftp-master-poneys
+    - ruby-elisp
+  * nm.d.o:
+    + libjs-jquery
+
+  [ Ana Guerrero Lopez ]
+  * Add bits.debian.org. Initial dependencies:
+    python-unidecode, python-jinja2, python-pygments, python-docutils,
+    python-markdown, python-tz, python-typogrify, python-six
+
+  [ Niels Thykier ]
+  * lintian:
+    - Bump version on hardening-includes to (>= 2.2~).
+    - Add versioned depends on perl | libautodie-perl.
+    - Add libfile-basedir-perl and liblist-moreutils-perl.
+    - Add libperlio-gzip-perl.
+
+  [ Gerfried Fuchs ]
+  * packages:
+    - add a packages-master package depending on the packages package and
+      pulling in additional dependencies.
+
+  [ Holger Levsen ]
+  * Split debian.org-piuparts.debian.org package into two.
+  * Add adequate tp piuparts-slave depends.
+  * Add devscripts to piuparts-master depends.
+
+  [ Cyril Brulebois ]
+  * Introduce debian.org-d-i.debian.org, initially depending on:
+    + gnuplot
+    + libemail-mime-perl
+    + libemail-sender-perl
+    + liblist-moreutils-perl
+    + libsort-versions-perl
+    + devscripts
+    + liburi-perl
+
+  [ Martin Zobel-Helas ]
+  * add sg3-utils to debian.org-recommended
+
+  [ Enrico Zini ]
+  * nm.d.o update
+    + postgresql-client
+    + python-django-south
+
+  [ Michael Stapelberg ]
+  * Add codesearch.debian.org. Initial dependencies:
+    dpkg-dev, xz-utils, postgresql-client
+
+  [ Ivo De Decker ]
+  * piuparts-master:
+    + add python-yaml
+
+ -- Peter Palfrader <weasel@debian.org>  Mon, 15 Apr 2013 13:01:08 +0200
+
+debian.org (51) unstable; urgency=low
+
+  * bwm-ng is linux only.
+  * move a copy of linux-only packages from debian.org-recommended
+    [linxu-any], to the d.o-r-linux package.
+
+ -- Peter Palfrader <weasel@debian.org>  Sat, 02 Mar 2013 23:03:38 +0100
+
+debian.org (50) unstable; urgency=low
+
+  [ Cyril Brulebois ]
+  * release.debian.org: Add python-{networkx,pygraphviz}.
+
+  [ Luca Filipozzi (lfilipoz) ]
+  * Added Luca Filipozzi as a maintainer
+  * Added packages to udd per Lucas Nussbaum
+
+  [ Martin Zobel-Helas ]
+  * debian.org-www-master.debian.org: add opencc
+    as per http://lists.debian.org/<CAFZbbGDFMfHyuwmYxRtdwvszqXFOxqzkj_5Z7U3Sj9JOJ6pxUg@mail.gmail.com>
+  * add ethtool to debian.org-recommends-linux
+
+  [ Peter Palfrader ]
+  * bugs:
+    - add libmail-rfc822-address-perl
+  * qa:
+    - add raptor-utils | raptor2-utils
+
+  [ Stephen Gran ]
+  * Add ccze to -recommended
+  * Add bwm-ng to -recommended
+
+  [ David Prévot ]
+  * www-master: use recent version of gawk
+
+  [ Niels Thykier ]
+  * lintian:
+    - devscripts (for dd-list)
+    - libarchive-zip-perl
+    - libtext-levenshtein-perl
+    - gnuplot-nox | gnuplot
+    - t1utils
+
+  [ Steve McIntyre ]
+  * cdbuilder.debian.org
+    - add mtools
+  * wiki.debian.org
+    - start new section for the Debian wiki
+
+  [ Don Armstrong ]
+  * bugs.debian.org
+    - add libtext-iconv-perl
+  * bugs-master.debian.org
+    - add kgb-client-git
+
+  [ Holger Levsen ]
+  * Add debian.org-piuparts.debian.org metapackage.
+
+  [ Peter Palfrader ]
+  * Make debian.org-recommended arch any so we can replace type-handling
+    dependencies with [$arch] restricted dependencies.
+
+ -- Peter Palfrader <weasel@debian.org>  Thu, 31 Jan 2013 14:14:38 +0100
+
+debian.org (49) unstable; urgency=low
+
+  [ Felipe Augusto van de Wiel (faw) ]
+  * Add ddtp.debian.org
+  * Add i18n.debian.org
+  * Add l10n.debian.org
+
+  [ Martin Zobel-Helas ]
+  * apache2-vhost-update:
+    decline to have LoadModule and LoadFile in vhosts
+
+  [ Peter Palfrader ]
+  * lintian:
+    - hardening-includes (>= 2.0)
+
+ -- Martin Zobel-Helas <zobel@debian.org>  Sun, 24 Jun 2012 12:05:16 +0200
+
+debian.org (48) unstable; urgency=low
+
+  * apt-in-chroot: fix PATH to include the sbin directories.
+
+ -- Peter Palfrader <weasel@debian.org>  Wed, 23 May 2012 16:19:20 +0200
+
+debian.org (47) unstable; urgency=low
+
+  [ Peter Palfrader ]
+  * Skip version number 46.  It has been used by partial builds.
+  * apt-in-chroot: add schroot support.
+  * apt-in-chroot: allow clean.
+
+  [ Enrico Zini ]
+  * Added entry for debtags.debian.net
+  * nm.d.o needs python-flup for fastcgi deployment
+
+  [ Raphael Geissert ]
+  * qa: add devscripts
+
+  [ Cyril Brulebois ]
+  * release.debian.org: Add git-email.
+
+  [ Faidon Liambotis ]
+  * Remove python-flaskext.wtf, python-wtforms depends from nm.d.o.
+
+  [ Martin Zobel-Helas ]
+  * add sso.debian.org 
+  * add lists.debian.org
+
+  [ Niels Thykier ]
+  * lintian.debian.org:
+    - add libclone-perl
+
+ -- Peter Palfrader <weasel@debian.org>  Mon, 07 May 2012 21:55:13 +0200
+
+debian.org (45) unstable; urgency=low
+
+  [ Andreas Barth ]
+  * add python3.1, python3.1-dev and python3-apt for release.debian.org
+
+  [ Tollef Fog Heen ]
+  * Add clasp, picosat for release.debian.org (RT #3324)
+
+  [ Philipp Kern ]
+  * Drop clasp from release.debian.org.
+  * Add openjdk-6-jre-headless to release.debian.org.
+
+  [ Peter Palfrader ]
+  * recommended:
+    - add ncdu
+    - add tmux
+    - add bc
+  * lintian:
+    - add debhelper
+  * www-master:
+    - remove python-xml (upgraded to squeeze)
+    - remove python2.4
+    - remove littex
+
+  [ Steve McIntyre ]
+  * cdimage-search.debian.org
+    - add libsoap-lite-perl
+
+  [ David Prévot ]
+  * www-master:
+    - add lmodern
+    - add texlive-lang-all
+    - remove texlive-lang-* (superseded by texlive-lang-all)
+
+  [ Martin Zobel-Helas ]
+  * add packages.qa.d.o
+
+  [ Iain Lane ]
+  * udd:
+    - add dpkg-dev
+    - add python-launchpadlib
+
+  [ Adam D. Barratt ]
+  * release
+    - remove python2.5{,-dev}
+    - add python2.6{,-dev}
+
+ -- Martin Zobel-Helas <zobel@debian.org>  Sun, 01 Jan 2012 23:48:46 +0100
+
+debian.org (44) unstable; urgency=low
+
+  [ Peter Palfrader ]
+  * recommended:
+    - iputils-tracepath
+    - unbound-host
+  * planet:
+    - Fix timeout dependency ( | coreutils >> somethingorother)
+    - add libdbi-perl
+    - add libdate-manip-perl
+    - add libdbd-sqlite3-perl
+  * apt-in-chroot: "fix" bashism.
+  * add women.d.o
+  * buildd:
+    - remove db4.8-util
+    - remove quinn-diff
+    - remove python-coverage-test-runner
+    - add libdpkg-perl
+  * ftpmaster-poneys:
+    - add colordiff
+  * add lintan.d.o
+  * add popcon.d.o
+  * add dde.d.n
+  * release:
+    - add rrdtool
+
+  [ Steve McIntyre ]
+  * cdimage-search.debian.org
+    - add cdimage-search metapackage
+  * cdbuilder.debian.org
+    - add devscripts
+
+  [ Simon Paillard ]
+  * www-master:
+    - add libsoap-lite-perl (RT#3117, Bug#574550)
+
+  [ David Prévot ]
+  * www-master:
+    - add iso-codes
+    - add isoquery (Bug#624150)
+    - add uni2ascii (Bug#625650)
+    - add libemail-address-perl
+    - add libmime-lite-perl (Bug#541839)
+
+  [ Stephen Gran ]
+  * Update apt-in-chroot to work with dash
+  * add imagemagick to depends for www-master
+
+ -- Peter Palfrader <weasel@debian.org>  Tue, 26 Jul 2011 14:31:17 +0200
+
+debian.org (43.3) unstable; urgency=low
+
+  * Add debian.org-udd.debian.org.
+  * Add debian.org-snapshot.debian.org.
+
+ -- Peter Palfrader <weasel@debian.org>  Sat, 26 Mar 2011 22:28:16 +0100
+
+debian.org (43.2) unstable; urgency=low
+
+  [ Stephen Gran ]
+  * debian.org:
+    - add nagios-plugins-standard (>= 1.4.15) | nagios-plugins-basic for
+      check_mailq
+
+  [ Peter Palfrader ]
+  * release
+    - needs edos-debcheck, not edos-distcheck.
+    - python-dev
+  * ftp-poneys
+    - gitstats
+
+ -- Peter Palfrader <weasel@debian.org>  Mon, 21 Mar 2011 22:28:16 +0100
+
+debian.org (43.1) unstable; urgency=low
+
+  * release:
+    - add edos-distcheck
+    - add python2.5-dev
+    - add libapt-pkg-dev
+    - add dpkg-dev
+    - remove obsolete python-simplejson | python (>= 2.6)
+  * Add debian.org-ftpmaster.debian.org-poneys package.
+
+ -- Peter Palfrader <weasel@debian.org>  Sun, 20 Mar 2011 00:36:33 +0100
+
+debian.org (43) unstable; urgency=low
+
+  * buildd.debian.org:
+    - remove dependency on postgresql-8.4 - we do not depend on db servers in
+      debian.org metapackages.
+  * Move lsscsi from -recommended to -recommended-linux as it does not exist
+    on the BSDs.
+
+ -- Peter Palfrader <weasel@debian.org>  Sat, 19 Mar 2011 23:54:49 +0100
+
+debian.org (42) unstable; urgency=low
+
+  [ Steve McIntyre ]
+  * cdbuilder.debian.org
+    - add dosfstools
+
+  [ Joerg Jaspert ]
+  * debian.org-ftpmaster.debian.org: Add xz-utils (bpo or higher version)
+  * use python-debianbts instead of python-btsutils
+
+  [ Peter Palfrader ]
+  * Add debian.org-qa.debian.org.
+  * -recommended:
+    - add busybox-static
+    - add lsscsi
+    - add cvs (yes, really)
+  * www-master:
+    - add ttf-malayalam-fonts
+    - add tidy
+    - add libjson-perl
+  * ftp-master:
+    - add python-simplejson || python (>= 2.6)
+    - dependency on python-sqlalchemy is no longer versioned
+    - remove irb (now provided by ruby)
+  * buildd.debian.org:
+    - dependency on python-sqlalchemy is no longer versioned
+
+  [ Bernd Zeimetz ]
+  * nm.d.o:
+    - make dependency on python-sqlalchemy versioned (>= 0.6),
+    - python (>= 2.5.4-5~) also works instead of python-simplejson,
+    - new dependencies: python-flask (>= 0.6), python-flaskext.wtf,
+      python-wtforms.
+
+  [ Martin Zobel-Helas ]
+  * add ipython to -recommended.
+  * add diffstat to -recommended
+
+  [ Stephen Gran ]
+  * Add wheezy chroots to upgrade-porter-chroots
+
+  [ Francesca Ciceri ]
+  * debian.org-www-master.debian.org:
+    - add libintl-perl
+
+ -- Peter Palfrader <weasel@debian.org>  Sat, 19 Mar 2011 23:34:04 +0100
+
+debian.org (41.1) stable; urgency=low
+
+  * -recommended:
+    - Fix typo/copy error.
+    - lshw isn't available on *bsd either.
+
+ -- Peter Palfrader <weasel@debian.org>  Fri, 10 Sep 2010 20:32:07 +0200
+
+debian.org (41) stable; urgency=low
+
+  * debian.org-buildd.debian.org: Fix the moreutils versioned dependency.
+  * Split -recommended-linux off of -recommended, so we can install
+    the latter on kfreebsd hosts.  Also keep a few tools in -recommended
+    that do not yet exist on freebsd but might eventually (have not+gnu-linux
+    as an alternative for them for now).
+
+ -- Peter Palfrader <weasel@debian.org>  Fri, 10 Sep 2010 20:22:55 +0200
+
+debian.org (40) stable; urgency=low
+
+  * Remove acpid from debian.org-recommended.  >= 2.0 doesn't exist in
+    stable.
+
+ -- Peter Palfrader <weasel@debian.org>  Thu, 09 Sep 2010 20:56:24 +0200
+
+debian.org (39) stable; urgency=low
+
+  [ Joerg Jaspert ]
+  * More updates for the ftpmaster package.
+
+  [ Martin Zobel-Helas ]
+  * add syslog-ng (>= 3.1) to debian.org.
+  * add acpid (>= 2.0) to debian.org-recommended.
+  * start new package debian.org-nm.debian.org
+  * add wdiff dependency to ftpmaster package.
+
+  [ Philipp Kern ]
+  * add mutt to debian.org-recommended
+  * add debian.org-release.debian.org metapackage
+  * add python-mako to debian.org-buildd.debian.org
+  * add moreutils (>= 0.39) to debian.org-buildd.debian.org
+    (for a fixed parallel)
+
+  [ Peter Palfrader ]
+  * A new debian.org-backports.debian.org package.
+  * debian.org-recommended updates for squeeze:
+    - Dependency on timeout can also be satisfied by coreutils >= 8.0-1.
+    - Dependency on emacs* can also be satisfied by emacs23.
+
+ -- Peter Palfrader <weasel@debian.org>  Thu, 09 Sep 2010 17:10:31 +0200
+
+debian.org (38) stable; urgency=low
+
+  * Update python-sqlalchemy dependency for ftpmaster metapackage to version > 0.5 << 0.6
+
+ -- Joerg Jaspert <joerg@debian.org>  Thu, 01 Jul 2010 21:55:14 +0200
+
+debian.org (37) stable; urgency=low
+
+  [ Martin Zobel-Helas ]
+  * add mercurial to -recommended
+
+  [ Stephen Gran ]
+  * Remove etch from upgrade-porter-chroots
+
+ -- Stephen Gran <sgran@debian.org>  Thu, 01 Jul 2010 23:59:13 +0100
+
+debian.org (36) stable; urgency=low
+
+  * buildd.debian.org:
+    - depend on db4.8-util instead of 4.7.
+  * buildd-reboot: change shutdown time to 1 minute from 15.
+
+ -- Peter Palfrader <weasel@debian.org>  Mon, 14 Jun 2010 17:53:41 +0200
+
+debian.org (35) stable; urgency=low
+
+  [ Peter Palfrader ]
+  * -recommended: puppet now wants augeas, so add it to dependencies:
+    - libaugeas-ruby
+    - libaugeas-ruby1.8
+    - libaugeas0 (/lenny-backports)
+    - augeas-lenses (/lenny-backports == >= 0.7)
+
+  [ Martin Zobel-Helas ]
+  * do proper input validation
+    With the current code APTCMD was parsed for the valid subcomands, but if
+    it was invalid, it just printed it but worked nevertheless. Now we exit
+    if the subcommand is invalid.
+
+ -- Martin Zobel-Helas <zobel@debian.org>  Wed, 28 Apr 2010 16:08:59 +0200
+
+debian.org (34) stable; urgency=low
 
   [ Peter Palfrader ]
   * buildd.debian.org
     - add python-nose and php5
     - depend on edos-distcheck instead of edos-debcheck
   * bugs.debian.org: libdbd-pg-perl python-pyinotify python-yaml
+  * -recommended: remove irqbalance
 
   [ Andreas Barth ]
   * buildd.debian.org
     - add libfile-spec-perl
 
- -- Andreas Barth <aba@no.so.argh.org>  Wed, 07 Apr 2010 07:30:37 +0000
+  [ Steve McIntyre ]
+  * cdbuilder.debian.org
+    - add zip
+
+ -- Peter Palfrader <weasel@debian.org>  Fri, 23 Apr 2010 18:44:55 +0200
 
 debian.org (33) stable; urgency=low