chiark / gitweb /
remove some obsolete source-depends stuff
authoraph <aph@313b444b-1b9f-4f58-a734-7bb04f332e8d>
Sat, 4 Nov 2000 18:22:43 +0000 (18:22 +0000)
committeraph <aph@313b444b-1b9f-4f58-a734-7bb04f332e8d>
Sat, 4 Nov 2000 18:22:43 +0000 (18:22 +0000)
git-svn-id: svn://anonscm.debian.org/ddp/manuals/trunk/developers-reference@1033 313b444b-1b9f-4f58-a734-7bb04f332e8d

debian/changelog
debian/rules

index 8aa1256..56b42aa 100644 (file)
@@ -4,8 +4,9 @@ developers-reference (2.8.1) unstable; urgency=low
     (closes: Bug#69435)
   * spelling corrections, awkward grammar suggestions from Andreas Krueger 
     (closes: Bug#72810)
+  * debian/rules: remove some obsolete source-depends stuff
 
- -- Adam Di Carlo <aph@debian.org>  Sat,  4 Nov 2000 13:12:57 -0500
+ -- Adam Di Carlo <aph@debian.org>  Sat,  4 Nov 2000 13:22:21 -0500
 
 developers-reference (2.8.0) unstable; urgency=low
 
index f8b06e3..dd2c897 100755 (executable)
@@ -24,22 +24,8 @@ DEB_VERSION  := $(shell LC_ALL=C dpkg-parsechangelog | grep '^Version: ' | sed 's
 # pretty-print the date
 DATE           := $(shell LC_ALL=C date --date="`dpkg-parsechangelog | grep '^Date: ' | sed 's/^Date: *//'`" '+%d %B, %Y')
 
-# source depends -- check if these packages are installed
-SRC_DEPENDS    := debiandoc-sgml lout psutils
-
-.PHONY: source-depends
-source-depends:
-       @set -e                                                         ;\
-       for dep in $(SRC_DEPENDS); do                                   \
-           echo "checking if package \`$$dep' is installed..."         ;\
-           dpkg --get-selections | grep "$$dep\W\+install" ||  \
-               exit 1                                                  ;\
-       done
-       @echo "all source-depends seem to be installed, good"
-
 build: developers-reference.sgml
        $(checkdir)
-#      ./debian/rules source-depends
        rm -f version.ent
        echo "<!entity version \"$(DEB_VERSION)\">" >> version.ent
        echo "<!entity date    \"$(DATE)\">"        >> version.ent