chiark / gitweb /
Factor out common files to fix multi-arch installs
[elogind.git] / debian / rules
index 99bed261089aba209d2179a5b777ba6688246e1c..76f29f0d474f73ab3545dbad37e7c75fc039f71d 100755 (executable)
@@ -1,20 +1,24 @@
 #! /usr/bin/make -f
 
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+# The options have been chooses as follows:
+# - manually set pamlibdir because we'Re installing in /usr by default but 
+#   pam libs must go to /lib/*/security
+# - Disable lto because this makes the build fail with static library 
+#   warnings and with  linking errors. (It seems taht instead of ar/ld 
+#   gcc-ar and gcc should be used)
+# - tests disabled beacuase some of the tests seem to require elogind running.
+#   Need to sort out which tests could be run
 
-# disable lto because this does not work for me. Building static libraries with i
-# libtool/ar failes. I think this a apackage problem, it should use gcc-ar instead
 CONFFLAGS = \
-  --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
-  --enable-kdbus \
+  --with-pamlibdir=/lib/$(DEB_HOST_MULTIARCH)/security \
   --disable-lto \
   --disable-tests
 
-autoreconf:
-       ./autogen.sh
+#autoreconf:
+#      ./autogen.sh
        
-override_dh_autoreconf:
-       dh_autoreconf debian/rules -- autoreconf
+#override_dh_autoreconf:
+#      dh_autoreconf debian/rules -- autoreconf
 
 override_dh_auto_configure:
        dh_auto_configure --builddirectory=build \