chiark / gitweb /
fix hardcoding of patch dir
[topgit.git] / debian / tg2quilt.mk
index 2ad3cba29b6da481a477e6a9a42264c619cd1b1a..1f890920b5bcf33ec0be264afe5c51d78c2999d9 100644 (file)
@@ -69,7 +69,7 @@ $(QUILT_STAMPFN): tg-export
 unpatch: __tg-temp-export
 __tg-temp-export:
        @echo "Exporting TopGit branches to series so that quilt can clean up..." >&2
-       $(MAKE) $(MAKEFLAGS) -f debian/rules tg-export
+       $(MAKE) -f debian/rules tg-export
 .PHONY: __tg-temp-export
 
 # Set some tg-export-specific variables, e.g. default TG_BRANCHES to all
@@ -121,10 +121,10 @@ endif
 
 # Make sure that we try to clean up the patches directory last
 tg-clean: clean
-       $(MAKE) $(MAKEFLAGS) -f debian/rules tg-rmdir
+       $(MAKE) -f debian/rules tg-rmdir
 
 tg-forceclean: clean
-       test -d debian/patches && rm -r $(PATCHES_DIR) || :
+       test -d $(PATCHES_DIR) && rm -r $(PATCHES_DIR) || :
 
 endif