chiark / gitweb /
fix hardcoding of patch dir
[topgit.git] / debian / tg2quilt.mk
index 031d7b1ae92e70f2bb06f1ba76e582aa380afbda..1f890920b5bcf33ec0be264afe5c51d78c2999d9 100644 (file)
@@ -5,8 +5,9 @@
 # a quilt series.
 #
 # It is intended to be included from debian/rules files of TopGit-using
-# packages, like so:
+# packages after including the quilt rules, like so:
 #
+#   include /usr/share/quilt/quilt.make
 #   -include /usr/share/topgit/tg2quilt.mk
 #
 # The snippet exports the following targets. These targets only perform the
@@ -60,15 +61,16 @@ else
 
 # We are in a TopGit branch, so let the fun begin.
 
-PATCHES_DIR ?= debian/patches
+PATCHES_DIR ?= $(QUILT_PATCH_DIR)
 
 # Hook tg-export into quilt's make(1) snippet such that it gets executed
 # before quilt patches or unpatches.
-debian/stamp-patched: tg-export
+$(QUILT_STAMPFN): tg-export
 unpatch: __tg-temp-export
 __tg-temp-export:
        @echo "Exporting TopGit branches to series so that quilt can clean up..." >&2
-       $(MAKE) $(MAKEFLAGS) -f debian/rules tg-export
+       $(MAKE) -f debian/rules tg-export
+.PHONY: __tg-temp-export
 
 # Set some tg-export-specific variables, e.g. default TG_BRANCHES to all
 # TopGit branches
@@ -119,10 +121,10 @@ endif
 
 # Make sure that we try to clean up the patches directory last
 tg-clean: clean
-       $(MAKE) $(MAKEFLAGS) -f debian/rules tg-rmdir
+       $(MAKE) -f debian/rules tg-rmdir
 
 tg-forceclean: clean
-       test -d debian/patches && rm -r $(PATCHES_DIR) || :
+       test -d $(PATCHES_DIR) && rm -r $(PATCHES_DIR) || :
 
 endif