chiark / gitweb /
Update changelog for 20170923.ff218728-0+iwj2~3.gbpc58e0c release
[sgt-puzzles.git] / debian / changelog
index d1e384ee31eac1c2c540700551bd95d36f744dda..e97872f9d1605acfe48afc0397ec4892ceec933d 100644 (file)
@@ -1,6 +1,6 @@
-sgt-puzzles (20170923.ff218728-0+iwj2~1.gbpc10c7b) UNRELEASED; urgency=medium
+sgt-puzzles (20170923.ff218728-0+iwj2~3.gbpc58e0c) UNRELEASED; urgency=medium
 
-  ** SNAPSHOT build @c10c7b419420113a0d8103e9d157e407d99e5322 **
+  ** SNAPSHOT build @c58e0c245845ba619c52ed1f63bd6db4388d729a **
 
   [ Simon Tatham ]
   * Avoid macro-generating a trailing comma in an enum.
@@ -21,8 +21,43 @@ sgt-puzzles (20170923.ff218728-0+iwj2~1.gbpc10c7b) UNRELEASED; urgency=medium
 
   [ Ian Jackson ]
   * Revert "RFH: tracks: Grid line width problems"
+  * tracks.c: draw_clue: Introduce bg parameter
+  * tracks: Greyscale colour initialisation: line up columns
+  * tracks: Make error clue background white
+  * midend: Allow "new game" to be undone
 
- -- Ian Jackson <ian@zealot.relativity.greenend.org.uk>  Sat, 30 Sep 2017 01:29:04 +0100
+  [ Simon Tatham ]
+  * Net: rewrite the drawing code for better scalability.
+  * Fix auto-selection of presets in GTK.
+  * Fix changing puzzle size in a maximised GTK3 window.
+
+  [ Ian Jackson ]
+  * tracks.c: draw_clue: Introduce bg parameter
+  * tracks: Greyscale colour initialisation: line up columns
+  * tracks: Make error clue background white
+
+  [ Simon Tatham ]
+  * deserialise: use the right one of {,c}params.
+  * midend_deserialise: keep deserialised data in a struct.
+  * midend_deserialise: accept an extra validation function.
+
+  [ Ian Jackson ]
+  * midend: Allow "new game" to be undone
+
+  [ Simon Tatham ]
+  * Style tweaks to the newgame_undo patch.
+  * Forbid undo of new-game if it would change the params.
+  * Make newgame_undo_buf 'char *', not 'void *'.
+  * Fix an int->pointer cast warning in windows.c.
+  * New name UI_UPDATE for interpret_move's return "".
+  * Use a proper union in struct config_item.
+  * Return error messages as 'const char *', not 'char *'.
+  * Assorted char * -> const char * API changes.
+  * Make the code base clean under -Wwrite-strings.
+
+  [ Ian Jackson ]
+
+ -- Ian Jackson <ian@zealot.relativity.greenend.org.uk>  Tue, 03 Oct 2017 20:48:57 +0100
 
 sgt-puzzles (20170923.ff218728-0+iwj1) unstable; urgency=medium