chiark / gitweb /
Makefiles: Use Final.sd.mk to implementing RECHECK_RM
[secnet.git] / debian / rules
index 9749fab4357af5f8cdac1a68df40c74f081d0da4..f94e7521ba9d088ec90493ed7deb8e192ae45da8 100755 (executable)
 #  along with this software; if not, see
 #  https://www.gnu.org/licenses/gpl.html.
 
-build: build-stamp
+export EXTRA_CFLAGS= $(shell dpkg-buildflags --get CPPFLAGS) \
+                    $(shell dpkg-buildflags --get CFLAGS)
+export EXTRA_LDFLAGS=$(shell dpkg-buildflags --get LDFLAGS)
+
+build build-arch: build-stamp
 build-stamp:
        dh_testdir
 
@@ -59,7 +63,7 @@ install: build
        $(MAKE) DESTDIR=`pwd`/debian/`dh_listpackages` install
 
 # Build architecture-independent files here.
-binary-indep: build install
+build-indep binary-indep:
 # We have nothing to do by default.
 
 # Build architecture-dependent files here.