chiark / gitweb /
changelog: Start 0.6.1
[secnet.git] / debian / changelog
index 1fb9258720ea985b008e22707e81ad0497791cf3..9ee83bd098eb5e5d36057234a58a02147826d411 100644 (file)
@@ -1,4 +1,82 @@
-secnet (0.5.1~) unstable; urgency=medium
+secnet (0.6.1~) unstable; urgency=medium
+
+  * 
+
+ --
+
+secnet (0.6.0) unstable; urgency=medium
+
+  Bugfixes:
+  * mobile sites: Do not ever expire peer addresses.  In practice
+    this fixes transitions between IPv6-only and IPv4-only networks.
+  * make-secnet-sites: Tainted: Fix a lot of bad return values
+    (which would result in assertions rather than nice error messages).
+  * Fix hash algo confusion in mixed sha1/md5 configurations (see below).
+
+  Incompatible changes:
+  * site: Always advertise all capabilities, even in MSG1.  This is
+    incompatible with secnets earlier than 0.3.0 (September 2013), which
+    are all quite badly broken and should have been upgraded long ago.
+  * Drop support for using the same loaded rsa key with multiple different
+    hash algorithms (which was broken in 0.5.0).  Right now we support
+    only `sha1' and `md5' so everyone should be using `sha1'.
+    Installations which specified `md5' anywhere may need config changes.
+
+  Major new featureset (use of which is not adviseable yet):
+  * New facilities for negotiating about the signing keys to use for
+    authentication during key setup, and selecting and using the
+    appropriate keys.  (``key-cache'/`privcache' and `peer-keys').
+    Using these new facilities for keyrollover now is in principle
+    possible but rather complex.  Further machinery is planned;
+    for now, retain your existing config which should keep working.
+    In summary:
+       - secnet: new `privcache' closure;
+       - secnet: `key-cache' and `peer-keys' keys on site closures;
+       - secnet: new file format for peer public keysets;
+       - secnet: new `make-public' config operator;
+       - make-secnet-sites `pub', `pkg', `serial', etc. keywords;
+       - make-secnet-sites --filter, --pubkeys-*, --output-version.
+
+  More minor (logging) improvements:
+  * Make stderr line buffered and log to it by default.
+  * Do not log differently with --nodetach.
+  * New `prefix' option to `logfile' closure.
+  * Tidy and simplify some messages.
+
+  Supporting changes:
+  * Many substantial internal refactorings in secnet.
+  * Many substantial internal refactorings in make-secnet-sites.
+  * make-secnet-sites option parsing totally replaced.
+  * Imported subtrees for base91-c and base91-python.
+  * New portablity code, etc.: osdep.[ch], fmemopen reimplementation.
+  * Explicitly define oddly-rotated dh padding arrangement (write_mpbin).
+
+  Build system and packaging:
+  * Do not fail to build from git when HEAD refers to a packed ref.
+  * Update to subdirmk 0.3.
+  * Many makefile fixes (esp. to clean and cdeps).
+  * configure.ac: Drop or suppress some very obsolete checks.
+  * autogen.sh: Write a comment about need for autoheader.
+  * dir-locals: Provide python-indent-offset too.
+
+  Test suite bugfixes:
+  * stest: Use stderr, not tty, for logging.
+  * stest/udp-preload.c: Fix error handling of sun_prep.
+  * stest: Fix breakage if nproc is not installed.
+
+  Test suite improvements:
+  * New tests, including tests for new features.
+  * Existing tests (especially stest) generally made more thorough.
+  * New comprehensive-test and pretest-to-tested convenience scripts.
+  * Arrangements for testing with (user-provided) old secnet.
+  * parallel-test.*: scripts to help with parallelised bisection.
+  * stest: Print a lot more output about what we are doing.
+  * stest: Better support for cwd with longish pathname.
+  * stest: More flexibility, env var hooks, etc.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Sun, 16 Feb 2020 12:48:13 +0000
+
+secnet (0.5.1) unstable; urgency=medium
 
   POTENTIALLY INCOMPATIBLE CHANGE.  Some security implications.
 
@@ -44,7 +122,7 @@ secnet (0.5.1~) unstable; urgency=medium
   * Release checklist update.
 
   documentation:
-  * Creit Mark Wooding properly in CREDITS.
+  * Credit Mark Wooding properly in CREDITS.
   * Include DEVELOPER-CERTIFICATE.
 
   tests:
@@ -52,8 +130,9 @@ secnet (0.5.1~) unstable; urgency=medium
   * Somewhat better debugging output from mtest.
   * Do not run msgcode-test except with `make fullcheck'.
   * Other minor bugfixes and improvments.
+  * stest: Suppress unhelpful -Wno-unused-result (needed for stretch).
 
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk>  Fri, 22 Nov 2019 23:13:14 +0000
 
 secnet (0.5.0) unstable; urgency=medium