chiark / gitweb /
wiringpi module in changelog
[chiark-tcl.git] / debian / rules
index a9f57a69f2a09307525d77e209e700cda25b4608..faa763a91b3e1456da41e07357b9a82e80f2e757 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 # chiark-tcl - various Tcl bindings and extensions
 #!/usr/bin/make -f
 
 # chiark-tcl - various Tcl bindings and extensions
-# Copyright 2006 Ian Jackson
+# Copyright 2006-2012 Ian Jackson
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License as
 #
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License as
@@ -14,9 +14,7 @@
 # General Public License for more details.
 #
 # You should have received a copy of the GNU General Public License
 # General Public License for more details.
 #
 # You should have received a copy of the GNU General Public License
-# along with this library; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-# 02110-1301, USA.
+# along with this library; if not, see <http://www.gnu.org/licenses/>.
 
 
 majversion=1
 
 
 majversion=1
@@ -32,10 +30,13 @@ define checkdir
        test -f hbytes/hbytes.tct
 endef
 
        test -f hbytes/hbytes.tct
 endef
 
-build:
+build: build-arch build-indep
+build-arch:
        $(checkdir)
        $(MAKE) prefix=/usr VERSION=$(majversion) TCL_VERSION=$(tclversion)
 
        $(checkdir)
        $(MAKE) prefix=/usr VERSION=$(majversion) TCL_VERSION=$(tclversion)
 
+build-indep:
+
 clean:
        $(checkdir)
        $(MAKE) clean
 clean:
        $(checkdir)
        $(MAKE) clean
@@ -50,7 +51,7 @@ binary-arch:  checkroot build
        install -d debian/$(libpackage)/usr/lib
        install -d debian/$(docpackage)/usr/share/doc/$(docpackage)
 
        install -d debian/$(libpackage)/usr/lib
        install -d debian/$(docpackage)/usr/share/doc/$(docpackage)
 
-       set -e; for f in lintian linda; do                                   \
+       set -e; for f in lintian; do                                         \
                install -d debian/$(libpackage)/usr/share/$$f/overrides;     \
                cp debian/$$f-overrides                                      \
                 debian/$(libpackage)/usr/share/$$f/overrides/$(libpackage); \
                install -d debian/$(libpackage)/usr/share/$$f/overrides;     \
                cp debian/$$f-overrides                                      \
                 debian/$(libpackage)/usr/share/$$f/overrides/$(libpackage); \